• We did not send an email asking for donations - please read this post.

I Cannot Solve The Firefox Freezing Issue In Ubuntu 20.04!

Ericmyers

New Member
Joined
Jan 9, 2020
Messages
2
Reaction score
0
Credits
21
Hello everyone. How are you? I'm posting this for the sake of my Firefox web browser in Ubuntu 20.04. Whenever I want to use the Mozilla Firefox browser on my Windows 10 PC, the Firefox freezing issue makes it very difficult to use. I don’t know why this is happening or how to fix this issue. Can anyone provide any suggestions? It would be greatly appreciated.
 


kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,277
Reaction score
1,061
Credits
9,171
I'm a little confused by your question. Are you using Firefox on windows or Ubuntu?
Often times in FF it's extensions that cause problems so disable all your extensions and add them back one at a time see if one of them causes the freeze.
 
Last edited:

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,962
Reaction score
3,606
Credits
36,165
Whenever I want to use the Mozilla Firefox browser on my Windows 10 PC, the Firefox freezing issue makes it very difficult to use.
This is a Linux forum so follow the advice of @kc1di and if that doesn't work find a Windows forum to ask your question.
 
Last edited:

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
7,368
Reaction score
6,351
Credits
59,736
I am kinda puzzled as to why they'd ask a Windows question on a Linux forum...

Trolling, or just oblivious to their surroundings?
 
OP
Ericmyers

Ericmyers

New Member
Joined
Jan 9, 2020
Messages
2
Reaction score
0
Credits
21
Thanks for replying to all. Sorry, I can't clear up the matter. Both Windows 10 and Ubuntu are already installed on the same PC. And the same issue is happening with both OSs. However, I figured out the issue. I just turned off the hardware acceleration. and the issue is gone. But, I'm not sure if it is permanent or not.
 
Last edited by a moderator:

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
7,786
Reaction score
6,611
Credits
28,653
But, I'm not sure if it is permanent or not.

I guess you'll just have to wait and see.

Your last Post came across my desk for approval because it contained a link to a site, headquartered in Attapur, Hyderabad in India.

I note that your profile says you are from USA but that your IP address is from India, perhaps Kolkata?

Any comments in that regard?

Chris Turner
wizardfromoz
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
7,368
Reaction score
6,351
Credits
59,736
Yeah, that certainly looks like a spam link/post.

This wouldn't be the first time an older account has been used to spam. I saw a couple of those fairly recently, but didn't put much thought into it at the time. I just spam cleaned them. I did kinda admire their tenacity. Like this person, their IPs came from India.
 

bob466

Well-Known Member
Joined
Oct 22, 2020
Messages
644
Reaction score
453
Credits
4,724
Confusing for sure.
t1822.gif
 

rdm

New Member
Joined
Sep 9, 2022
Messages
3
Reaction score
0
Credits
28
I'm getting the same issue on an HP All-in-One 22-c0xx running Ubuntu 20.04.1. I've tried the sudo apt update && sudo apt full-upgrade commands, but it keeps hanging.
 

arochester

Moderator
Staff member
Gold Supporter
Joined
Apr 25, 2017
Messages
1,677
Reaction score
1,339
Credits
3,385
If you start it from a Terminal, rather than the menu, what does it say? Can you Copy and Paste the result here?

Is it Firefox ESR? If it is, In the Terminal, type firefox-esr. If it isn't just try: firefox.
 

rdm

New Member
Joined
Sep 9, 2022
Messages
3
Reaction score
0
Credits
28
Interesting, it's been working most of today, and I had work to do, but here's the terminal results:

[email protected]:~$ firefox
Gtk-Message: 14:25:41.974: Failed to load module "canberra-gtk-module"
Gtk-Message: 14:25:41.976: Failed to load module "canberra-gtk-module"
ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.
Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,277
Reaction score
1,061
Credits
9,171
Try installing
Code:
sudo apt install libcanberra-gtk-module libcanberra-gtk3-module
Don't know if it will stop the freezing but It should do away with the first two error message.
 

rdm

New Member
Joined
Sep 9, 2022
Messages
3
Reaction score
0
Credits
28
thanks, but hmmm, it didn't seem to particularly like loading that module:

Setting up libcanberra-gtk0:amd64 (0.30-10ubuntu1) ...
Setting up libcanberra-gtk-module:amd64 (0.30-10ubuntu1) ...
Processing triggers for libc-bin (2.35-0ubuntu3.1) ...
[email protected]:~$ firefox
Gtk-Message: 15:01:52.734: Failed to load module "canberra-gtk-module"
Gtk-Message: 15:01:52.736: Failed to load module "canberra-gtk-module"
ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.
Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs

And . . . a solve on github - sudo apt install xdg-desktop-portal-gtk didn't do much either.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top