I can't login into my desktop since yesterday


New Member
Apr 21, 2024
Reaction score
I run my arch on gnome and was updating the system. The system froze during update, I tried waiting but nothing worked so I used the power button to turn it completely off. When I tried loging in it started giving me :- https://imagebin.ca/v/7zErQblLuBss

Now I went through guides online they said using Ctrl alt f2 etc but that didn't work. Other said to use live iso and use mount and chroot so went and did that, I couldn't do it at first and faced various problems but atlast I successfully did and one command updated the system.

mount /dev/nvme0n1p2/mnt
mount /dev/Nvme0n1p2 /mnt/boot
Pacman -Syu

I was trying to use commands to mount and chroot but I couldn't go pass the second command, idk why after trouble shooting I used this command

pacstrap /mnt base linux linux-firmware

And it triggered an update and after the update I tried
And Pacman -Syu

And rebooted and the problem is still there

This is the picture commands I did after trying again

All of this but the problem at the top still persists

I have important data on the drive, If I couldn't recover the system I would still want the data from the drive. If you know how to solve this kindly help me or help me to recover my data, thanks.

Reinstall your Nvidia drivers from a chroot.
looks like a gdm issue. it probably got borked when the updater froze. try reinstalling gdm3
sudo pacman -S gdm
and then
sudo systemctl enable gdm.service
then reboot

Members online

Latest posts