Solved I'm having issues rendering PDF files in Firefox

Solved issue

CaffeineAddict

Well-Known Member
Joined
Jan 21, 2024
Messages
713
Reaction score
460
Credits
5,888
Sample PDF file to test is below:

Rendering the same PDF when downloaded and opened with KDE's okular it renders just fine.

Here is how it renders in my Firefox v126.0 (sometimes entire PDF page is blinking and getting dark):

PDF.png
 
Last edited:


The sample opens well for me on Debian 12 FF 115.11:-

Try another PDF viewer for FF.
In the General panel, go down to the Applications section. Find Portable Document Format (PDF) in the list and click the entry to select it. Click the arrow under the Action column for the above entry and select the PDF viewer you wish to use from the drop-down menu.

It could be that the default PDF viewer isn't disabled and that's why perhaps the page is blinking or getting dark? Just a thought:-

What distro and DE are you running?
 
In the General panel, go down to the Applications section. Find Portable Document Format (PDF) in the list and click the entry to select it. Click the arrow under the Action column for the above entry and select the PDF viewer you wish to use from the drop-down menu.
Thanks, that's what I already did and set it to KDE's okular PDF viewer which works to open PDF in external program and is readable just fine, but I'd like to read PDF files in firefox.

It could be that the default PDF viewer isn't disabled and that's why perhaps the page is blinking or getting dark? Just a thought:-
Had same problem without any PDF viewers installed, when firefox was the only one set in Applications.

What distro and DE are you running?
Debian Bookworm 12.5, KDE Plasma 5.27.5
 
Opened properly etc in Brave Browser, in LM21.3

I have it set to use Document Viewer
Brave itself also opens it properly
Mullvad browser also opens correctly....using the browser itself.

And then I opened it in Mozilla Firefox 126.0....it opened perfectly...as below

1716152999745.png
 
Looks like others are having the same issue:-

I don't use snap or flatpac pkg's so if your using one of those it may be having issues.

See if it's a bug on the Debian Bug site:

Maybe @osprey will know a way around this.
 
bye bye Firefox ?
 
Sample PDF file to test is below:

Rendering the same PDF when downloaded and opened with KDE's okular it renders just fine.

Here is how it renders in my Firefox v126.0 (sometimes entire PDF page is blinking and getting dark):
Firefox 126.0 renders pdf files normally here, including that sample pdf in post #1. The firefox I use is from the tarball: firefox-126.0.tar.bz2, so it's not a flatpak or a snap or a distro repository version. That should not make a difference, but I mention it just in case.
 
I opened it in Firefox on my Android phone without any issues.

I understand that you're having trouble opening it in Firefox, correct? I've only ever used LM and <cough, cough> the Giant. In either OS, I have to right-click on the file and choose to open it with in Firefox. I assume you're probably doing this? If PDF's use to open in Firefox by default but aren't now I would guess a setting got changed somewhere. Maybe with an update or something.

But also....

I've created A LOT of PDFs and run into issues like this. In may case it didn't have anything to do with the OS. Usually the problem originated in the app I used to create the PDF. The most problematic one I've used it LibreOffice Draw. Any edits I make skew the document. The best way I've found to create PDF's is to start out in LibreOffice Write and then export it as a PDF.
 
I just opened it on my laptop with LM OS. Still no problems here.

A couple of other ideas. Try re-downloading the doc. DON'T open it with your PDF viewer. Instead just open it in Firefox. If it opens fine, the viewer you're using might alter the document in some way after it's closed. I've run into that problem too.

Try opening your document in a different viewer. If the issue persists, then I would look at the OS. My guess is an app is causing issues.
 
Sorry I keep adding to this... :)

Another thing I've run into is the default Zoom settings in Firefox. Try lowering/increasing the zoom.

If I remember something else, I'll add it. I know how frustrating these things can be.
 
Hey guys the problem was fixed somehow on it's own but I think I know what it was:
In the General panel, go down to the Applications section. Find Portable Document Format (PDF) in the list and click the entry to select it. Click the arrow under the Action column for the above entry and select the PDF viewer you wish to use from the drop-down menu.

As suggested by @Alexzee I toggled which application opens the PDF and then set back to firefox and that seemingly made it work after firefox restart.

All help of others is appreciated as well!
 
Using firefox esr 102.3 appimage on Debian 12. File rendered fine no issues.
 
Hey guys the problem was fixed somehow on it's own but I think I know what it was:


As suggested by @Alexzee I toggled which application opens the PDF and then set back to firefox and that seemingly made it work after firefox restart.

All help of others is appreciated as well!
Glad to hear it's working for you now.
Have a great rest of the week mate!
 

Members online


Top