Installing Arch Linux in VirtualBox

miche_archie

New Member
Credits
0
Dear,
I am trying to install, for the first time in my life, Arch Linux in a Virtual Machine using Virtual Box (OS host: Ubuntu). After having installed the grub (I have a laptop with BIOS and not UEFI), following the wiki at https://wiki.archlinux.org/index.php/Installation_guide , when I reboot the system, I got in a grub shell (grub >...) instead of login, and I have no idea on how to go on and solve it. Can you help me?
Thanks for your time.
 


Tolkem

Active Member
Credits
460
Dear,
I am trying to install, for the first time in my life, Arch Linux in a Virtual Machine using Virtual Box (OS host: Ubuntu). After having installed the grub (I have a laptop with BIOS and not UEFI), following the wiki at https://wiki.archlinux.org/index.php/Installation_guide , when I reboot the system, I got in a grub shell (grub >...) instead of login, and I have no idea on how to go on and solve it. Can you help me?
Thanks for your time.
Do you get any error message? This usually happens due to a wrong install, maybe you missed some step or did it in a wrong way ... Did you try booting from the fallback initramfs? At boot in grub choose advanced options for arch and select the fallback initramfs, hit enter and see if that works, if it does, then first thing you do is update & upgrade the system
Code:
sudo pacman -Syu
wait till the process is finished and reboot the VM, try and see if this time it boots from the default.

Hope this helps! :)
 

miche_archie

New Member
Credits
0
Do you get any error message? This usually happens due to a wrong install, maybe you missed some step or did it in a wrong way ... Did you try booting from the fallback initramfs? At boot in grub choose advanced options for arch and select the fallback initramfs, hit enter and see if that works, if it does, then first thing you do is update & upgrade the system
Code:
sudo pacman -Syu
wait till the process is finished and reboot the VM, try and see if this time it boots from the default.

Hope this helps! :)
Thank you @Tolkem for your support.
No, any error message, just a grub shell, as you can see in the picture attached.
Regarding the installation steps, I typed the following (for the grub installation) code:
Code:
pacman -S grub
grub-install /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg
and then:
Code:
exit
umount /mnt/home
umount /mnt
reboot
I can't choose advanced option because, at startup, the system, rapidly show me the grub shell.
Maybe because I didn't give
Code:
linux and linux-firmware
after
Code:
pacstrap /mnt base base-devel
?
 

Attachments

Tolkem

Active Member
Credits
460

miche_archie

New Member
Credits
0
@miche_archie You could read here https://www.linux.com/training-tutorials/how-rescue-non-booting-grub-2-linux/ and tried that. It explains how to boot your system from a grub shell so it might just be what you need. If you manage to finally boot into Arch, install efibootmgr
Code:
sudo pacman -S efibootmgr
I just remembered I had a similar issue in one of my VMs and installing it seems to have solved it.
Dear @Tolkem ,
I am reading and following the guide you sent me, but, when I type the ls command in the grub shell (I mean: ls (hd0,1)/), I get the message in the picture and, as you can see, something is missing respect to the message in the guide:
Code:
grub> ls (hd0,1)/
lost+found/ bin/ boot/ cdrom/ dev/ etc/ home/  lib/
lib64/ media/ mnt/ opt/ proc/ root/ run/ sbin/
srv/ sys/ tmp/ usr/ var/ vmlinuz vmlinuz.old
initrd.img initrd.img.old
The initrd.img is missing. It's really weird.
I think the problem is just that: no vmlinuz found and initrd.img too.
 

Attachments

Last edited:

Tolkem

Active Member
Credits
460
@miche_archie Like I said before, this usually happens due to a wrong install, maybe you should try and reinstall Arch, I still remember the first time I tried to install Arch in VBox, it was really frustrating and took me several attempts till I finally made it, now it's my main system :) The install process has been updated and it seems a bit easier to me, back when I tried you had to create 3/4 partitions, now you can just create 2; root and swap. Try again and maybe create snapshots of the process as you go should anything go wrong you can just revert back to some point instead of having to start from 0 again.
 

miche_archie

New Member
Credits
0
@miche_archie Like I said before, this usually happens due to a wrong install, maybe you should try and reinstall Arch, I still remember the first time I tried to install Arch in VBox, it was really frustrating and took me several attempts till I finally made it, now it's my main system :) The install process has been updated and it seems a bit easier to me, back when I tried you had to create 3/4 partitions, now you can just create 2; root and swap. Try again and maybe create snapshots of the process as you go should anything go wrong you can just revert back to some point instead of having to start from 0 again.
Do you have a good link from which I can install Arch Linux in VirtualBox? I mean, a specific one (with all steps) for VB? Thank you.
 

Tolkem

Active Member
Credits
460
Do you have a good link from which I can install Arch Linux in VirtualBox? I mean, a specific one (with all steps) for VB? Thank you.
You could try this one https://itsfoss.com/install-arch-linux/ which is basically the same thing as explained in here https://wiki.archlinux.org/index.php/Installation_guide plus a few more steps, however, like I said the process has been updated and it's a bit easier right from the wiki, also,when logged into arch live type
Code:
ls
and you'll see a install.txt file sitting on home dir, you can open it with cat or nano in case you can't open/acces your browser.
 

Tolkem

Active Member
Credits
460
Installing Arch is no different than installing any other Linux under VirtualBox.


Eh ... it is, there's no graphical installer for you click next and let it do the hard work for you.
 

dos2unix

Well-Known Member
Credits
638
Eh ... it is, there's no graphical installer for you click next and let it do the hard work for you.
Agreed, what I meant was... setting up the VM to install "Arch" Linux is nor different than setting up the VM for any other Linux. Once you get the VM booted into your distro, then the steps might be different.
 

Tolkem

Active Member
Credits
460
Agreed, what I meant was... setting up the VM to install "Arch" Linux is nor different than setting up the VM for any other Linux. Once you get the VM booted into your distro, then the steps might be different.
Ahh ... yeah, that's right, however, his issue seems to be that after installing Arch it won't boot properly rather than the VM configuration which is a different topic.
 

miche_archie

New Member
Credits
0
You could try this one https://itsfoss.com/install-arch-linux/ which is basically the same thing as explained in here https://wiki.archlinux.org/index.php/Installation_guide plus a few more steps, however, like I said the process has been updated and it's a bit easier right from the wiki, also,when logged into arch live type
Code:
ls
and you'll see a install.txt file sitting on home dir, you can open it with cat or nano in case you can't open/acces your browser.
Thanks to your link I was able to boot Arch Linux and installed gnome DE. Now, I don't know why, when I run the browser or the terminal (to update the system), the system freezes and reboot, continuously. I am getting crazy. It's really weird.
 

Tolkem

Active Member
Credits
460
Thanks to your link I was able to boot Arch Linux and installed gnome DE. Now, I don't know why, when I run the browser or the terminal (to update the system), the system freezes and reboot, continuously. I am getting crazy. It's really weird.
That is weird indeed. What's the VM set up? RAM, CPUs, graphics memory ... There's a neat trick to increase the maximum memory for graphics;
1. Select the Arch VM from VBox's main window and click on settings
2. On the settings window select display >> screen tab, move the slider for video memory right to the end up to 128mb, tick the 3d accelaration box and click on OK.



3. Open the VM settings again, go to dispay >> screen tab and move the slider for the monitor count to the end, you'll see now that you can increase the video memory up to 256mb, do that and click on OK.



4. Select the VM, open settings, go to display >> screen tab, move the monitor count slider back to 1 monitor and click on OK.



Now start the VM and you should see a bit of an improvement and maybe, hopefully the issue gets fixed as well. :)
 

miche_archie

New Member
Credits
0
@Tolkem I tried to change setting, as you suggested to me, but, increasing Video Memory until 256MB results in a critical error when I run the Arch VM, so I got back to 128 MB, and I was able to launch Arch Linux. Oddly, if I launch epiphany browser in a terminal, the app starts regularly (and the system doesn't freeze), but I get a warning:

GDK is not able to create a GL context, falling back to glReadPixels (slow!)
Even after the installation of chromium, I get the following error messages:
ERROR: edid_parser.cc (102) Too short EDID data: manufacturer id [] : ERROR: gl_surface_presentation_helper.cc (259) GetVSyncParametersIfAvailable () failed for 1 times!
and, obviously, chromium doesn't run. The good news is that the system doesn't reboot continuosly just after opening a windows or a terminal.
 


Members online


Latest posts

Top