Intel UHD 750 resolution problem

zonley

New Member
Credits
65
Hi. Recently i have bought new pc, with intel i5-11500 and their integrated graphics card. It works properly on windows but i have a problem with drivers on linux - it does not depend on distribution, i have checked both on fedora and ubuntu(mint). I have been trying to resolve this problem on my own but i have no more ideas. So basically I have no choice on resolution - the default and unchangeable is 1024x768. I tried to add something in grub options just as i saw in the internet but maybe I do it wrong? Please give me some help, cuz its really annoying working on such resulution.
 

Attachments



brickwizard

Well-Known Member
Credits
6,924
Welcome to the forums.. @zonley
what is the machine [make and full model number]
what distribution are you using? [name and build number]
If you have inxi installed
run from a terminal inxi -G [inxispace-G].. and past the results back

Bwiz
 

zonley

New Member
Credits
65
Hi, thank you for your respond.
I can give specification, i have bought computer components seperatly:

Motherboard: Gigabyte B560M DS3H
Processor: Intel Core i5-11500
Disc: Crucial 500GB M.2 PCIe NVMe P5
RAM: Crucial 16GB (2x8GB) 3200MHz CL16 Ballistix Black

My current linux distribution is Linux Mint 20.2 Cinnamon (but I'm open to other distributions, i just really need normal resolution to work)
 

Attachments

f33dm3bits

Gold Member
Gold Supporter
Credits
25,777
Try installing the xserver-xorg-video-intel driver, open a terminal and run the following.
Code:
sudo apt install xserver-xorg-video-intel
Then reboot and show the output of inxi -G again as text output please.
 

zonley

New Member
Credits
65
This version is already the newest version, no change in the inxi -G

"
xserver-xorg-video-intel is already the newest version (2:2.99.917+git20200226-1).
"

Text output of inxi -G
Graphics:
Device-1: Intel driver: N/A
Display: x11 server: X.Org 1.20.11 driver: fbdev
unloaded: modesetting,vesa resolution: 1024x768~76Hz
OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.0.3
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,777
Can you share the output of the following.
Code:
dpkg --list | grep xorg
 

brickwizard

Well-Known Member
Credits
6,924
Device-1: Intel driver: N/A... this is sugesting no intel driver for this gpu is installed..

this what my inxi-G shows for I5 4th gen...... [this machine also has mint 20.2]
Graphics:
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
driver: i915 v: kernel
 

zonley

New Member
Credits
65
Yes, this is the problem. I have tried to fix it on my own but I gave up - I have wasted few hours and got no results. So do you have any idea how I can get a driver? I found information that i should add i915.force_probe=4c8a" but this didnt work.. maybe i wrote it wrong? Can you take a look? Its in first post
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,777
And what output do you get when you run the following?
Code:
dmesg | grep firmware
 

zonley

New Member
Credits
65
And what output do you get when you run the following?
Code:
dmesg | grep firmware
I dont get anything.


Can you share the output of the following.
Code:
dpkg --list | grep xorg
ii python3-xkit 0.5.0ubuntu4 all library for the manipulation of xorg.conf files (Python 3)
ii xorg 1:7.7+19ubuntu14 amd64 X.Org X Window System
ii xorg-docs-core 1:1.7.1-1.1 all Core documentation for the X.org X Window System
ii xserver-xorg 1:7.7+19ubuntu14 amd64 X.Org X server
ii xserver-xorg-core 2:1.20.11-1ubuntu1~20.04.2 amd64 Xorg X server - core server
ii xserver-xorg-input-all 1:7.7+19ubuntu14 amd64 X.Org X server -- input driver metapackage
ii xserver-xorg-input-libinput 0.29.0-1 amd64 X.Org X server -- libinput input driver
ii xserver-xorg-input-wacom 1:0.39.0-0ubuntu1 amd64 X.Org X server -- Wacom input driver
ii xserver-xorg-legacy 2:1.20.11-1ubuntu1~20.04.2 amd64 setuid root Xorg server wrapper
ii xserver-xorg-video-all 1:7.7+19ubuntu14 amd64 X.Org X server -- output driver metapackage
ii xserver-xorg-video-amdgpu 19.1.0-1 amd64 X.Org X server -- AMDGPU display driver
ii xserver-xorg-video-ati 1:19.1.0-1 amd64 X.Org X server -- AMD/ATI display driver wrapper
ii xserver-xorg-video-fbdev 1:0.5.0-1ubuntu1 amd64 X.Org X server -- fbdev display driver
ii xserver-xorg-video-intel 2:2.99.917+git20200226-1 amd64 X.Org X server -- Intel i8xx, i9xx display driver
ii xserver-xorg-video-nouveau 1:1.0.16-1 amd64 X.Org X server -- Nouveau display driver
ii xserver-xorg-video-qxl 0.1.5+git20200331-1 amd64 X.Org X server -- QXL display driver
ii xserver-xorg-video-radeon 1:19.1.0-1 amd64 X.Org X server -- AMD/ATI Radeon display driver
ii xserver-xorg-video-vesa 1:2.4.0-2 amd64 X.Org X server -- VESA display driver
ii xserver-xorg-video-vmware 1:13.3.0-3 amd64 X.Org X server -- VMware display driver

Of course.
 

Attachments

f33dm3bits

Gold Member
Gold Supporter
Credits
25,777
Can you run xrandr and share the output.
Code:
xrandr
 

zonley

New Member
Credits
65
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
1024x768 76.00*
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,777
Can you share the output of the following.
Code:
dmesg | grep i915
 

zonley

New Member
Credits
65
[ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-5.4.0-88-generic root=UUID=642a547e-7fe9-41aa-8309-4c360c23e1ad ro ... quiet i915.force_probe=4c8a quiet splash
[ 0.051185] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.4.0-88-generic root=UUID=642a547e-7fe9-41aa-8309-4c360c23e1ad ro ... quiet i915.force_probe=4c8a quiet splash
[ 68.852399] snd_hda_codec_hdmi hdaudioC0D2: No i915 binding for Intel HDMI/DP codec
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,777
Can you put comment in front of the following line in /etc/default/grub so that it looks like this.
Code:
#intel_pstate=disable
And you can remove the line to grub you added which didn't work, so remove this.
Code:
i915.force_probe=4c8a
Then update grub and reboot.
Code:
sudo update-grub
sudo reboot
Then share the output of inxi -G and xrandr again?
 

zonley

New Member
Credits
65
Okay, now my /etc/default/grub file looks like this:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="... quiet"
#intel_pstate=disable
# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

And nothing changed:

Graphics:
Device-1: Intel driver: N/A
Display: x11 server: X.Org 1.20.11 driver: fbdev
unloaded: modesetting,vesa resolution: 1024x768~76Hz
OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.0.3

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
1024x768 76.00*
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,777
This won't change anything but only set it back to default.
Change the following line from this.
Code:
GRUB_CMDLINE_LINUX="... quiet"
To this.
Code:
GRUB_CMDLINE_LINUX=""
Then run sudo update-grub and reboot
Code:
inxi -G
xrandr
 

zonley

New Member
Credits
65
again the same

Graphics:
Device-1: Intel driver: N/A
Display: x11 server: X.Org 1.20.11 driver: fbdev
unloaded: modesetting,vesa resolution: 1024x768~76Hz
OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.0.3
[email protected]:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
1024x768 76.00*
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top