Internal Mic is not working using linux

baezacaljo

New Member
Credits
170
Can you share the output of:
Code:
arecord -l
pacmd list-cards
And also try these steps: Pulseaudio Uses wrong microphone
using: arecord -l

Code:
**** List of CAPTURE Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: AD1984A Analog [AD1984A Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
using

pacmd list-cards

Code:
1 card(s) available.
    index: 0
    name: <alsa_card.pci-0000_00_14.2>
    driver: <module-alsa-card.c>
    owner module: 23
    properties:
        alsa.card = "0"
        alsa.card_name = "HDA ATI SB"
        alsa.long_card_name = "HDA ATI SB at 0xfe7f4000 irq 16"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:14.2"
        sysfs.path = "/devices/pci0000:00/0000:00:14.2/sound/card0"
        device.bus = "pci"
        device.vendor.id = "1002"
        device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
        device.product.id = "4383"
        device.product.name = "SBx00 Azalia (Intel HDA)"
        device.form_factor = "internal"
        device.string = "0"
        device.description = "Built-in Audio"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    profiles:
        input:analog-stereo: Analog Stereo Input (priority 65, available: no)
        output:analog-stereo: Analog Stereo Output (priority 6500, available: unknown)
        output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: no)
        output:iec958-stereo: Digital Stereo (IEC958) Output (priority 5500, available: unknown)
        output:iec958-stereo+input:analog-stereo: Digital Stereo (IEC958) Output + Analog Stereo Input (priority 5565, available: no)
        off: Off (priority 0, available: unknown)
    active profile: <output:analog-stereo>
    sinks:
        alsa_output.pci-0000_00_14.2.analog-stereo/#1: Built-in Audio Analog Stereo
    sources:
        alsa_output.pci-0000_00_14.2.analog-stereo.monitor/#1: Monitor of Built-in Audio Analog Stereo
    ports:
        analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
            properties:
                
        analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: no)
            properties:
                
        analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
            properties:
                device.icon_name = "audio-speakers"
        analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "audio-headphones"
        iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
            properties:
After i applied the steps Pulseaudio Uses wrong microphone.
and we get:

pressing_F5.png



if i change to capture option (pressing F4).
we get:
pressing_F4.png
 


f33dm3bits

Gold Member
Gold Supporter
Credits
25,700
I was a head of myself that's why I removed it from my previous post. Let's try this first, add the bottom of this file(/etc/pulse/default.pa), add the following:
Code:
load-module module-alsa-source device=hw:0,0
Reboot your system, then see what devices are in your audio mixer under "Input Devices" and "Configuration".
 

baezacaljo

New Member
Credits
170
I was a head of myself that's why I removed it from my previous post. Let's try this first, add the bottom of this file(/etc/pulse/default.pa), add the following:
Code:
load-module module-alsa-source device=hw:0,0
Reboot your system, then see what devices are in your audio mixer under "Input Devices" and "Configuration".
input device

input.png


configuration

configuration.png
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,700
I'm running out of ideas here, but can you share the output of these commands one more time.
Code:
arecord -l
pacmd list-cards
pacmd list-sinks
 

baezacaljo

New Member
Credits
170
I'm running out of ideas here, but can you share the output of these commands one more time.
Code:
arecord -l
pacmd list-cards
pacmd list-sinks
arecord -l

Code:
**** List of CAPTURE Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: AD1984A Analog [AD1984A Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
pacmd -list-cards

Code:
1 card(s) available.
    index: 0
    name: <alsa_card.pci-0000_00_14.2>
    driver: <module-alsa-card.c>
    owner module: 27
    properties:
        alsa.card = "0"
        alsa.card_name = "HDA ATI SB"
        alsa.long_card_name = "HDA ATI SB at 0xfe7f4000 irq 16"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:14.2"
        sysfs.path = "/devices/pci0000:00/0000:00:14.2/sound/card0"
        device.bus = "pci"
        device.vendor.id = "1002"
        device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
        device.product.id = "4383"
        device.product.name = "SBx00 Azalia (Intel HDA)"
        device.form_factor = "internal"
        device.string = "0"
        device.description = "Built-in Audio"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    profiles:
        input:analog-stereo: Analog Stereo Input (priority 65, available: no)
        output:analog-stereo: Analog Stereo Output (priority 6500, available: unknown)
        output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: no)
        output:iec958-stereo: Digital Stereo (IEC958) Output (priority 5500, available: unknown)
        output:iec958-stereo+input:analog-stereo: Digital Stereo (IEC958) Output + Analog Stereo Input (priority 5565, available: no)
        off: Off (priority 0, available: unknown)
    active profile: <output:analog-stereo>
    sinks:
        alsa_output.pci-0000_00_14.2.analog-stereo/#1: Built-in Audio Analog Stereo
    sources:
        alsa_output.pci-0000_00_14.2.analog-stereo.monitor/#2: Monitor of Built-in Audio Analog Stereo
    ports:
        analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
            properties:
                
        analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: no)
            properties:
                
        analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
            properties:
                device.icon_name = "audio-speakers"
        analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "audio-headphones"
        iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
            properties:
pacmd -list-sinks

Code:
1 sink(s) available.
  * index: 1
    name: <alsa_output.pci-0000_00_14.2.analog-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE
    priority: 9039
    volume: front-left: 30835 /  47% / -19.65 dB,   front-right: 30834 /  47% / -19.65 dB
            balance -0.00
    base volume: 65536 / 100% / 0.00 dB
    volume steps: 65537
    muted: no
    current latency: 0.00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 2
    sample spec: s16le 2ch 44100Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 0
    configured latency: 0.00 ms; range is 0.50 .. 1999.82 ms
    card: 0 <alsa_card.pci-0000_00_14.2>
    module: 27
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "AD1984A Analog"
        alsa.id = "AD1984A Analog"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "0"
        alsa.card_name = "HDA ATI SB"
        alsa.long_card_name = "HDA ATI SB at 0xfe7f4000 irq 16"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:14.2"
        sysfs.path = "/devices/pci0000:00/0000:00:14.2/sound/card0"
        device.bus = "pci"
        device.vendor.id = "1002"
        device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
        device.product.id = "4383"
        device.product.name = "SBx00 Azalia (Intel HDA)"
        device.form_factor = "internal"
        device.string = "front:0"
        device.buffering.buffer_size = "352768"
        device.buffering.fragment_size = "176384"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analog Stereo"
        device.description = "Built-in Audio Analog Stereo"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: no)
            properties:
                
        analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
            properties:
                device.icon_name = "audio-speakers"
        analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "audio-headphones"
    active port: <analog-output-speaker>
But one of my doubt arises.

Look the computer have and input to plug headphones and above of it also appears and input for microphone, both of them jack 3.5.

Therefore what i did was to plug two earphones. one for the headphones and the other for the microphone. and the result was this.

obviously those plugged in the earphones worked as earphones (output device). And those plugged in as microphone worked work as microphone, what i mean is this. how come? earphones working as a microphone?. (they do not have microphone).

Therefore i went to the store and i bought an small microphone jack 3.5 (those that have a clip and you can hang it on your clothes while you are talking). when i plugged it, nothing happens.

is quite strange that using two earphones one of them work as a microphone and the other one as a headphone.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
25,700
You can remove the following from the file(/etc/pulse/default.pa)and then reboot your machine since that didn't make a difference.
Code:
load-module module-alsa-source device=hw:0,0
For your internal mic I have no more ideas, since I don't have the same setup it's hard to have any further advice and things to to try. I just plugged in my own headset which uses 3.5 jack and it works but I had to play around with some settings, let's try your 3.5 jack microphone again:
1. Plug it in
2. Open Audio mixer
3. Go to "Configuration"
4. Then under "Built-in Audio" select: "Analog Stereo Duplex"
5. Go to "Input Devices" and under Built-in Audio Analog Stereo": Then pull the little round slider to about 75-80%"
6. Then in your voicechat program(Skype, Zoom, teams etc): Configure your Input and Output Audio settings to: Built-in Audio Analog Stereo.

If that doesn't work play around with these settings until you get it to work because the mic functions seems to work as you said you had your second headset acting/working as a microphone. Also you can also try installing pavucontrol and pavucontrol-qt, then launch it through the menu.
 
Last edited:

baezacaljo

New Member
Credits
170
You can remove the following from the file(/etc/pulse/default.pa)and then reboot your machine since that didn't make a difference.
Code:
load-module module-alsa-source device=hw:0,0
For your internal mic I have no more ideas, since I don't have the same setup it's hard to have any further advice and things to to try. I just plugged in my own headset which uses 3.5 jack and it works but I had to play around with some settings, let's try your 3.5 jack microphone again:
1. Plug it in
2. Open Audio mixer
3. Go to "Configuration"
4. Then under "Built-in Audio" select: "Analog Stereo Duplex"
5. Go to "Input Devices" and under Built-in Audio Analog Stereo": Then pull the little round slider to about 75-80%"
6. Then in your voicechat program(Skype, Zoom, teams etc): Configure your Input and Output Audio settings to: Built-in Audio Analog Stereo.

If that doesn't work play around with these settings until you get it to work because the mic functions seems to work as you said you had your second headset acting/working as a microphone. Also you can also try installing pavucontrol and pavucontrol-qt, then launch it through the menu.

thank you very much for your help.

ill start playing with it, checking if the external microphone works. a i mentioned before it recognizes it, but the bar below the round slider, does not move when i talk, only moves A LOT when i plug it and unplug it.

Anyways ill start checking it.
thanks.
 

Condobloke

Well-Known Member
Credits
16,044
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Latest posts

Top