Issues with Arduino IDE

Roy J. Tellason

New Member
Jan 10, 2021
Reaction score
I started fooling around with some arduino stuff last year. I installed the arduino IDE package from the Debian repositories, and it pretty much just worked, for the most part. Recently I acquired some ESP32 boards that I'd like to play with, and the first thing they tell you to do (in multiple places on the 'net) is to put an entry right at the end of the File->Preferences option. Only I didn't have that field to enter anything into there.

A bit of further research showed that this was a *real* early version of that software, and that it hadn't been updated since 2014! (And what's up with that?) So I removed it and then installed the latest directly from, version 1.8.13 it seems. This allowed me to put the required info in there and then load some stuff up for the ESP32. Unfortunately the choice for serial ports did NOT include /dev/ttyUSB0, which is what I had been using before, and which I even tried inserting manually into my preferences.txt file.

Perusing other threads in here I saw a suggestion in one to try lsusb, which did not show me the ESP32 board that I had plugged in. When I grabbed a Nano out of my box of arduino stuff and plugged _it_ in I saw another entry appear, and sure enough, /dev/ttyUSB0 now shows up in my files listing, where it didn't before. I had no idea that this was loading (and apparently unloading) dynamically.

I modified the blink sketch that was on the nano to see that things were working properly, and they were. The system is apparently NOT seeing the ESP32 board, though. I get a power LED lit on the board and that's it.

$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online