Solved Kali linux installation

Solved issue


New Member
Jun 13, 2024
Reaction score
I am using a asus zephyrus g14 laptop. I installed the latest kali version as a host OS(NOT DUAL Booted) instead of win.

Its is giving this error and screen is stuck here.

amdgpu 0000:04:00.0: [drm] fb0: amdgpudrmfb frame buffer

Can someone guide me through this?


  • 20240613_124052.jpg
    6.1 MB · Views: 66

If the machine doesn't have the package: firmware-amd-graphics, installed, perhaps install that, reboot and see if it makes a difference.
I am not able to get the terminal this OS is not fully the start itself i am getting this error.
Try pressing ctrl+alt+f3, that should give you a tty where you can login if the system is far enough into the boot process. Other wise you will have to boot into rescue mode or boot from a live installation media, mount your filesystem and chroot and finally install the package from there.
Probably need to add "nomodeset" to the startup

Hold down the shift key when booting starts.
You will then get a grub console mode menu. The top option should be selected. Press 'e' key to edit that line.
Scroll down to the "Linux /boot/vmlinuz- your kernel-root=UUID.." line. That is the line that tells Grub which kernel to boot with and the parameters to be passed to the kernel when it boots are placed at the end of this line.
Press 'e' key again to edit this line.
Move to the end of the line to the text that says "quiet splash" it may just say "quiet" and then enter "nomodeset" after the word splash and before " mark ensuring there is a space between the new option and any other option.
It should look like "quiet splash nomodeset"
Once you have added the parameter, press Enter to accept the editing.
Then press 'b' to boot using that kernel and those parameters.

If it boot normally you can make it permanent by
adding this option to /etc/default/grub

sudo texteditor /etc/default/grub

where it says "texteditor" change that name of your text editor you are currently using (i.e. nano, gedit, mousepad, etc)

and then add nomodeset to GRUB_CMDLINE_LINUX_DEFAULT: So it should look something like this

GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

And then save by hitting Ctrl+O, then exit nano with Ctrl+X, then simply run:

sudo update-grub

Staff online

Members online

Latest posts