Kali Linux: No Sound Failed to connect to bus: No medium found

makt

New Member
Joined
Apr 11, 2023
Messages
2
Reaction score
0
Credits
29
I have tried following one after one

nano /etc/pulse/client.conf
in the editor I have modified ; autospawn = yes

then next step done is

nano /etc/systemd/system/pulseaudio.service

added couple of lines

[Unit]
Description=PulseAudio system server

[Service]
Type=notify
ExecStart=pulseaudio --daemonize=no --system --realtime --log-target=journal

[Install]
WantedBy=multi-user.target

executing following line

sudo systemctl --user start pulseaudio.socket

it returns me

Failed to connect to bus: No medium found


I did also check some options like

/etc/default/grub to make sure it is not blocked by grub while booting
I add GRUB_CMDLINE_LINUX_DEFAULT="quiet snd_hda_intel.dmic_detect=0"

but yes pipewire-pulse also installed
out put:

sudo apt list --installed | grep pipewire-pulse

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

pipewire-pulse/kali-rolling,now 0.3.65-3 amd64 [installed]

I did uninstall it and rebooted pc to see whats happened , nothing changed

Finally, need assistance to get my system audio output sound back, Thanks in Advance
 
Last edited:


Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
3,385
Reaction score
1,753
Credits
19,661
Looks like pipewire-pulse should be removed.

Code:
If this package is installed, we will want to uninstall it and then reboot:

kali@kali:~$ sudo apt purge --autoremove pipewire-pulse
[...]
kali@kali:~$
kali@kali:~$ sudo reboot


Try this command as root:

Code:
pulseaudio -D


If that fails check if the sound is disabled and enable it.

More fixes for sound:

 
OP
M

makt

New Member
Joined
Apr 11, 2023
Messages
2
Reaction score
0
Credits
29
Looks like pipewire-pulse should be removed.

Code:
If this package is installed, we will want to uninstall it and then reboot:

kali@kali:~$ sudo apt purge --autoremove pipewire-pulse
[...]
kali@kali:~$
kali@kali:~$ sudo reboot


Try this command as root:

Code:
pulseaudio -D


If that fails check if the sound is disabled and enable it.

More fixes for sound:

First step already done,

I have tried pulseaudio -D and so on but problem is still remaining
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
4,940
Reaction score
3,307
Credits
36,762

TuxBot

Well-Known Member
Staff member
Joined
Mar 26, 2023
Messages
1,016
Reaction score
205
Credits
12,608
@TuxBot any ideas on @makt first post
It seems like you have already tried some of the common solutions for audio issues in Kali Linux. Another solution that you could try is to reload the ALSA sound driver by running the following command:

Code:
sudo alsa force-reload

If that doesn't work, you could try resetting the PulseAudio configuration files by running the following commands:

Code:
rm -r ~/.pulse*
sudo rm -r /etc/pulse

Then, reboot your system and see if the audio is working.

If none of these solutions work, you may want to check if any hardware connected to your computer is causing the issue. Try playing audio through a different output, such as headphones or external speakers, if possible.

Let me know if this helps, or if you have any other questions.
 

Members online


Top