KDE Programs Solved

OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,918
Reaction score
1,466
Credits
16,280
typo there.

Do you still have an /etc/X11/xinit/xinitrc ?

If not, you may have to copy it back again.

I was simply trying to answer your question as to whether to us

mv

or not, but perhaps I confused you.

So along the lines of what Jas was saying, and with now knowing your userid



My suggestion would read as

Code:
sudo cp /etc/X11/xinit/xinitrc /home/alex/.xinitrc

Wiz
Yes, I still have /etc/X11/xinit/xinitrc -:)
 


OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,918
Reaction score
1,466
Credits
16,280
I used the mv cmd to move xinitrc in my home directory to .xinitrc and now that file is not in the home directory.
Did something wrong I think.

Tried 3 times to copy the file again.
Using
cp /etc/X11/xinit/xinitrc ~/.xinitrc

I don't see xinitrc in the home directory--
When I used the mv cmd I ran this:
Code:
mv xinitrc .xinitrc2

Code:
bash-5.1$ cp /etc/X11/xinit/xinitrc ~/.xinitrc
bash-5.1$ ls
Books  Desktop      Downloads  Pictures  Public      Slackware.odt  Templates
CMD'S  Documents  Music      Programs  Slackware  Slackware~     Videos
bash-5.1$

Tried coping that file as root and it still did not show in the /home directory.
Trying to give you as much info as I can.
 
Last edited:
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,918
Reaction score
1,466
Credits
16,280
Running ls -la was helpful and I can see .xinitrc in the output.

Code:
-rwxr-xr-x  1 alex users   886 Feb  3 23:58 .xinitrc
-rwxr-xr-x  1 alex users   886 Feb  2 16:26 .xinitrc2

Not sure how to fix this, ideas please.
 

JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,704
Reaction score
2,471
Credits
13,677
Running ls -la was helpful and I can see .xinitrc in the output.

Code:
-rwxr-xr-x  1 alex users   886 Feb  3 23:58 .xinitrc
-rwxr-xr-x  1 alex users   886 Feb  2 16:26 .xinitrc2

Not sure how to fix this, ideas please.
Nothing to fix. .xinitrc is a hidden config file. Any file that has a name that starts with a . is a hidden file.

You can see it if you run any ls command that includes the -a flag.
E.g.
Bash:
ls -al

What the system will do on login is - if .xinitrc exists, it runs whatever is in there. Otherwise it uses the default one in /etc/X11/….

If you have your .xinitrc in place, then you should be good to go. The next time you log in, your .xinitrc will be ran.
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,918
Reaction score
1,466
Credits
16,280
Nothing to fix. .xinitrc is a hidden config file. Any file that has a name that starts with a . is a hidden file.

You can see it if you run any ls command that includes the -a flag.
E.g.
Bash:
ls -al

What the system will do on login is - if .xinitrc exists, it runs whatever is in there. Otherwise it uses the default one in /etc/X11/….

If you have your .xinitrc in place, then you should be good to go. The next time you log in, your .xinitrc will be ran.
That makes sense.
I haven't edited that file with the argument tho.

I understand how to use nano or vim to add the argument to the xinitrc file.
How do I find the file to edit it?
 

JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,704
Reaction score
2,471
Credits
13,677
That makes sense.
I haven't edited that file with the argument tho.

I understand how to use nano or vim to add the argument to the xinitrc file.
How do I find the file to edit it?
You know the file is there. You copied it from /etc/X11/…. to your home directory and named it .xinitrc.

To edit it, the quickest way would be to use a terminal based text editor (vim, eMacs, nano, joe, etc).
e.g.
Bash:
nano ~/.xinitrc
If you use a GUI editor, then you could use a text style launcher (similar to the windows ‘run’ dialog), if your distribution/desktop has one. That will pop up a dialog asking what you want to run.
So just enter the name of the editor and the name of the file:
e.g.
Bash:
leafpad ~/.xinitrc

Or if you open your editor graphically…. I can’t remember how you see hidden files offhand. I spend so much time in the terminal, it’s ridiculous.
But offhand, in the file->open dialog, you probably just need to use the file-type combo and set it to *.* in order to see all files, including hidden files.
Or there might be a checkbox somewhere to view hidden files. IDK. Like I say, I spend 99% of my time in the terminal!

Or just type the path/name of the file in the filename combo/control.
e.g. ~/.xinitrc
 
Last edited:
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,918
Reaction score
1,466
Credits
16,280
Ok this is really weird Jas--

I opened .xinitrc as root in nano added the export "QT_QPA_PLATFORMTHEME=qt5ct" saved and exited nano.
Rebooted-
When I checked on what I did strangely what I added does not appear!

***When I moved .xinitrc I renamed it .xinitrc2.*****

IS that why editing .xinitrc isn't working?

See screenshots:

Edit xinitrc.png


After reboot:

After Edit.png
 
Last edited:
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,918
Reaction score
1,466
Credits
16,280
I know what you mean, I spend a lot of time in the terminal as well.-:)
Mostly running build scripts waiting for them to finish so I can install dependencies and other cool programs.

Slackware doesn't perform dependency resolution so depending on the program I'd like to install it can be really interesting in the cmd-line. Verifying each pkg to ensure it hasn't been compromised is quite the task too; if there are a lot of dependencies that have to be installed first before I get to the main pkg, YAY! LOL!

When, with your help, the .xinitrc is as it should be with the environment set I'm planning on learning Python.
Read the whole Python book a few years ago but didn't use it enough for it to stick.
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,918
Reaction score
1,466
Credits
16,280
Ok so when I view the .xinitrc file as root the argument that I added to the file is there.
However, when I view the file with the cat cmd the argument is not in the file.

Is this normal? @ JasKinasis?

All of my KDE applications are still a blinding white when I launch them.
 

JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,704
Reaction score
2,471
Credits
13,677
I see what's going on.... ::facepalm::
If you take a look at your first screenshot in post #27 above - the file you have open is /root/.xinitrc!!

So what happened there is:
Because you used sudo when you copied the xinitrc file from /etc/X11/xinit/xinitrc to ~/.xinitrc - you were acting as root, so it copied the file to the root users home directory at /root/.xinitrc instead of /home/alex/.xinitrc.

In my first post, I recommended copying the file using cp and I deliberately made no mention of using sudo because it was absolutely not necessary to do so.

@wizardfromoz muddied the waters by recommending using sudo and I responded with a long post on why using sudo was a terrible idea in this instance. (and it turned out to be a slightly worse idea than I actually thought it was!)

With your later post, when you said you couldn't find .xinitrc, I just assumed you didn't know that you were dealing with a hidden config file.
However, I'd actually forgotten that if you use the ~ shortcut when logged in as root, or using sudo, it expands to /root/. So if you used @wizardfromoz 's sudo cp suggestion, then yes - it all makes sense now. You copied the .xinitrc file as root to roots home at /root/, NOT to your personal directory. Which is why it was not there!
And when you used sudo nano ~/.xinitrc you ended up opening the copy of .xinitrc that you accidentally copied to /root/! Ha ha!

So I will say it one, hopefully final time:
Whilst logged in as a normal user NOT ROOT and definitely NOT using sudo - copy the fallack xinitrc file to your home directory, as I originally recommended.
e.g.
Bash:
cp /etc/X11/xinit/xinitrc ~/.xinitrc
And then make your edits.
Bash:
nano ~/.xinitrc

Or - Alternatively, because you've already made the changes to the version in roots home directory - you could use sudo mv to move the file from /root/ to /home/yourusername/ and then use sudo chown to give you ownership of the file.
e.g.
Bash:
sudo mv /root/.xinitrc /home/alex/.xinitrc
sudo chown alex:alex /home/alex/.xinitrc
That will move your edited .xinitrc from /root/ to /home/alex/

Pick one of those two solutions and that should fix things!
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
8,628
Reaction score
7,587
Credits
35,291
@wizardfromoz muddied the waters by recommending using sudo and I responded with a long post on why using sudo was a terrible idea in this instance. (and it turned out to be a slightly worse idea than I actually thought it was!)

Oops :oops: - just call me Muddy Waters, Jas, My bad.

Wiz
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,918
Reaction score
1,466
Credits
16,280
Thanks Jaskinasis!

It's early in the morning and I have a few pressing matters/errands to run.
Once that's done I'll follow your instructions in post #30 later on in the day and let you know how it went.

Reminder:
*****I have PTSD and am easily confused sometimes*****
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,918
Reaction score
1,466
Credits
16,280
I can boot into either the KDE Plasma 5 DE or XFCE with this Slackware 15 install.
Both run great!

Perhaps I'm missing some other pkg's to give me the ability to change the backgrounds of my KDE app's?
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,918
Reaction score
1,466
Credits
16,280
When booted into the KDE Plasma DE all of my KDE app's are dark, YAY!
Kalzium in KDE.png

However when I am booted into XFCE all of my KDE app's are blinding white-kills my eyes!

How do I make these KDE apps in XFCE display like they do in the KDE DE?
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,918
Reaction score
1,466
Credits
16,280
With KDE Plasma I can select qt5ct style and it applied:-
KDE Setting QT.png


With XFCE I can add the qt5ct style but don't know how?
Any ideas?

Appearance Add.png
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,918
Reaction score
1,466
Credits
16,280
It's driving me nuts, I'm so close and yet don't get how to add the 'qt5ct-style theme' to the directory so it can be applied!

Code:
bash-5.1$ cd  /usr/share/plasma/desktoptheme/
bash-5.1$ ls
air  breeze-dark  breeze-light    default  oxygen
bash-5.1$

Another path is:
Code:
 ~/. local/share/plasma/desktoptheme/

Code:
bash-5.1$  ~/. local/share/plasma/desktoptheme/
bash: /home/alex/.: Is a directory

Code:
bash-5.1$ ls /usr/share/themes
Adwaita       Default              Greybird-bright           Moheli
Adwaita-dark  Default-hdpi          Greybird-compact           Raleigh
Breeze          Default-xhdpi          Greybird-dark           Retro
Breeze-Dark   Emacs              Greybird-dark-accessibility  Smoke
Bright          Greybird              HighContrast           ZOMG-PONIES!
Daloa          Greybird-accessibility  Kokodi               oxygen-gtk
bash-5.1$
 
Last edited:

JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,704
Reaction score
2,471
Credits
13,677
Hmmm, I'm not sure what to suggest offhand.
For me, with w3m, I just had qt5ct installed, I set the environment variables (I haven't fired up my laptop, to see where I'd actually put the settings yet) and all I had to do was set the theme in qt5ct and it just worked in any KDE/QT applications I used!

Maybe try setting this option too?
export KDE_FULL_SESSION=true

Other than that, I haven't used a full desktop environment for years, so maybe there are some environment settings in XFCE that are overriding, or conflicting with the qt5ct settings.... I don't know what to suggest ATM.

The next time I'm on my laptop, I'll try re-installing qt5ct and Dolphin (which wouldn't run properly at all without qt5ct )and get the environment variables set up again and I'll see what happens!
 

JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,704
Reaction score
2,471
Credits
13,677
Aha - a quick bit of duckduckgo-fu yielded this:

That looks like it should help.
Oh, and after all of that - it seems that .xinitrc isn't the place to be putting those KDE environment variables.
It turns out that ~/.profile was the correct place to put those settings. So my initial post about the environment variables was actually correct.... Go figure?!

So perhaps try creating a .profile file in your home directory and put the KDE environment variable in there.
e.g.
Bash:
nano ~/.profile
- Add the KDE environment variable
e.g.
Code:
export QT_QPA_PLATFORMTHEME=qt5ct
Then save the file and exit nano.

Then try logging out and logging back in again.
Hopefully when you open a KDE application, it will then use the qt5ct settings.

If not, try adding kvantum, as per the linked article.
At this point, you'll already have qt5ct and the environment variables in place - maybe the kvantum themes will improve things?! IDK!!
 
MALIBAL Linux Laptops

Linux Laptops Custom Built for You
MALIBAL is an innovative computer manufacturer that produces high-performance, custom laptops for Linux.

For more info, visit: https://www.malibal.com

Members online


Top