• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

KDE Programs Solved

Am I missing something why it is so hard for you to set everything dark on Slackware with KDE Plasma?
I run on the Fedora KDE Plasma Spin and I just have a dark theme configured under Appearance -> Global Theme. This works for all the applications on the system, the only exceptions being applications that are installed through Flatpak but that is a known problem with Flatpak and for those I usually just select the dark theme from within the application itself.
 
Last edited:


Other than that, I haven't used a full desktop environment for years, so maybe there are some environment settings in XFCE that are overriding, or conflicting with the qt5ct settings...
XFCE overriding, conflicting, <or> lacking plug in's or lib's that it needs to play nice and use the qt5ct style theme.

The KDE app's when booted into the KDE Plasma DE are working and display a dark background so I'm really pleased with that.
I'll ponder the idea of e-mailing the pkg maintainer, Alexander Verbovetsky and see what he says.
 
Am I missing something why it is so hard for you to set everything dark on Slackware with KDE Plasma?
I run on the Fedora KDE Plasma Spin and I just have a dark theme configured under Appearance -> Global Theme. This works for all the applications on the system, the only exceptions being applications that are installed through Flatpak but that is a known problem with Flatpak and for those I usually just select the dark theme from within the application itself.
All of the KDE Apps backgrounds are set to the qt5ct-style theme and work flawlessly. I'm happy with that.

Slackware does not use flatpak's, does not use or have systemd, has it's own pkg management system like unto it'self, does not do dependency resolution and is a 'completely different beast' than FC or any other distro for that matter.

The problem is that XFCE is not using the qt5ct-style that is set in KDE and rightfully so because the variable was set in the .xinictrc file. XFCE most likely needs something ie> other lib's, plugins, another envirnment variable set <or> something to that tune to be set so that all of KDE applications will launch and comply with the qt5ct-style theme.

As I've shared with Jas, I'll ponder the idea and think about it and maybe e-mail the pkg maintainer and see what he says.
 
Without any recent experience of Slackware, I've also been interested in darkness. It varies with different programs. For firefox, I use the extension "Dark background and light text", which means I don't have to use the dark theme on this site, or any other site. My xterms are in reverse video, configured in an .Xdefaults file. There are a few other web browsers that have no dark theme, or just an experimental one like on brave that I use. If there is no dark background in the browser or other applications that I use, I make use of xcalib in a terminal to reverse the video for as long as I need, and then return to the original state by the toggling the same command:
Code:
xcalib -i -a
Not all video cards are susceptible to xcalib's magic, but most I've used have been.
@osprey :-

For the Chromium-based 'clones' - including Brave - I use this dark theme from the Chrome App Store:-

Morpheon Dark

.....which blends very nicely with both the

SlicknesS-black

.....and/or

Melissa

.....GTK2 themes which I use across the Puppy 'kennels'. Stuff's out there.....ya just gotta get "stuck in" on occasion, and spend a bit of time tracking the good stuff down!


Mike. ;)
 
I ran this to see what's going on.
Code:
echo $QT_QPA_PLATFORMTHEME

And it didn't return anything which implies that it didn't get to my environment and likely isn't affecting QT apps outside of KDE.
Maybe I need to add QT_QPA_PLATFORMTHEME=qt5ct to my .profile in my /home folder?

But before I edit that .profile I think installing qt5-style-plugins might be wise. I'll find out--
 
Installing the qt5 styleplugins made no difference--
Code:
root@slackware64:/tmp# installpkg qt5-styleplugins-5.0.0.20170112-x86_64-2_SBo.tgz
Verifying package qt5-styleplugins-5.0.0.20170112-x86_64-2_SBo.tgz.
Installing package qt5-styleplugins-5.0.0.20170112-x86_64-2_SBo.tgz:
PACKAGE DESCRIPTION:
# qt5-styleplugins (additional style plugins for Qt5)
#
# Additional style plugins for Qt5.
#
Package qt5-styleplugins-5.0.0.20170112-x86_64-2_SBo.tgz installed.
root@slackware64:/tmp#

Slackware does not have a .profile in the /home directory. Only a etc/profile.

After executing commands from /etc/profile, the shell checks if the next file exists and is readable. If so, it then executes the commands that the file contains. On a fresh Slackware install, only /etc/profile exists and sets the environment system wide. If a user wants to override their login shell settings, they need to manually create one of the other files. Please note that each of this files is sourced only once when a user logs in.

Does anyone know if I create a .profile and place the export QT_ etc. variable in that file if that will break anything?
 
Aha - a quick bit of duckduckgo-fu yielded this:

That looks like it should help.
Oh, and after all of that - it seems that .xinitrc isn't the place to be putting those KDE environment variables.
It turns out that ~/.profile was the correct place to put those settings. So my initial post about the environment variables was actually correct.... Go figure?!

So perhaps try creating a .profile file in your home directory and put the KDE environment variable in there.
e.g.
Bash:
nano ~/.profile
- Add the KDE environment variable
e.g.
Code:
export QT_QPA_PLATFORMTHEME=qt5ct
Then save the file and exit nano.

Then try logging out and logging back in again.
Hopefully when you open a KDE application, it will then use the qt5ct settings.

If not, try adding kvantum, as per the linked article.
At this point, you'll already have qt5ct and the environment variables in place - maybe the kvantum themes will improve things?! IDK!!
Headed over to boot up Slackware XFCE now to create a ~/.profile in the /home directory.
Be back to let you know if it works.
 
Problem Solved:-

Created a .profile for my /home directory in nano added the variable, saved the file, logged out logged in again.
No dice!

Opened the .xinictrc file in nano made sure that the variable I copied and pasted was still there and hit the space bar one time saved and exited nano.

Logged out and logged back in, SHAZAM!
With the exception of Kalzium most of my KDE applications while running under the XFCE DE now have a dark backgrounds!

Thanks Jas for the help!
 

Members online


Latest posts

Top