laptop starts itself after a few seconds after switching off?

linux_user96

New Member
Joined
Dec 19, 2021
Messages
16
Reaction score
5
Credits
147
hi
I have recently installed lubuntu 21.1 on my old laptop. when I switch off the laptop it starts itself after a few seconds. Even when laptop is closed it starts itself. but I dont have the problem when the charger is connected and the laptop is loading its battery! and when I unplug the charger it switches on itself again.

why and how to I reverse that?
 
Last edited:


KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
5,769
Reaction score
5,206
Credits
46,570
I've seen this before and it can be a few reasons. That doesn't mean I have the answer.

In your BIOS, do you have Wake On Land "WOL" enabled?

There's a hardware button usually, an Fn + F key of some type, that disables wireless. What happens if you disable wireless before rebooting?
 
OP
L

linux_user96

New Member
Joined
Dec 19, 2021
Messages
16
Reaction score
5
Credits
147
I've seen this before and it can be a few reasons. That doesn't mean I have the answer.

In your BIOS, do you have Wake On Land "WOL" enabled?

There's a hardware button usually, an Fn + F key of some type, that disables wireless. What happens if you disable wireless before rebooting?
I can see in the bios that "wake on usb" and wake on lan is enabled" I disabled both and that doesnt work.

to disconnect wireless I use the key Fn+ the wireless key on my laptop and when rebooting nothing special happens.

I forgot to mention that wifi that does not connect automatically to wifi, I think thats normal when you deactivate wake on lan, isnt it?
 
Last edited:

Terminal Velocity

Active Member
Joined
Oct 13, 2021
Messages
147
Reaction score
94
Credits
1,053
Look if there is a bios update/repair in your manufacturer site, do that
 

Terminal Velocity

Active Member
Joined
Oct 13, 2021
Messages
147
Reaction score
94
Credits
1,053
Bios repair tools usually work in two ways ''repair the bios of this computer'' which run on windows, and ''create a USB with the bios repair tool'' to repair a non working (booting) computer. If you have Linux in it now you need to create a USB media, if that doesn't work then you need to install windows and run the repair tool ''for this computer'' from Windows, pain I know, and it may not fix your problem
 
Last edited:

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
5,769
Reaction score
5,206
Credits
46,570
I think thats normal when you deactivate wake on lan, isnt it?

It shouldn't be active if WoL is disabled.

Hmm...

I have one more attempt you can make. Because it'll be easier if you just look up a good tutorial for nomodeset - except I want you to use:

Code:
xhci_hcd.quirks=270336

Alright, I found you a correct tutorial:


It's the tutorial at the top about adding 'nomodeset'. Just follow the tutorial, but instead use the code I included above instead of 'nomodeset'.

Try that. If that doesn't work, you can just undo it.
 
OP
L

linux_user96

New Member
Joined
Dec 19, 2021
Messages
16
Reaction score
5
Credits
147
It shouldn't be active if WoL is disabled.

Hmm...

I have one more attempt you can make. Because it'll be easier if you just look up a good tutorial for nomodeset - except I want you to use:

Code:
xhci_hcd.quirks=270336

Alright, I found you a correct tutorial:


It's the tutorial at the top about adding 'nomodeset'. Just follow the tutorial, but instead use the code I included above instead of 'nomodeset'.

Try that. If that doesn't work, you can just undo it.
yes wifi is deactivated when wol is disabled in the bios, I think I didnt explain that clearly. and wake on usb is also disabled...

now I have found something more: when the laptop is charging, it doesnt boot itself after shutting down. I clicked all buttons on the laptop, clicked the mousepad keys, pulled the usb mouse. everything ok.

but as soons as I pull the charger the laptop boots itself. note that wol and wake on usb is still deactivated.

and when I shut down the laptop without the charger plugged in, after a few seconds the laptop reboots itself. same settings in the bios when charger was plugged in.

Now I have activated wol and wake on usb and plugged in the charger, and the laptop does not reboot itself. and when I pull the charger it boots itself again.

well done, I will try to find solutions to this "new" problem on google...
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
5,769
Reaction score
5,206
Credits
46,570
I'm at a loss. I'd try the fix I suggested (it's easily undone if it doesn't work). I'm wondering if there's some strange ACPI issues going on, some weirdness your laptop does regarding power. That may be one way to go, as I'm plum out of ideas.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Latest posts

Top