Let's encrypt issue with dyndns

CptCharis

Well-Known Member
Credits
350
Hello everybody.
I am using Let's encrypt for an SSL certificate on my nextcloud home server.
As can you see on below screenshots SSL certificate has been created but is working only if I use my IP.
Once I try with my mysecret.dyndns.org domain, connection failed.

This is how I set up my virtual host in sites-available
Screenshot from 2020-06-16 12-21-51.png


Here you can see that all files have been created accordingly.
Screenshot from 2020-06-16 12-23-11.png


And here is certificate installation results

Screenshot from 2020-06-16 12-23-42.png


Why mysecret.dyndns.org domain is not working with SSL?
By the way I had some results with openssl

Can somebody explain?
 

Attachments



f33dm3bits

Gold Member
Gold Supporter
Credits
3,889
What does your SSL configuration look like? What happens in the browser when you go the https version of your website? What do you see in the error logs of your vhost?
 

f33dm3bits

Gold Member
Gold Supporter
Credits
3,889
I can re-direct you in this thread of Let's encrypt forum for more details.
I see you have something listening op 443/tcp on your system. Are you able to connect on port 443 by either connecting via your external ip or your dyndns name. So with your example mysecret.dyndns.org or with example external ip 1.2.3.4. External ip being the ip you get back from for example ipchicken

Code:
telnet mysecret.dyndns.org 80
telnet 1.2.3.4  80
telnet mysecret.dyndns.org 443
telnet 1.2.3.4  443
 
Last edited:

CptCharis

Well-Known Member
Credits
350
I am currently on board and I don't have SSH access in my home server right now but if I remember well port 443 should serve security cameras.
Just now I remember this "minor" detail :confused::rolleyes:
 

f33dm3bits

Gold Member
Gold Supporter
Credits
3,889
I am currently on board and I don't have SSH access in my home server right now but if I remember well port 443 should serve security cameras.
Just now I remember this "minor" detail :confused::rolleyes:
I just read the remaining part of that other forum post. Your port fowarding looks good, seems like you are able to connect on your external ip on 80 and 443. 80 and 443 are working from you internal network.

Have you tried removing the ssl configuration to see if when you just use http a webpage loads? If a page then loads using http, then you at least know up to that point is working and something is probably wrong with your ssl config. If that doesn't work then I suspsect your ISP might be blocking you in some way from being able to to traffic data through 80 and 443 on your home ip. You could probably verify this by running a tcpdump on your webserver system to see what kind of traffic you see. And you could try running you http and https on ports other than 80 and 443 and forward does to see then if a webpage does load then on http and https. Don't have a lot to go on so trying to give you some options you can try once you have access to your system again to try it.
 

CptCharis

Well-Known Member
Credits
350
I am not sure that I fully understood what you are saying but I can reach my page (owncloud) with http, internal - external network and also I can reach it https only by internal network. (using IP)
I can not reach it https by external network. (using dyndns domain)
 

f33dm3bits

Gold Member
Gold Supporter
Credits
3,889
I am not sure that I fully understood what you are saying but I can reach my page (owncloud) with http, internal - external network and also I can reach it https only by internal network. (using IP)
I can not reach it https by external network. (using dyndns domain)
You just mentioned the information I was looking for, you can reach your website via http by using your external ip but not https, but you can reach both http and https on your internal network. Try changing the ssl port(ie: 8443 or 9443) for your owncloud https configuration to something else, and then try forwarding that in your router. See if that makes a difference for reaching https externally.
 
Last edited:


Members online


Top