LG Gram 17 2020 Won't Shut Down on Kernel 5.5+

origamisith

New Member
Joined
Aug 5, 2020
Messages
14
Reaction score
4
Credits
147
Hello everyone,

I was trying to install Arch dual booted with Windows on my LG Gram 17 2020 laptop. Everything worked as expected, except that shutting down, rebooting or halting would result in an infinite hang on a blank screen. You can read the saga (including logs and such) here. Notably, another user had the same issue. Out of desperation, I tried a few different operating systems, and found that only operating systems that used Linux kernel 5.4 or earlier would shut down properly (such as Linux Mint 20, Arch February release, and Fedora 31). Obviously, I would like to be able to use the most current Linux kernel without having to hold down the power button whenever I reboot (which also messes up the system clock and some bios settings). Given that the most popular distro, Ubuntu, is currently on 5.4, and may use 5.5 next, scores of Gram 17 Linux users may end up with the same problem later this year (unless it is only I and another unlucky user cursed with a Linux-unfriendly laptop). I have little idea where to start, whether some convenient kernel parameter or bios setting will fix all my problems, or whether a major patch needs to exist specifically for my device. I would appreciate any help I can get.
 


sp331yi

Well-Known Member
Joined
Apr 11, 2020
Messages
725
Reaction score
326
Credits
4,614
I just ran across this GitHub webpage that may be of help (although it deals with your laptop, 2019 model).
 

tpetersohn

New Member
Joined
Aug 15, 2020
Messages
9
Reaction score
2
Credits
91
Did this nommconf trick work for you? I'm scared to install fedora on my gram because of this.
 
OP
O

origamisith

New Member
Joined
Aug 5, 2020
Messages
14
Reaction score
4
Credits
147
Did this nommconf trick work for you? I'm scared to install fedora on my gram because of this.
It did not :(
If you want to help find out the cause of the problem, you can try bisecting different releases of the kernel to find exactly which patch breaks things. In the Arch forum I linked, someone explains how to it on Arch, but I am getting errors in the build process. If someone else can build and test kernel versions on their LG Gram 2020, that would be great. I'm struggling to find the time right now.
 

tpetersohn

New Member
Joined
Aug 15, 2020
Messages
9
Reaction score
2
Credits
91
I turned off suspend/hibernate in gnome energy settings (manjaro 5.7). So far it seems to work ... it did reboot after 40 minutes without hanging.
 

studesom

New Member
Joined
Aug 26, 2020
Messages
1
Reaction score
0
Credits
6
Another 2020 gram 17 user here, I'm having the same issue on a new fedora 32 install (kernel 5.7).
 

tpetersohn

New Member
Joined
Aug 15, 2020
Messages
9
Reaction score
2
Credits
91
Turn off TCSS xHCI ... if anyone here could explain to me what this is why it prevents rebooting my notebook ... ???
 

tpetersohn

New Member
Joined
Aug 15, 2020
Messages
9
Reaction score
2
Credits
91
I can't stop tweaking the bios :) Set "Enable the iTBT PCIe on Extra Segment" inside the TCSS xHCI thing to ENABLE and that finally fixes the hang problem !!!
 
OP
O

origamisith

New Member
Joined
Aug 5, 2020
Messages
14
Reaction score
4
Credits
147
@tpetersohn You are a madlad. How in the world did you discover that. It worked for me, installing the latest Arch release. I still need to find which exact kernel release necessitates that BIOS tweak, but for now we have a fix.
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
7,112
Reaction score
5,988
Credits
23,530
Legend folks :)

Love it when they solve their own probs, sort of makes us redundant, but I can live with that - more time for me :cool:

Enjoy your Linux

Wiz
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
7,112
Reaction score
5,988
Credits
23,530
BTW @studesom - you might want to try the above as well?

If you need help, swing around to here.

Cheers

Wiz
 

tpetersohn

New Member
Joined
Aug 15, 2020
Messages
9
Reaction score
2
Credits
91
ehm I have to add something ... this time I turned on everything in system agent except for ITBT root port and iTBT PCIe on Extra Segment ... because I still had an error or two in dmesg mmconfig something and something else i cant remember. Now all errors are gone. I mean really ALL errors ;-)
 

jglen490

Well-Known Member
Joined
Mar 10, 2020
Messages
736
Reaction score
503
Credits
4,106

jglen490

Well-Known Member
Joined
Mar 10, 2020
Messages
736
Reaction score
503
Credits
4,106
Glad that you have a really out of the blue fix for this? So just out of curiosity, in your UEFI settings what SATA boot parameter is set? AHCI or something else?
 

May Ismyauntie

New Member
Joined
May 5, 2021
Messages
1
Reaction score
0
Credits
9
I can't stop tweaking the bios :) Set "Enable the iTBT PCIe on Extra Segment" inside the TCSS xHCI thing to ENABLE and that finally fixes the hang problem !!!

TPetersohn,

Good afternoon. I have struggled to find this setting in BIOS having searched through it.

May I cordially request added (or maximal, preferrably) specific info on where this setting is located?

Thank you.

Edit: Do you have BIOS is Phoenix version C2ZE0131 in your LG Gram 17? An update C2ZE0160 was released recently. Superficially, it looks cosmetically the same as C2ZE0131 when I tab through the two BIOS menus side-by-side.
 

rxtx

New Member
Joined
Jan 28, 2022
Messages
2
Reaction score
0
Credits
15
Sorry to hijack the thread, but could someone tell me what brand is the touchpad on LG Gram i7 2020? Does it have a good driver, capable of setting e.g. touch sensitivity/palm rejection?
 
OP
O

origamisith

New Member
Joined
Aug 5, 2020
Messages
14
Reaction score
4
Credits
147
Sorry to hijack the thread, but could someone tell me what brand is the touchpad on LG Gram i7 2020? Does it have a good driver, capable of setting e.g. touch sensitivity/palm rejection?
Not sure, but here is what xinput tells me
https://pastebin.com/6jTT1Z2E
As for palm rejection, I think by default the touchpad disables entirely while typing, but I found that annoying so I turned it off. As a result it does fling my cursor sometimes when I'm typing, but if you don't need to use the touchpad and keyboard simultaneously then you could leave the "Disable While Typing enabled" flag at 1.
I found touch sensitivity to be quite adjustable.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top