LibreWolf Won't Let Me Make it the Default Browser

SpongebobFan1994

Active Member
Credits
4,572
Whenever I go to the "hamburger" icon at the top right of the screen, and then go to preferences, I get this notice saying "LibreWolf is not your default browser"

Librewolf.png


I'd obviously change that so it would be that, but as you can see, the "make default" option isn't highlighted. I've tried searching DDG for troubleshooting, but the closest solution I could find was for the Windows version. Because I don't use FireFox anymore, but I somehow still had it downloaded, I deleted it, hoping I could automatically make LibreWolf my default browser, but that didn't work either. Is there a command I could run to fix this?
 


SpongebobFan1994

Active Member
Credits
4,572
Hello, can I ask why you chose Librewolf over Firefox? It looks like a firefox with default ublock origin
You must be living under a rock because Mozilla has been making some very stupid decisions in recent times, so LibreWolf was forked from FireFox in response to that.
 

slowlearning

New Member
Credits
91
Any links are welcomed, I indeed live under a rock

edit: Thanks for the links, I meant links for the stupid decisions of firefox
 
Last edited:

craigevil

Active Member
Credits
1,740
Hello, can I ask why you chose Librewolf over Firefox? It looks like a firefox with default ublock origin
A fork of Firefox, focused on privacy, security and freedom.

What distro are you using? In Debian you can use the alternatives to add it and make it default.
 

craigevil

Active Member
Credits
1,740
First you need to add LibreWolf to the proper Alternatives:
x-www-browser
gnome-www-browser

You need to know the path to the executable.

This page has someone adding Waterfox, the commands are the same you just use the path to Librewolf.
 

SpongebobFan1994

Active Member
Credits
4,572
A fork of Firefox, focused on privacy, security and freedom.

What distro are you using? In Debian you can use the alternatives to add it and make it default.
I'm using Mint 20.2 Cinnamon. I should be able to get it to work since it's the grandchild of Debian.
 

SpongebobFan1994

Active Member
Credits
4,572
Any links are welcomed, I indeed live under a rock

edit: Thanks for the links, I meant links for the stupid decisions of firefox
Here's Mozilla advocating censorship and surveillance in "the name of" fighting against white supremacy: https://foundation.mozilla.org/en/blog/fellow-research-decentralized-web-hate/ Be aware that the far-left and the far-right are two heads of the same monster known as political extremism.

Here's Mozilla advocating a spyware feature in FireFox (which can be turned off, so joke's on them) https://www.bleepingcomputer.com/ne...ows-ads-as-sponsored-address-bar-suggestions/

Here's Mozilla thinking they don't have cross-platform compatibility (which is a lie), them adding in features users don't want or don't like (such as the Google search engine, all because Google is bribing them), giving users buggy updates, etc

Being that I answered your question, lets now drop the subject of Mozilla because that's besides the point
 

Condobloke

Well-Known Member
Credits
16,178
LM20.2
click menu
type in Preferred applications.
Set LW as the preferred app to open Web.
 

SpongebobFan1994

Active Member
Credits
4,572
LM20.2
click menu
type in Preferred applications.
Set LW as the preferred app to open Web.
I tried doing that last night, but I saw it wasn't listed for some reason. If this helps knowing, I installed it as an appimage. I'm wondering if that has something to do with it?
 

Condobloke

Well-Known Member
Credits
16,178
I tried doing that last night, but I saw it wasn't listed for some reason. If this helps knowing, I installed it as an appimage. I'm wondering if that has something to do with it?
When you click on the drop down and find that LW is not there...is there an option to select "other application" ?
 

KGIII

Super Moderator
Staff member
Gold Supporter
Credits
28,890
I don't think it's all that straightforward to make an appimage the default. It's possible, but not by normal means.

You'll have to modify this answer to suit:


I'm not sure, but the edit would look something like:

Code:
MimeType=x-scheme-handler/http;x-scheme-handler/https;text/html;application/xhtml+xml;//
Then, after that, you may still need to set it as the default elsewhere - like the #6 answer in this thread.
 

SpongebobFan1994

Active Member
Credits
4,572
When you click on the drop down and find that LW is not there...is there an option to select "other application" ?
Yes, and it still wasn't listed
 

Condobloke

Well-Known Member
Credits
16,178
Have another look......and make allowance that it may be under a slightly different name....depending where the app image came from perhaps? Stranger things have happened.
 

SpongebobFan1994

Active Member
Credits
4,572
Have another look......and make allowance that it may be under a slightly different name....depending where the app image came from perhaps? Stranger things have happened.
There's no browser-related software on that list. I've triple-checked.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top