Linux keeps crashing on new pc

Gokarn

New Member
Credits
0
So a few days ago i built a new pc, and decided i wanted to try Linux for the first time. First i tried ubuntu, but it kept freezing a few minutes after booting every time. After that i gave up and went back to windows for a while and it worked perfectly fine. Today i wanted to try Linux again, so i downloaded Linux Mint, but it freezes after a few minutes every time i go on it. Only way to stop it is if i restart the pc by turning the power off.
 


poorguy

Well-Known Member
Credits
454

jglen490

Active Member
Credits
656
So a few days ago i built a new pc, and decided i wanted to try Linux for the first time. First i tried ubuntu, but it kept freezing a few minutes after booting every time. After that i gave up and went back to windows for a while and it worked perfectly fine. Today i wanted to try Linux again, so i downloaded Linux Mint, but it freezes after a few minutes every time i go on it. Only way to stop it is if i restart the pc by turning the power off.
That's very likely a hardware issue in need of a driver solution. IIRC Mint includes the inxi command line utility, so after a boot up open a terminal and enter
Code:
inxi -Fxxxz
exactly as shown - upper case/lower case. It will prompt you for your password, the same one you use to login.

If inxi is not installed, you can do so at the command line
Code:
sudo apt update && sudo apt install inxi
exactly as shown with that spacing. It will prompt you for your password, the same one you use to login.
 

Gokarn

New Member
Credits
0
That's very likely a hardware issue in need of a driver solution. IIRC Mint includes the inxi command line utility, so after a boot up open a terminal and enter
Code:
inxi -Fxxxz
exactly as shown - upper case/lower case. It will prompt you for your password, the same one you use to login.

If inxi is not installed, you can do so at the command line
Code:
sudo apt update && sudo apt install inxi
exactly as shown with that spacing. It will prompt you for your password, the same one you use to login.
Inixi was already installed.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
972
so after a boot up open a terminal and enter
Code:
inxi -Fxxxz
exactly as shown -
just an FYI no need for sudo

:)@Gokarn welcome to linux.org

can you give us that inxi output please?

christurner
wizardfromoz
 

Gokarn

New Member
Credits
0
just an FYI no need for sudo

:)@Gokarn welcome to linux.org

can you give us that inxi output please?

christurner
wizardfromoz
Thanks :)
Here is the output:
System:
Host: sivert-Z390-UD Kernel: 5.3.0-45-generic x86_64 bits: 64
compiler: gcc v: 7.5.0 Desktop: Cinnamon 4.4.8 wm: muffin 4.4.2
dm: LightDM 1.26.0 Distro: Linux Mint 19.3 Tricia
base: Ubuntu 18.04 bionic
Machine:
Type: Desktop Mobo: Gigabyte model: Z390 UD v: x.x serial: <filter>
UEFI [Legacy]: American Megatrends v: F9 date: 10/15/2019
CPU:
Topology: 6-Core model: Intel Core i5-9600K bits: 64 type: MCP
arch: Kaby Lake rev: D L2 cache: 9216 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44398
Speed: 4476 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 3691 2: 3562
3: 3402 4: 3566 5: 3691 6: 3176
Graphics:
Device-1: NVIDIA driver: nouveau v: kernel bus ID: 01:00.0
chip ID: 10de:1e89
Display: x11 server: X.Org 1.20.5 driver: modesetting unloaded: fbdev,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: llvmpipe (LLVM 9.0 256 bits) v: 3.3 Mesa 19.2.8
compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte
driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a348
Device-2: NVIDIA driver: snd_hda_intel v: kernel bus ID: 01:00.1
chip ID: 10de:10f8
Sound Server: ALSA v: k5.3.0-45-generic
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel port: 3000 bus ID: 04:00.0
chip ID: 10ec:8168
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 465.76 GiB used: 16.31 GiB (3.5%)
ID-1: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB
speed: 6.0 Gb/s serial: <filter> rev: 023 scheme: MBR
Partition:
ID-1: / size: 457.45 GiB used: 16.31 GiB (3.6%) fs: ext4 dev: /dev/sda1
Sensors:
System Temperatures: cpu: 33.0 C mobo: N/A gpu: nouveau temp: 28 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 737
Info:
Processes: 231 Uptime: 9m Memory: 15.57 GiB used: 1008.8 MiB (6.3%)
Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.5.0 alt: 7 Shell: bash
v: 4.4.20 running in: gnome-terminal inxi: 3.0.32
 

jglen490

Active Member
Credits
656
Two comments.
Your UEFI is running in Legacy mode, which could be a problem, depending on other UEFI settings. When running Linux on a single boot machine Legacy is usually the last thing to try.

Also, you are still running the Nouveau driver for your Nvidia video card. It may be happier with an Nvidia driver. Open a terminal and run
Code:
inxi -Gxxxx
ubuntu-drivers devices
as two separate entries, then copy and paste the results of each command. The ubuntu-drivers devices may run for a while, so be patient.
 

Alexzee

Well-Known Member
Credits
1,089
Have you looked in Driver Manger?

What's the output of:

lspci | grep -i VGA
 

jglen490

Active Member
Credits
656
That's pretty much what Gokarn was asked to do ;)
 


Members online


Latest posts

Top