Linux Mint 20.2 Cinnamon HP Device Manager Not Seeing Printer / Dependencies Missing SOLVED

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
3,941
Reaction score
3,556
Credits
20,114
I've got another (potentially) silly one for you

Turn the printer off at the wall socket. Leave it off for a minute or two, then turn it back on again.

Any joy?
 


Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,166
Reaction score
780
Credits
8,630
Also make sure bluez-cups is installed
warning: Failed to read /etc/cups/ppd/HP_ENVY_110_series.ppd ppd file
This warning means that the hp-check script doesn't have the permission to read this file.

Need to change the permissions on that file in root - check Owner probably Root - Group is probably Read - "Other" need to change that to Read it might say No Right
 
Last edited:
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,065
Reaction score
1,004
Credits
10,297
I've got another (potentially) silly one for you

Turn the printer off at the wall socket. Leave it off for a minute or two, then turn it back on again.

Any joy?
No joy:-

It's still giving me the communications error.
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,065
Reaction score
1,004
Credits
10,297
Also make sure bluez-cups is installed

This warning means that the hp-check script doesn't have the permission to read this file.

Need to change the permissions on that file in root - check Owner probably Root - Group is probably Read - "Other" need to change that to Read it might say No Right
Bluez-cups is installed, so that's a plus.

What file do you mean that I need to change permissions on?

Code:
cat /etc/cups/ppk/HP_ENVY_110_series.ppd ppd file
cat: /etc/cups/ppk/HP_ENVY_110_weries.ppd: No such file or directory
cat: ppd: No such file or directory
cat: file: No such file or direct

I found the file-

PPD.png
 
Last edited:

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,166
Reaction score
780
Credits
8,630
The one in the original warning - you do have two errors in you cat commands - you have - cat /etc/cups/ppk/HP_ENVY_110_series.ppd ppd file - the "ppd file" should not be there should be - cat /etc/cups/ppk/HP_ENVY_110_series.ppd - the second one is - cat: /etc/cups/ppk/HP_ENVY_110_weries.ppd
it is series not weries a typo error - that is why it can't find it - should be - cat /etc/cups/ppk/HP_ENVY_110_series.ppd
here are the two warnings you have from your first post
warning: Failed to read /etc/cups/ppd/HP_ENVY_110_series.ppd
and
warning: Failed to read /etc/cups/ppd/ENVY_110_series_21F106_.ppd
Those are the files you need to check the permissions on
 
Last edited:
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,065
Reaction score
1,004
Credits
10,297
The one in the original warning - you do have two errors in you cat commands - you have - cat /etc/cups/ppk/HP_ENVY_110_series.ppd ppd file - the "ppd file" should not be there should be - cat /etc/cups/ppk/HP_ENVY_110_series.ppd - the second one is - cat: /etc/cups/ppk/HP_ENVY_110_weries.ppd
it is series not weries a typo error - that is why it can't find it - should be - cat /etc/cups/ppk/HP_ENVY_110_series.ppd
here are the two warnings you have from your first post
warning: Failed to read /etc/cups/ppd/HP_ENVY_110_series.ppd
and
warning: Failed to read /etc/cups/ppd/ENVY_110_series_21F106_.ppd
Those are the files you need to check the permissions on
I corrected my spelling and the command-line can't find it--

Code:
a-System-Product-Name:~$ cat /etc/cups/ppd/HP_ENVY_110_series.ppd
cat: /etc/cups/ppd/HP_ENVY_110_series.ppd: No such file or directory
a-System-Product-Name:~$ cat /etc/cups/ppd/HP_ENVY_110_series.ppd ppd file
cat: /etc/cups/ppd/HP_ENVY_110_series.ppd: No such file or directory
cat: ppd: No such file or directory
cat: file: No such file or directory
a-System-Product-Name:~$ cat /etc/cups/ppd/ENVY_110_series_21f106_.ppd
cat: /etc/cups/ppd/ENVY_110_series_21f106_.ppd: No such file or directory

I went back to the original post and made sure that what I was typing was correct.
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,065
Reaction score
1,004
Credits
10,297
BTW, I have a pc down the hallway in another room running Kubuntu.
Kubuntu saw the printer and printed a test page.:)

However the HP Manager still has the communication error and the Simple Scan isn't in the Menu for me to use.
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,166
Reaction score
780
Credits
8,630
I corrected my spelling and the command-line can't find it--

Code:
a-System-Product-Name:~$ cat /etc/cups/ppd/HP_ENVY_110_series.ppd
cat: /etc/cups/ppd/HP_ENVY_110_series.ppd: No such file or directory
a-System-Product-Name:~$ cat /etc/cups/ppd/HP_ENVY_110_series.ppd ppd file
cat: /etc/cups/ppd/HP_ENVY_110_series.ppd: No such file or directory
cat: ppd: No such file or directory
cat: file: No such file or directory
a-System-Product-Name:~$ cat /etc/cups/ppd/ENVY_110_series_21f106_.ppd
cat: /etc/cups/ppd/ENVY_110_series_21f106_.ppd: No such file or directory

I went back to the original post and made sure that what I was typing was correct.
Looks to me that directory was not created during driver install that is why it failed the only way I know to solve this is to manually create the directory before you install the driver. Physically got to /etc/cups/ppd and see if it exists - also check for /usr/share/cups/model and see if the HP ppd files are there or it exists
so you will need to uninstall the driver, create the directory listed above in root, and then install the driver again.

You can install Xsane for the scanner
 
Last edited:
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,065
Reaction score
1,004
Credits
10,297
Looks to me that directory was not created during driver install that is why it failed the only way I know to solve this is to manually create the /usr/share/cups/ppd/ directory before you install the driver. Physically got to /etc/cups/ppd and see if it exists
so you will need to uninstall the driver, create the directory listed above in root, and then install the driver again.

You can install Xsane for the scanner
I installed the driver through the HP Device Manager by giving it the printers URI.
I'm not sure how to uninstall the driver at this point--

The directory /etc/cup/ppd does exist and it has 2 files in it .
Both file's are the HP Envy ppd files.
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,166
Reaction score
780
Credits
8,630
It is good the files are there /etc/cups/ppd it is a permission problem - also check for /usr/share/cups/model and see if the HP ppd files are there or it exists
Make sure you belong to the lpadmin group:
Code:
sudo adduser username lpadmin
Reload CUPS:
Code:
sudo service cups restart
You then access CUPS via this address : http://localhost:631/ then click on Administration tab at the top
Click "Add Printer" and follow through: you will see an option to use a PPD file.
 
Last edited:
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,065
Reaction score
1,004
Credits
10,297
Maybe delete all 3 instances of the printer and start over?
Also, I'm thinking of removing the HP Device Manger, removing HPLIP and start all over again.

What do you think Lord Boltar?
 
Last edited:

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,166
Reaction score
780
Credits
8,630
Maybe delete all 3 instances of the printer and start over?
Also, I'm thinking of removing the HP Device Manger, removing HPLIP and start all over again.

What do you think Lord Boltar?
No you do not need to do that it looks fine from what I see show your Bluetooth driverless connection and your regular one - when you went to /etc/cups/ppd and opened the envy.ppd file did you do that in root, you need to be in root to change the permissions - then change Access to Read-only otherwise it will be greyed out
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,065
Reaction score
1,004
Credits
10,297
No you do not need to do that it looks fine from what I see show your Bluetooth driverless connection and your regular one - when you went to /etc/cups/ppd and opened the envy.ppd file did you do that in root, you need to be in root to change the permissions - then change Access to Read-only otherwise it will be greyed out
From what I can tell I can not open that file as root in the GUI.
And there is no option in the left click menu to open that ppd file as the administrator.

Do I need to install gksudo?
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,166
Reaction score
780
Credits
8,630
If you are running Cinnamon you can open Nemo then right click inside and select Open as Root another instance of Nemo will open then navigate to the file and open it
1.png

If you are running Xfce and Thunar you will have to add that function to the right click menu - open Thunar then go to Edit then down to "Configure custom actions" and open that "Custom Actions" will appear then click the Plus "+" button to add feature - "Create Action" will appear - in the Name block type in Open Root Here the Description block you can leave blank - under Command type in pkexec thunar %f you can pick an Icon if you want but is optional, now click on Appearance Conditions and put a check mark in Directories and Text Files click OK and exit out - Now close Thunar and re-open it now Right-Click your "Open as Root" should be there

2.png
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
2,065
Reaction score
1,004
Credits
10,297
If you are running Cinnamon you can open Nemo then right click inside and select Open as Root another instance of Nemo will open then navigate to the file and open it
View attachment 10805
If you are running Xfce and Thunar you will have to add that function to the right click menu - open Thunar then go to Edit then down to "Configure custom actions" and open that "Custom Actions" will appear then click the Plus "+" button to add feature - "Create Action" will appear - in the Name block type in Open Root Here the Description block you can leave blank - under Command type in pkexec thunar %f you can pick an Icon if you want but is optional, now click on Appearance Conditions and put a check mark in Directories and Text Files click OK and exit out - Now close Thunar and re-open it now Right-Click your "Open as Root" should be there

View attachment 10806
I was able to open that ppd file as root and changed the access to read only.
Thanks for showing me that.

The HP Device MGR is still not working unfortunately.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Top