Linux Mint 20.2 Cinnamon HP Device Manager Not Seeing Printer / Dependencies Missing SOLVED



OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
re-configure it using
Code:
hp-setup
from the terminal
Well I tried running hp-setup in the terminal and it launched the Device Discovery gui.
HPLIP can't detect my printer:-

Device Discovry.png


HPLIP Can Not.png


I've been to http://hplipopensource.com/node/374 4 times and that page is not found.

Like I shared before, this HP Envy 110 has worked with Linux for the last 10 years under different distro's.
So I don't get what the problem is.

Before I installed Linux Mint Cinnamon 20.2 I was running Linux Mint XFCE 19.1 and the printer worked fine under LM 19.1 for 3 years.
My other desktop pc down the hall from my studio can see the printer and can print a test page.
Go figure.

Could this be a kernel issue Lord Boltar?
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
976
Reaction score
626
Credits
7,241
Those web addresses hplipoensource do not exist anymore all of that is now developers.hp.com

Can you ping your printer? What is the IP address?
I am inclined to believe it is a network issue If you can't ping the printer HPLIP won't work correctly
If your firewall is active make sure that port 161 (udp and tcp), port 162 (udp and tcp) and port 9100 (udp and tcp) are open through your firewall. If these are not open then HPLIP will not function.

Mint 19 was based on Ubuntu 18 both uses Kernel 4.15 then upgraded to 5.4 which is what 20.2 uses unless you upgraded with HWE
 
Last edited:
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
Those web addresses hplipoensource do not exist anymore all of that is now developers.hp.com

Can you ping your printer? What is the IP address?
I am inclined to believe it is a network issue If you can't ping the printer HPLIP won't work correctly
If your firewall is active make sure that port 161 (udp and tcp), port 162 (udp and tcp) and port 9100 (udp and tcp) are open through your firewall. If these are not open then HPLIP will not function.

Mint 19 was based on Ubuntu 18 both uses Kernel 4.15 then upgraded to 5.4 which is what 20.2 uses unless you upgraded with HWE
I don't know how to ping the printer. How would I do that?

The address is:
CUPS URI: hp:/net/ENVY_110_series?ip=192.168.0.16
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
Code:
System-Product-Name:~$ ping 192.168.0.16
PING 192.168.0.16 (192.168.0.16) 56(84) bytes of data.
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
From 192.168.0.14 icmp_seq=1 Destination Host Unreachable
From 192.168.0.14 icmp_seq=2 Destination Host Unreachable
From 192.168.0.14 icmp_seq=3 Destination Host Unreachable
From 192.168.0.14 icmp_seq=4 Destination Host Unreachable
From 192.168.0.14 icmp_seq=5 Destination Host Unreachable
From 192.168.0.14 icmp_seq=6 Destination Host Unreachable
From 192.168.0.14 icmp_seq=7 Destination Host Unreachable
From 192.168.0.14 icmp_seq=8 Destination Host Unreachable
I your Printer LAN or Wireless try running
Code:
hp-setup 192.168.0.16
All I get is Device not found and the printer is on.

This is really bizarre!
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
I checked the Firewall and all is good.

Code:
System-Product-Name:~$ telnet 192.168.0.16
Trying 192.168.0.16...
telnet: Unable to connect to remote host: No route to host
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
976
Reaction score
626
Credits
7,241
Is net-tools installed on you Mint - if not install it
Code:
 sudo apt install net-tools
and then run
Code:
ifconfig
with your printer plugged in and on and paste back the results

also your ran From 192.168.0.14 that is wrong IP Address should be 16 not 14
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
Is net-tools installed on you Mint - if not install it
Code:
 sudo apt install net-tools
and then run
Code:
ifconfig
with your printer plugged in and on and paste back the results

also your ran From 192.168.0.14 that is wrong IP Address should be 16 not 14
I'll install the net tools and run ifconfig for you Saturday or Sunday.
Have to go to work.
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
Good Morning:-

Code:
Product-Name:~$ ifconfig
enp5s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 04:d9:f5:f6:c7:1b  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 545  bytes 48108 (48.1 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 545  bytes 48108 (48.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.14  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::ab5:d09c:9d7:473f  prefixlen 64  scopeid 0x20<link>
        inet6 2601:146:4280:8f60::3  prefixlen 128  scopeid 0x0<global>
        inet6 2601:146:4280:8f60:9c82:82fc:e057:9e16  prefixlen 64  scopeid 0x0<global>
        inet6 2601:146:4280:8f60:9d9:6da:307:9aeb  prefixlen 64  scopeid 0x0<global>
        ether 24:ee:9a:22:5a:79  txqueuelen 1000  (Ethernet)
        RX packets 23473  bytes 27512162 (27.5 MB)
        RX errors 0  dropped 8  overruns 0  frame 0
        TX packets 5936  bytes 1345392 (1.3 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
976
Reaction score
626
Credits
7,241
Good Morning:-

Code:
Product-Name:~$ ifconfig
enp5s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 04:d9:f5:f6:c7:1b  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 545  bytes 48108 (48.1 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 545  bytes 48108 (48.1 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.14  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::ab5:d09c:9d7:473f  prefixlen 64  scopeid 0x20<link>
        inet6 2601:146:4280:8f60::3  prefixlen 128  scopeid 0x0<global>
        inet6 2601:146:4280:8f60:9c82:82fc:e057:9e16  prefixlen 64  scopeid 0x0<global>
        inet6 2601:146:4280:8f60:9d9:6da:307:9aeb  prefixlen 64  scopeid 0x0<global>
        ether 24:ee:9a:22:5a:79  txqueuelen 1000  (Ethernet)
        RX packets 23473  bytes 27512162 (27.5 MB)
        RX errors 0  dropped 8  overruns 0  frame 0
        TX packets 5936  bytes 1345392 (1.3 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
your loopback packet seems low to me but could just be your machine can you run
Code:
time ifconfig lo
and run
Code:
lpstat -a
Also go to Settings open Printers click add select Network Printers then Find Network Printer type in IP Address and click the Find button
If your printer still does not show you may have the wrong IP address to find it try
Code:
avahi-browse --all -t -r
 
Last edited:
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
your loopback packet seems low to me but could just be your machine can you run
Code:
time ifconfig lo
and run
Code:
lpstat -a
Also go to Settings open Printers click add select Network Printers then Find Network Printer type in IP Address and click the Find button
If your printer still does not show you may have the wrong IP address to find it try
Code:
avahi-browse --all -t -r
Code:
stem-Product-Name:~$ time ifconfig lo
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 1292  bytes 124498 (124.4 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1292  bytes 124498 (124.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


real    0m0.001s
user    0m0.001s
sys    0m0.000s
[email protected]:~$ lpstat -a
ENVY_110_series_21F106_ accepting requests since Sat 20 Nov 2021 10:06:09 AM EST

See the screenshot of Printer.

Code:
+ wlp4s0 IPv4 ENVY 110 series [21F106]                      PDL Printer          local
+ wlp4s0 IPv4 ENVY 110 series [21F106]                      Internet Printer     local
= wlp4s0 IPv4 ENVY 110 series [21F106]                      Internet Printer     local
   hostname = [HP21F106.local]
   address = [192.168.0.17]
   port = [631]
   txt = ["Scan=T" "Duplex=T" "Color=T" "UUID=1c852a4d-b800-1f08-abcd-ac162d21f106" "note=" "adminurl=http://HP21F106.local." "mac=ac:16:2d:21:f1:06" "priority=60" "usb_MDL=ENVY 110 series" "usb_MFG=HP" "product=(HP ENVY 110 series)" "ty=ENVY 110 series" "URF=CP1,MT1-2-8-9-10-11,OB9,OFU0,PQ3-4-5,RS300-600,SRGB24,W8,DEVW8,DEVRGB24-48,ADOBERGB24-48,DM3,IS1" "rp=ipp/printer" "pdl=application/vnd.hp-PCL,image/jpeg,application/xhtml+xml,image/urf" "qtotal=1" "txtvers=1"]
+ wlp4s0 IPv4 ENVY 110 series [21F106]                      Web Site             local
+ wlp4s0 IPv4 ENVY 110 series [21F106]                      _scanner._tcp        local
+ wlp4s0 IPv4 ENVY 110 series [21F106]                      _http-alt._tcp       local
= wlp4s0 IPv4 ENVY 110 series [21F106]                      PDL Printer          local
   hostname = [HP21F106.local]
   address = [192.168.0.17]
   port = [9100]
   txt = ["Scan=T" "Duplex=T" "Color=T" "UUID=1c852a4d-b800-1f08-abcd-ac162d21f106" "note=" "adminurl=http://HP21F106.local." "mac=ac:16:2d:21:f1:06" "priority=30" "usb_MDL=ENVY 110 series" "usb_MFG=HP" "product=(HP ENVY 110 series)" "ty=ENVY 110 series" "pdl=application/vnd.hp-PCL,image/jpeg,application/xhtml+xml,image/urf" "qtotal=1" "txtvers=1"]
= wlp4s0 IPv4 ENVY 110 series [21F106]                      Web Site             local
   hostname = [HP21F106.local]
   address = [192.168.0.17]
   port = [80]
   txt = []
= wlp4s0 IPv4 ENVY 110 series [21F106]                      _scanner._tcp        local
   hostname = [HP21F106.local]
   address = [192.168.0.17]
   port = [9500]
   txt = ["flatbed=T" "button=T" "UUID=1c852a4d-b800-1f08-abcd-ac162d21f106" "note=" "adminurl=http://HP21F106.local." "mdl=ENVY 110 series" "mfg=HP" "ty=ENVY 110 series" "txtvers=1"]
= wlp4s0 IPv4 ENVY 110 series [21F106]                      _http-alt._tcp       local
   hostname = [HP21F106.local]
   address = [192.168.0.17]
   port = [8080]
   txt = []

Both Printers.png
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
976
Reaction score
626
Credits
7,241
Code:
stem-Product-Name:~$ time ifconfig lo
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 1292  bytes 124498 (124.4 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1292  bytes 124498 (124.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


real    0m0.001s
user    0m0.001s
sys    0m0.000s
[email protected]:~$ lpstat -a
ENVY_110_series_21F106_ accepting requests since Sat 20 Nov 2021 10:06:09 AM EST

See the screenshot of Printer.

Code:
+ wlp4s0 IPv4 ENVY 110 series [21F106]                      PDL Printer          local
+ wlp4s0 IPv4 ENVY 110 series [21F106]                      Internet Printer     local
= wlp4s0 IPv4 ENVY 110 series [21F106]                      Internet Printer     local
   hostname = [HP21F106.local]
   address = [192.168.0.17]
   port = [631]
   txt = ["Scan=T" "Duplex=T" "Color=T" "UUID=1c852a4d-b800-1f08-abcd-ac162d21f106" "note=" "adminurl=http://HP21F106.local." "mac=ac:16:2d:21:f1:06" "priority=60" "usb_MDL=ENVY 110 series" "usb_MFG=HP" "product=(HP ENVY 110 series)" "ty=ENVY 110 series" "URF=CP1,MT1-2-8-9-10-11,OB9,OFU0,PQ3-4-5,RS300-600,SRGB24,W8,DEVW8,DEVRGB24-48,ADOBERGB24-48,DM3,IS1" "rp=ipp/printer" "pdl=application/vnd.hp-PCL,image/jpeg,application/xhtml+xml,image/urf" "qtotal=1" "txtvers=1"]
+ wlp4s0 IPv4 ENVY 110 series [21F106]                      Web Site             local
+ wlp4s0 IPv4 ENVY 110 series [21F106]                      _scanner._tcp        local
+ wlp4s0 IPv4 ENVY 110 series [21F106]                      _http-alt._tcp       local
= wlp4s0 IPv4 ENVY 110 series [21F106]                      PDL Printer          local
   hostname = [HP21F106.local]
   address = [192.168.0.17]
   port = [9100]
   txt = ["Scan=T" "Duplex=T" "Color=T" "UUID=1c852a4d-b800-1f08-abcd-ac162d21f106" "note=" "adminurl=http://HP21F106.local." "mac=ac:16:2d:21:f1:06" "priority=30" "usb_MDL=ENVY 110 series" "usb_MFG=HP" "product=(HP ENVY 110 series)" "ty=ENVY 110 series" "pdl=application/vnd.hp-PCL,image/jpeg,application/xhtml+xml,image/urf" "qtotal=1" "txtvers=1"]
= wlp4s0 IPv4 ENVY 110 series [21F106]                      Web Site             local
   hostname = [HP21F106.local]
   address = [192.168.0.17]
   port = [80]
   txt = []
= wlp4s0 IPv4 ENVY 110 series [21F106]                      _scanner._tcp        local
   hostname = [HP21F106.local]
   address = [192.168.0.17]
   port = [9500]
   txt = ["flatbed=T" "button=T" "UUID=1c852a4d-b800-1f08-abcd-ac162d21f106" "note=" "adminurl=http://HP21F106.local." "mdl=ENVY 110 series" "mfg=HP" "ty=ENVY 110 series" "txtvers=1"]
= wlp4s0 IPv4 ENVY 110 series [21F106]                      _http-alt._tcp       local
   hostname = [HP21F106.local]
   address = [192.168.0.17]
   port = [8080]
   txt = []

View attachment 10849
So your printer IP is 192.168.0.17 - not 192.168.0.16 - your loopback time is fine - have to modify the IP address on one of them and then delete the other and set the modified one to default - which is from the above output I see
hostname = [HP21F106.local]
address = [192.168.0.17]
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
So your printer IP is 192.168.0.17 - not 192.168.0.16 - your loopback time is fine - have to modify the IP address on one of them and then delete the other and set the modified one to default - which is from the above output I see
hostname = [HP21F106.local]
address = [192.168.0.17]
Ok-

I'll go back into the printer settings and delete the other instance of the printer.
I'll change the URI to hp:/net/ENVY_110_series?=192.168.0.17 and see if that helps.
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
I deleted the other instance of the printer.
And printed a test page.

New.png

The URI for the printer in the GUI for the printer is:
implicitclass://ENVY_110_series21F106_%40HP21F106.local/

Should I change that URI to hp:/net/ENVY_110_series?ip=192.168.0.17 ?
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
Settings Printer.png
 
OP
Alexzee

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
Yes change it based on the output
Changing the URI worked.
I was able to get the correct Menu for the HPLIP Device Manager this time.
HPLIP Working.png


What would of caused the URI to be wrong in the first place?

IF this happens again how can I know if it's the URI address is wrong again?
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Staff online


Latest posts

Top