Linux Mint not starting after Exiting boot menu

RedAreApples

New Member
Credits
113
I do not want to pollute the Q&A section with questions already asked. But I could not find the solution so I need a little help.
I do not know much about Linux so I am installing to learn something.
When I exit the boot menu after disabling SecureBoot and PTT and putting The USB stick up in the boot order, my system restarts but does not show the GRUB screen. Just a black screen. I tried again after restarting the system but the same problem happened.
Device : Dell Inspiron 5570 (Windows 10 Home)
Linux Distro : Linux Mint Cinnamon 64bit latest build
USB : San disk 32gb. Linux live Boot created using Rufus.

I do not know what else to provide. Can anyone help?
 


captain-sensible

Well-Known Member
Credits
8,468
I tried a few flavours of Mint for fun ( i don't have any issues witht my installed Linux which is slackware ) including Cinnamon and also got a problem. I wasn't interested enough to find out why but xfce version Mint from usb booted ok.

So to clarify you have a PC with Windows on it and trying to boot Linux live? with 32 gig usb stick you can try several Linux distros and choose to boot any of them see ventoy : https://www.ventoy.net/en/index.html
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
11,349
G'day @RedAreApples and welcome to linux.org :)

Sounds like what you have done so far is fine, so I'll ask a few questions and give you a few options:
  1. Did you check the integrity (hashsum) of the downloaded .iso file? If not, go to the Linux Mint website and get the appropriate SHA256 number for the Cinnamon build, and then you can from Windows use the following guide https://forums.linuxmint.com/viewtopic.php?f=42&t=291093
  2. Have you tried the Sandisk stick in any other USB ports or on any other computer/s?
  3. Rufus seems to have good days and bad days. You could try using another burning solution such as Etcher (Balena Etcher) or Unetbootin and see if one of those makes a difference.
  4. Andy's suggestion above for Ventoy is a good option to see if other Distros work
  5. Do you know if your Graphics are nVidia or AMD Radeon or other?
Cheers

Chris Turner
wizardfromoz
 

Alexzee

Well-Known Member
Credits
5,778
The last 3 times I used Unetbootin it didn't work. Boots to a black screen and hangs.
Pretty sure it's broken:-
 

Members online


Top