Lubuntu doesn't find the wireless on my Lenovo laptop.

  • Thread starter Deleted member 151145
  • Start date

Deleted member 151145

I believe this is where I should be posting this. If not, feel free to move it.

OK. On a different board I made mention of installing Lubuntu, but it doesn't find my wireless. I'm going to answer a couple of questions and respond to a couple of comments here instead of where the conversation started.

AKAIK that's just a distro that uses LXDE - not affiliated with the project itself?
That's my understanding as well, but then, I'm not exactly a guru.

That's bizarre - 'cause Lubuntu *is* Ubuntu. It's the same under the skin and uses content from the Ubuntu repositories. You could probably look to see what the driver is in one that does work and then make sure that driver exists in Lubuntu. But, my understanding is you would like the least amount of friction.
You got that right. Like I said, every other Debian/Ubuntu/Mint derivative I had tried finds every piece of hardware correctly on every one of my laptops. Lubuntu is the first and only distro I tried installing that didn't find my wireless adapter. I know this USED to be a problem with a lot of distros, but that hasn't been a problem for a few years now. I did find one other distro that wouldn't find my wireless adapter, but the distro was some small, poorly supported one that didn't really surprise me by not finding my adapter.

I do prefer very little friction when installing or using a distro now days. Yes, I most definitely have gotten lazy when it comes to working on a computer. Part of the problem is that in the past 10 years, give or take, Linux and most every distro have really advanced when it comes to installing and running. The vast majority really do work OOTB. If the only thing we have to figure out is how to get the wireless adapter working on this one laptop, I'm pretty sure I can manage to stay with you when you are trying to help me.

Then, info on my wireless adapter was requested. I should have known to do that, but I just wasn't thinking. Here is what I have:

Network: Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 IF: enp2s0 state: down mac: 54:e1:ad:17:a3:97 Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi IF: wlp3s0 state: up mac: dc:8b:28:5e:1f:dc

Or here, if you can read it better:


Network: Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 IF: enp2s0 state: down
I would expect this to be down unless you are hard-wired to the router
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi IF: wlp3s0 state: up
this shows your Wi-fi is Intel and that it is up and running

now this is no way common but does happen with some distributions and machines,that the system doesn't see the RTL810xE Ethernet card. you could try from the terminal

modinfo r8169 | grep 8136 and enter
By all rights, that looks like wireless should be running. The driver is in the kernel for that. It says it's up and running.

If this is a laptop, double check to make sure you didn't put it into airplane mode.
Just in case rfkill is implicated, perhaps run:
systemctl status systemd-rfkill.service
and run as root:
rfkill list
to see if anything is blocked.
The rfkill list command will show if there is hard or soft block on the wifi card depending what it reveals we can go from there.
Also on some machines if you have the ethernet cable connected the Wifi will be disabled.
I've had laptops on the bench that had an OFF / ON switch on the front or side of the case or could be switched off somewhere on the keypad.
I've had laptops on the bench that had an OFF / ON switch on the front or side of the case or could be switched off somewhere on the keypad.
Yep, on my Lenovo its F8 key toggles wifi on and off.
Moving this to Linux Networking.


Well, here is the deal, I guess. First, none of my laptops are ever set for airplane mode. Second, every other Debian/Ubuntu/Mint distro and/or derivative I have ever tried on these laptops finds the adapter just fine so I don't believe it's anything I have set right or wrong on the machines. Note that Ubuntu and Xubuntu find and install the adapter just fine. The ONLY distro that WON'T find and install the adapter is Lubuntu.

Secondly, I was feeling pretty punk yesterday and hit the couch directly after supper. I was watching a movie and a thought hit me. I got up and tried running Lubuntu live on the laptop I have slated for my shop computer. It has a completely different wireless adapter in it. I got the same problem when it finally was up and running. It took FOREVER to load, but once it did, no wireless. So, I decided to try it on the laptop that is the server in my office. It also has a completely different wireless adapter so thought maybe at least one of the three would work. Nope. Things were even worse on it. It refused to even boot the DVD Live. I switched so I could see if there were any blatant errors shown during the boot process. Error after error, in bright red, telling me what failed to start and it included pretty much every component on the thing. Then, it just stopped, cold. I waited for an extra 15 minutes after it stopped to be sure it wasn't just working slowly, but it was dead at that point.

So, I'm going to give up on trying to get Lubuntu installed. I'm just no longer willing to spend that much time and effort, and spend half my waking hours on here, asking for more help, to get a distro installed on my computers. Back in the day this would have been the exact kind of thing I waited for. I just won't do it anymore.

Thanks to everyone that posted up, trying to help out, but I'm jumping ship before the water gets too deep. Instead, I'll be downloading and trying out several of the mainstream distros with XFCE or LXQT as default DE. I have Devuan XFCE, Fedora LXQT, MX Linux, and Xubuntu already downloaded. Will maybe try one or two later today. I guess I'll simply be looking for a distro that will load the desktop with as few resources used as possible. If anyone is running any flavor that uses either XFCE (preferably) or LXQT that uses very few resources to present the desktop, I'm open to suggestions. Thanks!
I have zero experience of Lubuntu. Same for ubuntu itself for that matter.

But.....what you are describing screams Reinstall out loud to me.

Preferably with a completely clear mindset. Something very basic has gone wrong...somewhere. That's a bit of a 'duh' statement on my part. ....but it won't be because it is Lubuntu. If it were, you would get a similar problem installing anything from that Ubuntu family.
Fresh approach....just one more time

{thoughts...different usb stick....different usb/iso app (balena?).....mix it up}
I say install LXLE and I'll almost bet it will pick up the wireless adapter.

I wouldn't let something like not being able to create an LXLE forum account stop you.

Most answers and solutions to just about any problem that any Linux distro can have or will have can be found here on

I'll say it again Linux is Linux imo.

If a forum account is that important for the Linux distro you use than install Xubuntu it's as good as Lubuntu imo.

I can say that because I use Lubuntu and Xubuntu just different DEs but they both work well imo.
Last edited by a moderator:
Condobloke, I'm not arguing. Please understand that. I am, however, kind of disagreeing with you. I have countless trials involved with both running the various distros live, as well as multiple attempts to install them. I agree that it makes absolutely no sense that Ubuntu and Xubuntu will both run Live on my computers as well as install on my computers with the wireless adapter found and installed correctly, but Lubuntu refuses to find the wireless adapters on ANY of my laptops either running Live or being installed. It makes no sense and seems impossible, but that is exactly what has happened over and over.

It's not that the forum is that important to me. I judge the condition of a project based partly on the activity on their stated forum. If the official forum is dead and you can't even get an account set up, how long is that distro going to be around? I have been told a couple times here on this forum that LXLE is pretty much on life support at the present time. I kind of confirmed that by not being able to get an account on their official forum approved. By the way, I still have never been approved.

I ran into a very similar problem with the SolydXK distro. There isn't even a place to try to register for that forum. I found that the latest release is supposedly version 10.4 that was released on July 5th of 2020. Yes, 2020, not 2022. That seems a little off, in itself. Then, I tried to find a place to download version 10.4, but the only link provided results in version 10.0 released on September 27th of 2019. That was enough to kill any chance of me trying to install it and run it.

Now, on to the good news. I just got done running Devuan 4.0.2 XFCE on this laptop and it performed perfectly and only required 380 MB of RAM to present the desktop. That's running Live with a few apps autostarted that I will remove. I expect to see less than 350 MB used when it is installed with the unnecessary apps removed from autostarting. I had ignored Devuan because it is a direct derivative of Debian and Debian and I don't get along really well. Since I seem to be having a lot of difficulties finding that one distro that fully suits me, I thought I'd give it a whirl just to see if it's something worth spending some time on. I won't get to it today, but I'll be doing an install of Devuan on my shop laptop probably tomorrow morning, I ran it on this laptop that I consider to be my daily driver and did quite a but of playing around on it. One of the things I did was login to my small engine repair Facebook page and proceeded to open multiple tabs and watch every video that came up. After spending about 10 minutes playing around on Facebook, and still with all the tabs opened ( I believe it was 15, but might have only been 14), I checked the RAM used and it was still only using 965 MB. That's more in line with what I think should be used for such things. I'm just hoping nothing pops up when I install it. With my luck it'll probably bomb off. LOL!
Condobloke, I'm not arguing.
@lonewolf ....such is not my nature either. We are a friendly crowd here, and you do fit right in.
i enjoy reading your posts.
SolydXK distro. There isn't even a place to try to register for that forum
LOL...well, that tells its own story !

Devuan 4.0.2 XFCE
i will take a gander at that....just for interests sake.

Just as a matter of interest.....I always use a torrent download to get the iso files for me.
HAH! I guess maybe I'm a little gun shy after the problems I ran into on thar other forum. I wasn't trying to argue over there, but apparently even expressing an opinion other than what the clique thinks was considered arguing.

I happened to read something else about Devuan that might be another reason to try getting it installed. I'm not trying to open a discussion about this since all I know about it is what I have read on a few informational sites. Devuan is a non-systemd distro. From reading what little I have, I can see where not using systemd could, in fact, make a distro quicker and use less resources. I have no idea if that's an absolute truth, but the little time I played with it running Live on my laptop seems to agree. Everything I tried doing was fairly quick, even launching a program, tweaking the appearance, or any of several other things that required reading from the DVD. I won't be positive about anything until I get it installed on my laptop. Running live is fine for getting a general idea about a distro, but my experience has been that I'm only certain after I have it installed to the hard drive and running.

I also ran across some info about that SolydXK distro. I actually did laugh out loud when I read it. It said that if you wanted to register for that forum, the only way was to do it from a smartphone. There was a very basic explanation of what you have to do and the "supposed" reason why. The only thought that went through my head was, why in the hell would you make a forum for a Linux distribution that is INTENDED FOR USE ON A COMPUTER only accessible via a smartphone? Then I laughed out loud. LOL!
Last edited by a moderator:
I paid an extremely quick visit to devuan's te earlier....possibly a bit too quick....I will revisit later in my day.
Had a further look....not for me.
@lonewolf ......different strokes for different folks !!

i guess I will just stick with LM21.1
Was there something specific about Devuan that you guys didn't like? If something really stands out as a reason to NOT use it, I'd appreciate seeing what it was. Considering my lack of understanding of the inner workings of Linux and my lack of skill on the command line, if something really stands out it would be a great help to me if I knew before spending time on it.

Members online