Manjaro is not showing in grub


New Member
Feb 19, 2021
Reaction score
My manjaro dist wouldn’t update and couldn’t find the mirrors.
I followed some tutorials from google to fix it but now I’ve made it even worse.
Only memtest86 was starting on boot.
It seemed that grub didn’t exist no more.
I have now followed tutorials to get grub back, but Manjaro is not showing in grub.
I only have a simple command line grub when booting.

I’ve also tried to delete the grub folder and do:

mkdir /boot/grub
grub-mkcondig -o /boot/grub/grub.cfg
grub-install /dev/sda

And tried following:

But when I reboot I still only have the bash like grub thingy.

[manjaro /]# inxi -Fza
12System:    12Kernel 5.8.6-1-MANJARO x86_64 12bits 64 12compiler gcc 12v 10.2.1
       12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=dk tz=UTC driver=free
       nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 misobasedir=manjaro
       misolabel=MANJARO_KDE_201 quiet systemd.show_status=1 apparmor=1 security=apparmor
       12Console N/A 12wm kwin_x11 12Distro Manjaro Linux
12Machine:   12Type Laptop 12System Acer 12product Aspire 5742G 12v V1.11 12serial <filter>
       12Mobo Acer 12model Aspire 5742G 12v V1.11 12serial N/A 12BIOS Acer 12v 1.11 12date 12/15/2010
12Battery:   12ID-1 BAT0 12charge 14.7 Wh 12condition 16.0/48.8 Wh (33%) 12volts 12.6/11.1
       12model Simplo Li_Ion_4000mA 12type Li-ion 12serial <filter> 12status Charging
12CPU:       12Info Dual Core 12model Intel Core i5 M 480 12bits 64 12type MT MCP 12arch Nehalem 12family 6
       12model-id 25 (37) 12stepping 5 12microcode 7 12L1 cache 64 KiB 12L2 cache 3 MiB 12L3 cache 2.9 MiB
       12flags lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 12bogomips 21285
       12Speed 1359 MHz 12min/max 1199/2667 MHz 12base/boost 2663/2666 12boost enabled 12volts 0.0 V
       12ext-clock 1066 MHz 12Core speeds (MHz) 121 1359 122 1477 123 1377 124 1375
       12Vulnerabilities 12Type itlb_multihit 12status KVM: VMX disabled
       12Type l1tf 12mitigation PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
       12Type mds 12status Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable
       12Type meltdown 12mitigation PTI
       12Type spec_store_bypass
       12mitigation Speculative Store Bypass disabled via prctl and seccomp
       12Type spectre_v1 12mitigation usercopy/swapgs barriers and __user pointer sanitization
       12Type spectre_v2 12mitigation Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP:
       conditional, RSB filling
       12Type srbds 12status Not affected
       12Type tsx_async_abort 12status Not affected
12Graphics:  12Device-1 Intel Core Processor Integrated Graphics 12vendor Acer Incorporated ALI
       12driver i915 12v kernel 12bus ID 00:02.0 12chip ID 8086:0046 12class ID 0300
       12Device-2 NVIDIA GF108M [GeForce GT 540M] 12vendor Acer Incorporated ALI 12driver nouveau
       12v kernel 12bus ID 01:00.0 12chip ID 10de:0df4 12class ID 0300
       12Device-3 ALi Gateway Webcam 12type USB 12driver uvcvideo 12bus ID 1-1.1:3 12chip ID 0402:9665
       12class ID 0e02
       12Display 12server 1.20.10 12compositor kwin_x11 12driver 12loaded intel,nouveau
       12unloaded modesetting 12alternate fbdev,nv,vesa
       12Message Advanced graphics data unavailable for root.
12Audio:     12Device-1 Intel 5 Series/3400 Series High Definition Audio 12vendor Acer Incorporated ALI
       12driver snd_hda_intel 12v kernel 12bus ID 00:1b.0 12chip ID 8086:3b56 12class ID 0403
       12Device-2 NVIDIA GF108 High Definition Audio 12vendor Acer Incorporated ALI
       12driver snd_hda_intel 12v kernel 12bus ID 01:00.1 12chip ID 10de:0bea 12class ID 0403
       12Sound Server ALSA 12v k5.8.6-1-MANJARO
12Network:   12Device-1 Broadcom NetLink BCM57780 Gigabit Ethernet PCIe 12vendor Acer Incorporated ALI
       12driver N/A 12port 3000 12bus ID 02:00.0 12chip ID 14e4:1692 12class ID 0200
       12Device-2 Qualcomm Atheros AR9287 Wireless Network Adapter 12vendor Foxconn T77H167.00
       12driver ath9k 12v kernel 12port 3000 12bus ID 03:00.0 12chip ID 168c:002e 12class ID 0280
       12IF wlp3s0 12state up 12mac <filter>
12Drives:    12Local Storage 12total 237.89 GiB 12used 48.39 GiB (20.3%)
       12ID-1 /dev/sda 12maj-min 8:0 12vendor Kingston 12model SA400S37240G 12family Driven SSDs
       12size 223.57 GiB 12block size 12physical 512 B 12logical 512 B 12sata 3.2 12speed 3.0 Gb/s
       12rotation SSD 12serial <filter> 12rev B1D1 12temp 30 C
       12SMART yes 12state enabled 12health PASSED 12on 5d 5h 12cycles 59 12read 64 GiB 12written 108 GiB
       12ID-2 /dev/sdb 12maj-min 8:16 12type USB 12vendor SanDisk 12model Ultra 12size 14.32 GiB
       12block size 12physical 512 B 12logical 512 B 12serial <filter> 12rev 1.00
       12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
12Partition: 12ID-1 / 12raw size 215.81 GiB 12size 211.42 GiB (97.97%) 12used 48.24 GiB (22.8%) 12fs ext4
       12block size 4096 B 12dev /dev/sda1 12maj-min 8:1
12Swap:      12Alert No Swap data was found.
12Sensors:   12System Temperatures 12cpu 59.0 C 12mobo N/A 12gpu nouveau 12temp 56.0 C
       12Fan Speeds (RPM) N/A
12Info:      12Processes 192 12Uptime 5m 12wakeups 1 12Memory 3.52 GiB 12used 1.58 GiB (44.9%) 12Init systemd
       12v 247 12Compilers 12gcc 10.2.0 12Packages 12pacman 1306 12lib 386 12flatpak 0
       12Client Unknown Client: systemd 12inxi 3.3.01
[manjaro /]# sudo parted -l
Model: ATA KINGSTON SA400S3 (scsi)
Disk /dev/sda: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End    Size    Type     File system     Flags
 1      1049kB  232GB  232GB   primary  ext4            boot
 2      232GB   240GB  8327MB  primary  linux-swap(v1)

Model: SanDisk Ultra (scsi)
Disk /dev/sdb: 15.4GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type     File system  Flags
 2      3100MB  3105MB  4194kB  primary               esp

[manjaro /]# sudo efibootmgr -v
EFI variables are not supported on this system.
[manjaro /]# test -d /sys/firmware/efi && echo efi || echo bios

Bash like grub thing?
Can you give more details please.

Do you mean that when Manjaro boots all you have is a bash shell only?
I only have a simple command line grub when booting.

do you mean you see something om booting like like:

grub >

is there anything else on /dev/sda apart from manjaro.

can you do output of :

fdisk -l     /dev/sda

this will show disk label type . i think yours is mbr. if you use :

grub-install /dev/sda     //installs grub 
grub-mkconfig -o /boot/grub/grub.cfg   //creates config files after grub has been installed

to be honest i no nothing of arch or manjaro , since i never got dissatisfied with slackware but on googling updating and mirrors seems to involve : /etc/pacman. d/mirrorlist
Last edited:
Looking at the output of parted -l OP allocated 232 Gig's for his /ext 4 partition and 8.3 Gig's for his it appears that he is using the entire HDD that's 240 GB's.
Hi @Burak998 well all i can tell you is my motherboard has UEFI firmware and the cpu is 64 bit ; i'm running slackware so that might be the element that makes all the difference ? from Buntu's etc

But thats the command i used to install grub2. It went fine :

ls /sys/firmware
acpi  dmi  efi	memmap

it seems to be booting efi , entries are there on the EFI partition.

there are also more specific commands such as:

#grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=grub

Staff online