Mint keeps disconnecting from wifi



What happens if you disable the wireless yourself and then try to reconnect? Does it fail then, as well as when it happens due to other circumstances?

If so, you might be looking at a bug. I had, still have I guess - as I've not fixed it but haven't used it lately, a laptop like that. If I disconnect from the wirelessly tethered phone, I have to reboot to connect to it again. In fact, I sometimes have to delete the existing connection and reboot in order for it to connect again.

Mint came that way, so I haven't dug into it. I don't use the device regularly anyhow.

Yes will connect fine.
 
Has the driver for the wifi has been updated? The wifi drivers in my machines are commonly updated for each new kernel release, and I dutifully install them. YMMV.

Yes all drivers are the latest.
 
Thanks, I'll give it a go but can't see a work around from the driver manager not letting me change anything as it considers all drivers up to date.....
 
Hi @ThinkPad,

Sometimes the problem in Mint lies in the auto power saving setting of the Network setting. Try this to turn it off and see if the disconnects go away. Go to a terminal and do the following
Code:
xed admin:///etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
When that file opens change The line that looks like this
Code:
wifi.powersave = 3
to look like this
Code:
wifi.powersave = 2
Save the file and reboot your machine. see if that cure the disconnects.
 
Thanks, just made the change from 3 to 2, will see how it goes.
 
I had this same issue on my Acer laptop running Linux Mint. I purchased a mini-USB wi-fi dongle and it has worked flawlessly ever since. I think the correct driver for my on-board wi-fi has since been added to the kernel but the USB dongle works perfectly so I haven't bothered to switch. It was the quickest easiest way to deal with the issue.
 
Sadly it didn't last long, still disconnecting and occasionally asking for network credentials.
 
Do you have secure boot if so turn it off in bios. Other things that can cause problem would be if for some reason your Internet signal is being disrupted. on some machines bluetooth can interfere with proper operation of the wifi card also. so if you have bluetooth and are not using it shut it off and try.
Install linssid in terminal
Code:
sudo apt install linssid
once installed run it from menu>internet it will show you all the signals in and around yours. if there is a lot of congestion on your channel see if you can change channel that your router is operating on. I live in an apartment complex and there litterall 100's of wifi signals. So I have to choose a channel that is the least congested. Also if for some reason your router's wifi signal is weak. You may need a more powerful router. Just suggestions to check out. Good Luck.
 
Last edited:
None of these things worked for me. I just connected the wifi USB through a hub and it works ok now.
 
Myself, if that was for a server I would never trust to a wireless signal for this very reason. Servers NEED to be "hard-wired" to Ethernet.

To my mind, there just IS no option here. Wireless is too unpredictable; out in the countryside - especially in rural parts of the USA, as I understand - there very often is no signal at all.....and in densely-populated areas, there's simply too many conflicting signals (and people attempting to "borrow", or to "piggy-back" on to someone else's signal 'cos they're too cheap to buy their own air-time).

And Centrino has a long history of being problematic. It was a good idea, but Intel didn't get it right on that occasion...

Nah. For a server - which needs to be reliable, with a constant connection - that ain't no good.


Mike. :rolleyes:
 

Members online


Top