• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Modified Grub, and made (another boo-boo)..... :<



I had trouble with Sleep Mode, and unintentionally sped up the Boot time, which took as long a Windows 8 (sometimes) did..... :) So I modified GRUB, using a tutorial on plus.google.com to fix Sleep Mode to make it stop freezing on System Resume on the Acer C720,, and now it even Boots even FASTER..... :D But, in closing that wound, I opened another..... :( It's hard to make it out, but whenever I go from Sleep Mode to uh..... Awake Mode, everything works, except..... In TTY, the BASH-only Interface, I see nothing but errors..... Like, a STREAM of them..... And the only way to fix it is to reboot..... :< Which is fine, since it's a whole lot faster from SeaBIOS to the Lightdm Login Screen..... *Sigh*..... I'm so sorry for all the issues, guys..... But if I can learn more, maybe I can return the favor..... :) Thanks guys....... :)

Something about error waking up or something..... Wait, I'll just reproduce the problem..... :) Ok: It says:

ehci-pci 0000:00:1d.0: port 1 resume error 19
ehci-pci 0000:00:1d.0: port 2 resume error 19

And it just keeps going that that, from port 1 and port 2, and ONLY when I use the TTYs..... :\ Let me reboot now, since that lid-closing I just did messes some things up..... :(

Oh wait: Before I do.....

This is Grub (Apparently there are TWO files of the same name, but this one I modified to be able to put my Chromebook to sleep when on Battery, or Charging, or what have you..... :) )

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#This comment isn't in the original file, but I put it here to show you what line I edited to do all this..... :) It's the one below..... ^^ Thank you SO MUCH..... ^^
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash add_efi_memmap boot=local noresume noswap i915.modeset=1 tpm_tis.force=1 tpm_tis.interrupts=0 nmi_watchdog=panic,lapic"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
Sounds like a USB wakeup issue... I believe I've read that that can be the cause of tooth gnashing.
https://plus.google.com/ PedroLarroy/posts/6CgQypQukMa

seems to be a known issue with Chromebooks. (a driver issue no doubt)

I just got my Charger from Ebay..... :3 So I can get back to using Linux again..... :D :D :D :D :D I'll still use my RT, of course, but..... ;D While I was away, I've been studying a Python Virus of sorts, that alters text in ANY ".py" file...... :3 But I can protect against that by altering Folder Permissions, so..... :D Anyway, I'll check out that link..... Thanks!!..... ^^

Members online