MX Linux - Keyboard malfunction

kurp

New Member
Joined
Nov 30, 2023
Messages
5
Reaction score
0
Credits
38
After latest updates my keyboard is not responding well. Key like back space, letter d, enter not responding. This is happening for the past 2weeks after latest updates. I have Asus Tuf laptop.

Any help greatly appreciated
 


G'day kurp, Welcome to Linux.org

Do you have Timeshift set up ? Simply restore to a snapshot taken before the updates took place
 
No, but I still would like to hold on to latest updates. It feels like linux GRAB is screwing it as on the login screen I see the problem...
 
You just lost me...I have no experience of an app called grab

Is this a screengrab?...or something to grab video data ?...etc

Is it possible that deleting this app will make the problem go away?
 
After latest updates my keyboard is not responding well. Key like back space, letter d, enter not responding. This is happening for the past 2weeks after latest updates. I have Asus Tuf laptop.

Any help greatly appreciated
Check the defaults:
Code:
cat /etc/default/keyboard

As it says, "Consult the keyboard manpage" if you need to alter details.

Perhaps try to reconfigure the keyboard, as root:
Code:
dpkg-reconfigure keyboard-configuration
 
Last edited:
Asus laptop is correct configuration:

$ cat /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="asus_laptop"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"
 
Asus laptop is correct configuration:

$ cat /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="asus_laptop"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"
You could alter XKBMODEL="asus_laptop", to: XKBMODEL="pc105", since pc105 is the default on so many machines, and basically works with nearly all hardware. After altering it, perhaps reboot to ensure the config is registered. If it makes no difference, it's entirely reversible.
 
Sorry I meant grub.
Also, I changed to XKBMODEL="pc105" but it didn't help.
 
Sorry I meant grub.
Also, I changed to XKBMODEL="pc105" but it didn't help.
Thanks for that result.

The problem would be greatly helped by determining if its a hardware or software problem.

If you are running a distro which uses apt and dpkg, then you could "test" the software with the command mentioned in post #5:
Code:
dpkg-reconfigure keyboard-configuration

If using some other distro, choose that distro's keyboard reconfiguration tool, for example in fedora with gnome, it's: gnome-tweaks. And if running X with some other DE, it's the programs: setxkbmap and xmodmap, among others.

To check whether there's a hardware problem, one approach is to boot to a text prompt on a console, that is, boot without the GUI. Here is an example of instructions to do that in case you need it:

When on the console, press every key on the keyboard numerous times to make sure that it has the intended effect. If it does, then the problem is likely not hardware.

If the problem is not hardware, then the options really reduce to doing reconfigurations with the software programs mentioned above, or others that you may find useful.
 
Time to give up MX Linux...for over two weeks I cannot solve the issue with the keyboard. Thats a pity with Linux distros....you start using, getting used an start to love it...and then comes an update that completely makes it useless. Well over past 5 years I changed distros 5 times...
 


Latest posts

Top