MX Linux systemd Doesn't Login After Installing Nvidia Driver


New Member
Sep 22, 2023
Reaction score
Hi mates,

I've installed Nvidia driver using the provided MX Linux KDE's Nvidia driver installer. Now cannot login to systemd anymore. Sysvinit works but with low resolution.

I did all these but the issue persists:
  • The inxi -G shows the right Nvidia driver is installed and used.
  • Tried the Test Repo driver.
  • Downloaded and installed the latest compatible version from Nvidia website and installed manually.
  • Removed /etc/X11/xorg.conf suggested by
  • Installed the older version 470 which was previously tested and worked on my Ubuntu.
  • Rebooted with any step above.
I have to go with the non-free driver since my computer freezes every once in a while with nouveau driver.

I highly appreciate any help!

  Kernel: 6.1.0-10-amd64 [6.1.38-2] arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1.0-10-amd64 root=UUID=<filter> ro quiet splash
    resume=UUID=<filter> resume_offset=8423424
  Desktop: KDE Plasma v: 5.27.5 wm: kwin_x11 vt: 7 dm: SDDM Distro: MX-23_KDE_x64 Libretto July
    31 2023 base: Debian GNU/Linux 12 (bookworm)
  Type: Laptop System: ASUSTeK product: GL702VSK v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: GL702VSK v: 1.0 serial: <superuser required> UEFI: American Megatrends
    v: GL702VSK.311 date: 04/19/2019
  ID-1: BAT0 charge: 29.4 Wh (100.0%) condition: 29.4/76.0 Wh (38.6%) volts: 15.2 min: 15.2
    model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: not charging cycles: 104
  Info: model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake gen: core 7 level: v3
    note: check built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 9
    microcode: 0xF4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 2600 high: 2800 min/max: 800/3800 scaling: driver: intel_pstate
    governor: powersave cores: 1: 2800 2: 2800 3: 1200 4: 2800 5: 2800 6: 2800 7: 2800 8: 2800
    bogomips: 44798
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP104BM [GeForce GTX 1070 Mobile] vendor: ASUSTeK driver: nvidia v: 525.125.06
    non-free: 530.xx+ status: current (as of 2023-03) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1be1
    class-ID: 0300
  Device-2: Realtek USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 1-4:2
    chip-ID: 0bda:57fa class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: with: Xwayland v: 22.1.9 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 128 s-size: 762x211mm (30.00x8.31") s-diag: 791mm (31.13")
  Monitor-1: DP-4 pos: right res: 1920x1080 hz: 60 dpi: 128 size: 382x215mm (15.04x8.46")
    diag: 438mm (17.26") modes: N/A
  Monitor-2: HDMI-0 pos: primary,left res: 1920x1080 hz: 60 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 525.125.06 renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2
    direct-render: Yes
  Device-1: Intel CM238 HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
    chip-ID: 8086:a171 class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10f0 class-ID: 0403
  API: ALSA v: k6.1.0-10-amd64 status: kernel-api tools: alsamixer,amixer
  Server-1: PipeWire v: 0.3.65 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wireless 8260 driver: iwlwifi v: kernel modules: wl pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:24f3 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 04:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: eth0 state: down mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-9:6
    chip-ID: 8087:0a2b class-ID: e001
  Report: hciconfig ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 2.1 lmp-v: 4.2
    sub-v: 100 hci-v: 4.2 rev: 100
  Info: acl-mtu: 1021:4 sco-mtu: 96:6 link-policy: rswitch sniff link-mode: peripheral accept
    service-classes: rendering, capturing, object transfer, audio, telephony
  Local Storage: total: 715.41 GiB used: 76.27 GiB (10.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 PRO 512GB size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 4B6Q
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Sabrent model: SABRENT size: 238.47 GiB
    block-size: physical: 4096 B logical: 512 B type: N/A serial: <filter> rev: 0204 scheme: MBR
  ID-1: / raw-size: 133.78 GiB size: 130.62 GiB (97.64%) used: 76.22 GiB (58.4%) fs: ext4
    dev: /dev/sda4 maj-min: 8:4
  ID-2: /boot/efi raw-size: 261 MiB size: 259.9 MiB (99.62%) used: 50.1 MiB (19.3%) fs: vfat
    dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 15 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 28.42 GiB used: 0 KiB (0.0%) priority: -2 file: /swap/swap
  System Temperatures: cpu: 66.0 C pch: 59.5 C mobo: N/A gpu: nvidia temp: 65 C
  Fan Speeds (RPM): cpu: 3300
  Packages: pm: dpkg pkgs: 2689 libs: 1515 tools: apt,apt-get,aptitude,nala,synaptic pm: rpm
    pkgs: 0 pm: flatpak pkgs: 0
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
    1: deb bookworm-updates main contrib non-free non-free-firmware
  Active apt repos in: /etc/apt/sources.list.d/debian.list
    1: deb bookworm main contrib non-free non-free-firmware
    2: deb bookworm-security main contrib non-free non-free-firmware
  Active apt repos in: /etc/apt/sources.list.d/google-chrome.list
    1: deb [arch=amd64] stable main
  Active apt repos in: /etc/apt/sources.list.d/microsoft-prod.list
    1: deb [arch=amd64,arm64,armhf signed-by=/usr/share/keyrings/microsoft-prod.gpg] bookworm main
  Active apt repos in: /etc/apt/sources.list.d/mx.list
    1: deb bookworm main non-free
    2: deb bookworm ahs
  Active apt repos in: /etc/apt/sources.list.d/skype-stable.list
    1: deb [arch=amd64] stable main
  Active apt repos in: /etc/apt/sources.list.d/vscode.list
    1: deb [arch=amd64,arm64,armhf] stable main
  Processes: 282 Uptime: 4m wakeups: 2 Memory: 23.42 GiB used: 3.12 GiB (13.3%) Init: SysVinit
  v: 3.06 runlevel: 5 default: graphical tool: systemctl Compilers: gcc: 12.2.0 alt: 12
  Client: shell wrapper v: 5.2.15-release inxi: 3.3.26
Boot Mode: UEFI

Thanks for the response Brickwizard!

I tried installing your suggested driver manually. It gives me some odd errors which installation fails. I installed newer drivers manually with no error so I think my installation method is fine using

The drivers I picked are suggested both on Nvidia website and MX Nvidia Installer. Installed nvidia-legacy-390xx-driver which is the oldest in the MX installer's list yet getting low resolution. The screenshot shows what I get with the installer.


  • mx installer.png
    mx installer.png
    94.2 KB · Views: 134
Last edited:
That driver version should be compatible with your GPU.

Here's reference Supported GPU's

Have you tried installing drivers using the debian wiki, MX is debian based so it should work.

Thanks for the suggestion mate.
I just did it using THIS PAGE and unfortunately the issue persists. It seemed to me MX Linux installer is using the same method.
Last edited:
Hi,I had a similar problem. On MX Linux with KDE.The display manager sddm was to blame.I then installed gdm3 and haven't had any problems so far.

Members online