• We did not send an email asking for donations - please read this post.

MXLinux: SSD invisible

foobar900

New Member
Joined
Feb 3, 2022
Messages
1
Reaction score
0
Credits
23
Hello,

I've been a happy user of MXLinux on a macbook air (with a SSD, encrypted). Today I compiled a new kernel and unfortunately the machine did not boot anymore: whatever kernel I tried to boot, the system does not ask for the password to unlock the partition anymore
and instead falls back to the initramfs BusyBox.

If I "exit", I get a message saying
"Gave up waiting for root file system device […] ALERT! UUID=xxxx does not exist. Dropping to a shell"
Indeed, the given UUID does not show up when I do a blkid. I tried to edit the grub entries to put the "correct" UUID (essentially, the UUID appears 3 times in a grub entry, the first two are OK, the third one is the weird unknown one. But changing it does not help (same message, but with the "correct UUID" this time).

I thought I'd solve things using a live MXLinux on a USB stick, but here the weirder things begin: if I boot a live MXLinux (21, wildflowers), there is no trace of my SSD anymore. No program I could think of seems to find it.

But let me point out that when I try a "normal" boot as above (via grub), the dmesg shows the SSD is indeed found:
"sd 0:0:0:0: [sda] 49023xxx 512-byte logical blocks: (251 GB/234 GiB)"
and so one, with 4 partitions sda1 to sda4.
ending with
"sd 0:0:0:0: [sda] Attached SCSI disk".

I don't know what to do from here… commands in this BusyBox seem quite limited.
I'm fine with reinstalling everything, but I'd like to be able to make a copy of my encrypted home (well, with being able to uncrypt it also at some point!).

Any help much appreciated, thanks!
 


D

Deleted member 140690

Guest
Interesting scenario, I wonder if @foobar900 found a fix.
 
Last edited by a moderator:
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top