Need help installing Overwatch

BauaMomo

New Member
Credits
28
So I am a total noob regarding Linux, I just installed Pop!_OS as a second OS next to Win10 and I might even switch, but first I want to see how easy it is to get some games to run.
At the moment I'm stuck at Overwatch. I'm trying to install it using Lutris and follow the istructions it gives me (this guide), but I'm running into a few problems.

Firstly, installing DXVK as it says in this video which is linked in the install guide doesn't work, running
./package-release.sh master /home/(name)/.local/share/lutris/runtime/dxvk/dxvk-async --no-package
gives me the error:
.package-release.sh: line 51: meson: command not found

I should probably mention that git checkout async also doesn't work

I don't even know if I actually need DXVK for now, because other guides said that it can also be installed after the game itself is installed. Also Lutris itself says that "The installer provides a pre-generated DXVK state cache"

If I try to install Overwatch through Lutris without DXVK the Battle.net installer is stuck at about 30% of "Updating Blizzard agent" and it says
0058:fixme:kernelbase:AppPolicyGetThreadInitializationType FFFFFFFA, 0126FF10
in the terminal.

So I'm just generally really confused what to do or which guide to follow since they all seem to do things differently. I hope you can help me.

My System:
Ryzen 1600x
RTX 2070 Super
16 Gb RAM
Pop!_OS 20.04 64-bit
 


f33dm3bits

Gold Member
Gold Supporter
Credits
3,480
Code:
.package-release.sh: line 51: meson: command not found
You're missing the package meson on your system.
Code:
sudo apt-get install meson
Code:
I should probably mention that git checkout async also doesn't work
No I idea where you go that from but the official Lutris guide doesn't mention that.
Code:
If I try to install Overwatch through Lutris without DXVK the Battle.net installer is stuck at about 30% of
That sounds like the issue mentioned under know issues and troubleshooting, but they basically tell you to make sure you have the correct drivers installed including the 32-bit nvidia-utils or mesa.
 

BauaMomo

New Member
Credits
28
I have it running now, thanks.

For future people:

The meson thing: I just installed it wrong, idk.
Git checkout async (that was shown in the video I linked): I just left it.
Stuck installer: I missed something when installing the drivers.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
3,480
I have it running now, thanks.

For future people:

The meson thing: I just installed it wrong, idk.
Git checkout async (that was shown in the video I linked): I just left it.
Stuck installer: I missed something when installing the drivers.
The youtube video links to this github repository in the video description while in the video they use this github repository. The first one doesn't have a branch async, if you try the second one it does. Not sure if that is a mistake but you could probably best ask that on the on the Lutris forums on by asking it on their github issues as a question.
 
Last edited:


Members online


Top