Need Help with Samba permissions on sub directories.


New Member

I am still quite new to Linux, I have an HP micro server with an SSD and 4 drives. This used to be a windows server until it caught a power spike and fried the old SSD.
I decided I needed a change in my life and want to get better at Linux. So I installed Ubuntu server 18.04 and slapped a gui onto it.

Then I mounted all 4 of the previous windows ntfs drives into FSTAB and installed Samba.

I created a public share and set the config for an SMBGroup and a user to access it. All went well there.

My issue now comes onto the 4 devices which I would like to share. Since I am unable to just Right click and share the devices from the gui I have to do it from the command line and SMB config.

I set the following in the smb.conf


path = /media/"user"/908A20538A2037DC/Pictures
browseable = yes
writable = yes
read only = no
force user = "user"
force group = "user"

This allows the windows pc to access the pictures share, but I cannot access any of the containing files or folders as they all belong to Root and not the user for the share. In windows you can edit file permissions and set to push to all subfolders and files, I have no clue how to do that in Linux.

I tried to set the permissions from the GUI, but I don't see an option to apply to subfolders and files as well. Except for an "Apply permissions to enclosed files buttons" which doesn't seem to do anything as the permissions on folders within pictures do not get the same settings, they stay allocated to root. (yes, I did open the file explorer as superuser)

Also would it be possible to share the root of the drive (UUID) 908A20538A2037DC instead of individual folders within?



Well-Known Member
If I understood well we want to have a FTP server , why don’t you install owncloud or nextcloud app on top of Ubuntu server?


New Member
If I understood well we want to have a FTP server , why don’t you install owncloud or nextcloud app on top of Ubuntu server?
No sorry, I dont want to run ftp. I want to share folders using smb from ubuntu server to a windows machine. Like sharing on local lan between windows PC's.

I can finally get a public share to work. But when I want a protected share. Windows cannot access the share with the username and password configured with smbpasswd -a username.
It just says access denied.

I tried installing webmin and configured smb from there with the same results.
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online