New Computer Build - BrosTrend AC1200 Won't connect to WiFi

pizzipie

New Member
Credits
170
My OS - Ubuntu Mate 18.04.

I just completed my first computer build. The ethernet works just fine. The WiFi does not and I'm trying to get this to work.
I have a BrosTrend AC1200 Model AC3L Wireless USB Adapter for Linux. I have talked to BrosTrend support and have done the troubleshooting procedure they subscribe to. The answer they gave me is that their driver is installed satisfactorily and I can return the unit if I want.

This is not the answer I want to hear. The attached file has data from a group of commands that I copied from the internet and includes all system information regarding this new build .

Thank you in advance for help.

R

Can't get the file to open!!! HERE'S the info.

Sun 20 Sep 2020 02:22:14 PM PDT








[email protected]:~$ inxi -Fwz





System: Host: rick-MS-7C02 Kernel: 5.4.0-47-generic x86_64 bits: 64


Desktop: MATE 1.20.1 Distro: Ubuntu 18.04.5 LTS


Machine: Device: desktop System: Micro-Star product: MS-7C02 v: 1.0 serial: N/A


Mobo: Micro-Star model: B450 TOMAHAWK MAX (MS-7C02) v: 1.0 serial: N/A


UEFI [Legacy]: American Megatrends v: 3.70 date: 06/09/2020


CPU: Quad core AMD Ryzen 5 3400G with Radeon Vega Graphics (-MT-MCP-)


cache: 2048 KB


clock speeds: max: 3152 MHz 1: 2018 MHz 2: 3048 MHz 3: 1541 MHz


4: 1756 MHz 5: 1657 MHz 6: 3152 MHz 7: 1491 MHz 8: 2471 MHz


Graphics: Card: Advanced Micro Devices [AMD/ATI] Picasso


Display Server: x11 (X.Org 1.20.8 )


drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa)


Resolution: [email protected]


OpenGL: renderer: AMD RAVEN (DRM 3.35.0, 5.4.0-47-generic, LLVM 10.0.0)


version: 4.6 Mesa 20.0.8


Audio: Card-1 Advanced Micro Devices [AMD] Device 15e3 driver: snd_hda_intel


Card-2 Advanced Micro Devices [AMD/ATI] Device 15de


driver: snd_hda_intel


Sound: Advanced Linux Sound Architecture v: k5.4.0-47-generic


Network: Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller


driver: r8169


IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>


Drives: HDD Total Size: 500.1GB (2.5% used)


ID-1: /dev/nvme0n1 model: WDC_WDBA3V5000ANC size: 500.1GB


Partition: ID-1: / size: 458G used: 12G (3%) fs: ext4 dev: /dev/nvme0n1p1


RAID: No RAID devices: /proc/mdstat, md_mod kernel module present


Sensors: System Temperatures: cpu: No active sensors found. Have you configured your sensors yet? mobo: N/A


Weather: Weather data failure: Sun Sep 20 14:19:00 PDT 2020


Error: weather info downloaded but no data detected.


Info: Processes: 260 Uptime: 1:06 Memory: 1475.4/14004.8MB


Client: Shell (bash) inxi: 2.3.56


[email protected]:~$








[email protected]:~$ ifconfig





enp34s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500


inet 192.168.1.175 netmask 255.255.255.0 broadcast 192.168.1.255


inet6 2605:e000:1b04:ce7:675e:e672:2bbf:4ca1 prefixlen 64 scopeid 0x0<global>


inet6 2605:e000:1b04:ce7:876:c2a3:8747:f99 prefixlen 64 scopeid 0x0<global>


inet6 fe80::3c3e:b2cc:15ac:8b9e prefixlen 64 scopeid 0x20<link>


inet6 2605:e000:1b04:ce7:0:22c9:d74d:61e4 prefixlen 128 scopeid 0x0<global>


ether 2c:f0:5d:7b:a3:97 txqueuelen 1000 (Ethernet)


RX packets 12804 bytes 8141651 (8.1 MB)


RX errors 0 dropped 0 overruns 0 frame 0


TX packets 11996 bytes 2676008 (2.6 MB)


TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0





lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536


inet 127.0.0.1 netmask 255.0.0.0


inet6 ::1 prefixlen 128 scopeid 0x10<host>


loop txqueuelen 1000 (Local Loopback)


RX packets 1900 bytes 197703 (197.7 KB)


RX errors 0 dropped 0 overruns 0 frame 0


TX packets 1900 bytes 197703 (197.7 KB)


TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0





wlx4401bb92f088: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500


ether 44:01:bb:92:f0:88 txqueuelen 1000 (Ethernet)


RX packets 0 bytes 0 (0.0 B)


RX errors 0 dropped 0 overruns 0 frame 0


TX packets 0 bytes 0 (0.0 B)


TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


[email protected]:~$ iwconfig

enp34s0 no wireless extensions.
lo no wireless extensions.





wlx4401bb92f088 unassociated Nickname:"<[email protected]>"


Mode:Managed Frequency=2.412 GHz Access Point: Not-Associated


Sensitivity:0/0


Retry:eek:ff RTS thr:eek:ff Fragment thr:eek:ff


Power Management:eek:ff


Link Quality=0/100 Signal level=0 dBm Noise level=0 dBm


Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0


Tx excessive retries:0 Invalid misc:0 Missed beacon:0














[email protected]:~$ sudo lspci | grep net





22:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)





[email protected]:~$ sudo lshw -C network





*-network


description: Ethernet interface


product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller


vendor: Realtek Semiconductor Co., Ltd.


physical id: 0


bus info: [email protected]:22:00.0


logical name: enp34s0


version: 15


serial: 2c:f0:5d:7b:a3:97


size: 1Gbit/s


capacity: 1Gbit/s


width: 64 bits


clock: 33MHz


capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation


configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.1.175 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s


resources: irq:34 ioport:f000(size=256) memory:fcc04000-fcc04fff memory:fcc00000-fcc03fff








*-network


description: Wireless interface


physical id: 1


bus info: [email protected]:2


logical name: wlx4401bb92f088


serial: 44:01:bb:92:f0:88


capabilities: ethernet physical wireless


configuration: broadcast=yes driver=rtl88x2bu multicast=yes wireless=unassociated





[email protected]:~$ ip addr





1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000


link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00


inet 127.0.0.1/8 scope host lo


valid_lft forever preferred_lft forever


inet6 ::1/128 scope host


valid_lft forever preferred_lft forever


2: enp34s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000


link/ether 2c:f0:5d:7b:a3:97 brd ff:ff:ff:ff:ff:ff


inet 192.168.1.175/24 brd 192.168.1.255 scope global dynamic noprefixroute enp34s0


valid_lft 256823sec preferred_lft 256823sec


inet6 2605:e000:1b04:ce7:0:22c9:d74d:61e4/128 scope global dynamic noprefixroute


valid_lft 594426sec preferred_lft 594426sec


inet6 2605:e000:1b04:ce7:876:c2a3:8747:f99/64 scope global temporary dynamic


valid_lft 510378sec preferred_lft 83486sec


inet6 2605:e000:1b04:ce7:675e:e672:2bbf:4ca1/64 scope global dynamic mngtmpaddr noprefixroute


valid_lft 510378sec preferred_lft 510378sec


inet6 fe80::3c3e:b2cc:15ac:8b9e/64 scope link noprefixroute


valid_lft forever preferred_lft forever


3: wlx4401bb92f088: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000


link/ether 44:01:bb:92:f0:88 brd ff:ff:ff:ff:ff:ff








[email protected]:~$ nmcli dev show





GENERAL.DEVICE: enp34s0


GENERAL.TYPE: ethernet


GENERAL.HWADDR: 2C:F0:5D:7B:A3:97


GENERAL.MTU: 1500


GENERAL.STATE: 100 (connected)


GENERAL.CONNECTION: Wired connection 1


GENERAL.CON-PATH: /org/freedesktop/NetworkManager/ActiveCo


WIRED-PROPERTIES.CARRIER: on


IP4.ADDRESS[1]: 192.168.1.175/24


IP4.GATEWAY: 192.168.1.1


IP4.ROUTE[1]: dst = 0.0.0.0/0, nh = 192.168.1.1, mt =


IP4.ROUTE[2]: dst = 192.168.1.0/24, nh = 0.0.0.0, mt =


IP4.ROUTE[3]: dst = 169.254.0.0/16, nh = 0.0.0.0, mt =


IP4.DNS[1]: 192.168.1.1


IP4.DOMAIN[1]: home


IP6.ADDRESS[1]: 2605:e000:1b04:ce7:0:22c9:d74d:61e4/128


IP6.ADDRESS[2]: 2605:e000:1b04:ce7:876:c2a3:8747:f99/64


IP6.ADDRESS[3]: 2605:e000:1b04:ce7:675e:e672:2bbf:4ca1/6


IP6.ADDRESS[4]: fe80::3c3e:b2cc:15ac:8b9e/64


IP6.GATEWAY: fe80::366b:46ff:fe3c:fb6e


IP6.ROUTE[1]: dst = 2605:e000:1b04:ce7::/64, nh = ::,


IP6.ROUTE[2]: dst = ::/0, nh = fe80::366b:46ff:fe3c:fb


IP6.ROUTE[3]: dst = ff00::/8, nh = ::, mt = 256, table


IP6.ROUTE[4]: dst = fe80::/64, nh = ::, mt = 256


IP6.ROUTE[5]: dst = fe80::/64, nh = ::, mt = 100


IP6.ROUTE[6]: dst = 2605:e000:1b04:ce7:0:22c9:d74d:61e


IP6.DNS[1]: 2001:1998:f00:1::1


IP6.DNS[2]: 2001:1998:f00:2::1





GENERAL.DEVICE: wlx4401bb92f088


GENERAL.TYPE: wifi


GENERAL.HWADDR: 44:01:BB:92:F0:88


GENERAL.MTU: 1500


GENERAL.STATE: 30 (disconnected)


GENERAL.CONNECTION: --


GENERAL.CON-PATH: --





GENERAL.DEVICE: lo


GENERAL.TYPE: loopback


GENERAL.HWADDR: 00:00:00:00:00:00


GENERAL.MTU: 65536


GENERAL.STATE: 10 (unmanaged)


GENERAL.CONNECTION: --


GENERAL.CON-PATH: --


IP4.ADDRESS[1]: 127.0.0.1/8


IP4.GATEWAY: --


IP6.ADDRESS[1]: ::1/128


IP6.GATEWAY: --


IP6.ROUTE[1]: dst = ::1/128, nh = ::, mt = 256


lines 27-49/49 (END)








[email protected]:~$ netstat -nn





Kernel IP routing table


Destination Gateway Genmask Flags MSS Window irtt Iface


0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 enp34s0


169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 enp34s0


192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 enp34s0








[email protected]:~$ cat /etc/resolv.conf





# This file is managed by man:systemd-resolved(8). Do not edit.


# I deleted all the comment lines ... Rick 19Sep2020





nameserver 127.0.0.53


options edns0


search home
 

Attachments

Last edited:


arochester

Moderator
Staff member
Gold Supporter
Credits
2,109
lspci does not need to be sudo. My laptop shows nothing with |grep net. It needs to be |grep Network -with capital N

BUT you have a USB unit and the command needs to be just
Code:
lsusb
Did you have the unit plugged in first and then start your computer second, so it can be recognised?
 

pizzipie

New Member
Credits
170
lspci does not need to be sudo. My laptop shows nothing with |grep net. It needs to be |grep Network -with capital N

BUT you have a USB unit and the command needs to be just
Code:
lsusb
Did you have the unit plugged in first and then start your computer second, so it can be recognised?
Well I feel really stupid!!
Your answer gave my brain a jolt. I just built the computer and are not familiar with all the connections so I tried another USB connection and IT WORKED.

Thanks for the help.\\R
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
6,059
@pizzipie - G'day Rick and welcome to linux.org :)

Congrats on getting it sorted. If you get a chance, swing over to Member Introductions and say Hi and meet a few of The Gang.

Enjoy your Linux.

Chris Turner
wizardfromoz
 


Members online


Latest posts

Top