• We did not send an email asking for donations - please read this post.

New to Linux - VPN Connection Issue


New Member
Jun 24, 2022
Reaction score

I hope this is the correct place to post this. I am new linux, just wiped my drive from windows(accidentally trying to setup dual-boot lol) and installed Ubuntu. I love it! Definitely different environment. I am a fan of VPNs, specifically ProtonVPN's service. I downloaded the .deb file, ran it, and it installed with no fault at all. I could connect perfectly! The next day, i boot up my machine and there's no internet at all... even the wired connection icon was gone from the top right corner. So after 2 hours of research i ran "sudo dhclient eth0" which worked! Reason i give all this info is now, when i quick connect to protonVPN, the internet does not work. The browser just hangs. When i disconnect, bam! connection is back. Im on my third day of research and just cant figure this out. Im following the steps on their website and they advise to install "resolveconf" first. This is where i am now. Per my research resolve.conf should be preinstalled. When i goto my /etc folder and run "sudo ln -s /run/resolvconf/resolv.conf" it says "file exists"... so its there. But, when i run "sudo apt install resolvconf" it says:

Package resolvconf is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package 'resolvconf' has no installation candidate

Now i have tried to install 3 other packages, via .deb files, and this same error message comes up. I am 100% brand new to linux but understand the logic behind it. I have tried countless commands in the CLI from others but no one seems to have this issue. I feel as though there is some TCP connection Proton has taken, or some port that has been changed? Theres not much info on Protons website for this issue so any guidance is appreciated. I apologize for any ignorance in terms i am using incorrectly. I am here to learn! Thank you all!


Gold Member
Gold Supporter
Dec 11, 2019
Reaction score
It would be useful if you shared the output of the following commands when connected to your vpn.
ip a
ip route
cat /etc/resolv.conf
nmcli connection show "connection name"
Ubuntu normally installs all the needed packages for a network connection so it seems like something is not going right with the vpn or something like that.

Lord Boltar

Well-Known Member
Nov 24, 2020
Reaction score
First it is called resolv.conf which is preinstalled usually in 3 places /etc and /run/NetworkManager and lib/systemd

It has a "killswitch" make sure it is not engaged usually on the bottom right of the Quick Start menu
another option is to remove the ipv6 leak protection first close Proton then run
sudo nmcli connection delete pvpn-ipv6leak-protection
then reopen Proton does it connect?

have a look here - https://askubuntu.com/questions/1319033/internet-stops-working-after-installing-protonvpn
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online