No leap 15.3 for fish on any site where I can download 'fish'! When I do download file and try to install I get the errors depicted in the picture...

kevomac12

New Member
Joined
Jun 8, 2022
Messages
3
Reaction score
0
Credits
31
1654789987312.png


I need to load fish, Konsole sucks...need assistance Please!!
 


Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,757
Reaction score
1,175
Credits
13,083
Last edited:
OP
K

kevomac12

New Member
Joined
Jun 8, 2022
Messages
3
Reaction score
0
Credits
31
Thank you...I am on a work computer and don't have say so for upgrading to 15.4.
As soon as I get in on Friday, I'll try your suggestion...here's pray'n it works!

Thanks again, Kevin
 
OP
K

kevomac12

New Member
Joined
Jun 8, 2022
Messages
3
Reaction score
0
Credits
31
According to your photo - you have - repository SUSE:SLE-15-SP1:GA is invalid

run -
Code:
zypper lr
- and see if those repos are disabled and those repos are for the SLE (SUSE Linux Enterprise) not Leap

Direct link for 15.3 Fish Repository - https://download.opensuse.org/repositories/shells:fish/openSUSE_Leap_15.3/shells:fish.repo
Install the repository
Then try to install Fish

The next option is to upgrade to 15.4
abyss:~/Downloads # zypper install shells fish.repo
Retrieving repository 'SUSE:SLE-15-SP1:GA' metadata ..............................................................................................................................................[error]
Repository 'SUSE:SLE-15-SP1:GA' is invalid.
[https-download.opensuse.org-1f4125c9|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/GA/pool/] Valid metadata not found at specified URL
History:

- [https-download.opensuse.org-1f4125c9|https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/GA/pool/] Repository type can't be determined.

The "zypper lr" revealed the following:
"4 | https-download.opensuse.org-25d22778 | shells:fish:release:3 | Yes | (r) Yes | Yes | rpm-md".
As I am a neophyte to "openSuse (Leap 15.3) Linux" environment, having spent more time in DOS/Wiindows.

I can use the help with understanding, what the heck is on with openSuse. What does the bold text mean, and do I need to reinstall the Respository SUSE:SLE-15-SP1:GA??

Kevin
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation


Top