No sound

Granny Sue

Well-Known Member
Credits
0
I recently installed Linux Mint on a Compaq PC that a was in danger of being thrown away. I don't know anything about this PC other than that. Now that I have it up and running and have accessed the internet, I tried going to YouTube to see if I had sound. I don't, and I don't know how to find out why. Would someone be able to help me? Also, I didn't know if I should post this under Mint or General Computing, so please letme know if I need to move this. @atanere, I bet this would be a good time for a command line, ;).
 
Last edited:


atanere

Well-Known Member
Credits
0
Hey Sue! Sound is one of the most common problems. Both comments from @dos2unix and @arochester are good ideas. There are many possible solutions in the link, so check them all carefully. One will probably work. I'll just offer some other basic troubleshooting thoughts on sound.

1. Be sure the speakers are plugged into the right jack, almost always the green one. Be sure the speakers are plugged in (if powered) and that the volume control is "clicked ON" and the volume is up enough to hear. Simple stuff, but easy mistakes to make.

2. Left-click on the "speaker icon" on the panel, in the right corner near the clock. Make sure that the volume is mid-range. Next, right-click on the speaker icon and be sure that the Mute box is not checked, and from there click on Sound Preferences. In Sound Preferences, look at the Hardware tab and the Output tab. The Hardware tab has a "Test Speakers" button to test with. And the Output tab should show "Line Out" as the Connector, but you can also switch it to "Headphones" to see if it works instead. You might even plug the speakers into the Headphones jack... usually in the front of the computer, but still usually a green color to identify it.


Now that I have it up and running and have accessed the internet
Glad to hear the internet is working now! Wireless can be hard to setup too, but I guess you got through it easy-peasy. "Granny the Geek"... I'm tellin' ya! :D
 
Last edited:

Granny Sue

Well-Known Member
Credits
0
Granny the geek is showing her weak side. I had a raspberry pi all this time and totally forgot there's a Wi-Fi dongle on it. All I did was unplug it from the raspberry pi and plug it into my computer. Now if I can just lick the sound!
 

Granny Sue

Well-Known Member
Credits
0
I went to the website @arochester suggested and performed all four of the fixes there none of which worked. I tried the command line @dos2unix suggested and that didn't work either. Since my speakers are built into my monitor I will double check the connection but that's about all I can do there. I haven't gone into the hardware tab or used the test speakers button. I will check that in a little while.
 

atanere

Well-Known Member
Credits
0
I tried the command line @dos2unix suggested and that didn't work either.
The command won't fix it... it will tell us what kind of sound device is inside your computer. Knowing that is often a good starting point to troubleshoot sound problems.


Since my speakers are built into my monitor I will double check the connection but that's about all I can do there.
Some monitors may have a volume control too, like a rotating dial/knob on the side of the monitor. It probably isn't too common though, but worth a look to be sure, especially if it is an older monitor.
 

atanere

Well-Known Member
Credits
0
Granny the geek is showing her weak side. I had a raspberry pi all this time and totally forgot there's a Wi-Fi dongle on it. All I did was unplug it from the raspberry pi and plug it into my computer. Now if I can just lick the sound!
I didn't think about that either, although you had mentioned before that you had a Pi. I have a newer model and the WiFi is built onto the board. Hopefully it will work okay for you. I bought an Edimax brand dongle that is often used with the Pi's.... but I didn't have much luck with them (a lot of dropped connections).
 

Condobloke

Well-Known Member
Credits
516
When you open terminal....just copy and paste the sudo lspci | grep Audio ....into the terminal.......hit enter....it will then ask for your password.....(the letters/numbers etc will not show.)

The 'output' will be similar to mine below. Just copy and paste it to your reply


[email protected] ~ $ sudo lspci | grep Audio
[sudo] password for brian:
00:1f.3 Audio device: Intel Corporation 100 Series/C230 Series Chipset Family HD Audio Controller (rev 31)
[email protected] ~ $
 

Condobloke

Well-Known Member
Credits
516
confirm ....sudo not needed
 

Granny Sue

Well-Known Member
Credits
0
I didn't think about that either, although you had mentioned before that you had a Pi. I have a newer model and the WiFi is built onto the board. Hopefully it will work okay for you. I bought an Edimax brand dongle that is often used with the Pi's.... but I didn't have much luck with them (a lot of dropped connections).
So far, so good. But I am finding the system itself to be pretty slow. Maybe I need more ram? Just a guess.
 

Granny Sue

Well-Known Member
Credits
0
When you open terminal....just copy and paste the sudo lspci | grep Audio ....into the terminal.......hit enter....it will then ask for your password.....(the letters/numbers etc will not show.)

The 'output' will be similar to mine below. Just copy and paste it to your reply


[email protected] ~ $ sudo lspci | grep Audio
[sudo] password for brian:
00:1f.3 Audio device: Intel Corporation 100 Series/C230 Series Chipset Family HD Audio Controller (rev 31)
[email protected] ~ $
Again, I’ll be working on this tomorrow.
 

JulienCC

Active Member
Credits
0
I feel like I need to investigate deeper on linux audio handling. There a so many problems related to sound. Even android phones have problems...

Maybe start a project that collects automatically hardware info, grabs config and start to fill a database of what's working and what's not. Audio problems are more frequent nowadays than network ones. This is crazy, especially considering the fact that widespread audio hardware is limited to few brands...
 

Granny Sue

Well-Known Member
Credits
0
I'm posting a series of screenshots of my sound preferences window.
 

Attachments

atanere

Well-Known Member
Credits
0
OK. all you guys with brains
Well, that lets me out! :eek:o_O:D

But I guess I'll keep talking anyway. First things first... on the Hardware tab in your pics, did you try to change the Profile from OFF to something else with the down arrow? Or was nothing else available? It seems like a silly question, but we don't know if you don't tell us.
 
Last edited:

poorguy

Well-Known Member
Credits
582
I may be wrong but if that is the only sound card you have then I would think that should be switched to on.
 

Attachments

atanere

Well-Known Member
Credits
0
If there was no option to change the Profile, or no help, then try this:

Run alsamixer in a terminal, and show us a screenshot of that.

The ESC key will exit alsamixer.
 
Last edited:

Granny Sue

Well-Known Member
Credits
0
Well, that lets me out! :eek:o_O:D

But I guess I'll keep talking anyway. First things first... on the Hardware tab in your pics, did you try to change the Profile from OFF to something else with the down arrow? Or was nothing else available? It seems like a silly question, but we don't know if you don't tell us.
nothing else was available
 


Members online


Top