No sound

atanere

Well-Known Member
Credits
0
You can unhide them, but you usually don't want to do that. They're hidden for good reason.

Sometimes blowing it all up is not a bad thing.... really! I do it again and again on test computers, helping with troubleshooting like now. There is a lot to be gained from the repetition of reinstalling and reconfiguring everything.

OK, we're still failing. Sound can be a real pain, I know. There are more things to do if you're up for it. The next step I would go for is to install a different sound program (a program that helps to configure the sound preferences... similar to what you've seen already, but different). Your call....
 


Granny Sue

Well-Known Member
Credits
0
You can unhide them, but you usually don't want to do that. They're hidden for good reason.

Sometimes blowing it all up is not a bad thing.... really! I do it again and again on test computers, helping with troubleshooting like now. There is a lot to be gained from the repetition of reinstalling and reconfiguring everything.

OK, we're still failing. Sound can be a real pain, I know. There are more things to do if you're up for it. The next step I would go for is to install a different sound program (a program that helps to configure the sound preferences... similar to what you've seen already, but different). Your call....
I'm game if you are. It's Saturday night and I have nothing to do and my brain is still alive. Might as well use it.
 

atanere

Well-Known Member
Credits
0
And the time change gives us an extra hour... who needs sleep?!?! :eek:o_O:D

OK, we'll have you install a new program from the terminal. Enter this:
Code:
sudo apt install pavucontrol
 

Granny Sue

Well-Known Member
Credits
0
Sometimes blowing it all up is not a bad thing.... really! I do it again and again on test computers, helping with troubleshooting like now. There is a lot to be gained from the repetition of reinstalling and reconfiguring everything.
I understand why you would say that, but it still scares me.
And the time change gives us an extra hour... who needs sleep?!?! :eek:o_O:D I forgot about the time change, it's almost like New Year's Eve!! :D

OK, we'll have you install a new program from the terminal. Enter this:
Code:
sudo apt install pavucontrol
I entered the command and it's finished processing. Do I need to reboot?
 

Granny Sue

Well-Known Member
Credits
0
I understand why you would say that, but it still scares me.
I entered the command and it's finished processing. Do I need to reboot?
oh, heck, I'm going to reboot for the fun of it.
 

atanere

Well-Known Member
Credits
0
No need to reboot right now. And lest you think that I am pulling all this stuff out of the top of my head (or from the other end!).... I'll let you know that I am more-or-less following instructions on another webiste, here. I'm not smart enough to know all this stuff, but I try hard to Google up people who are that smart. :D

OK, simple command: pulseaudo -k (note the space before -k)... then wait a few seconds. Then run the aplay sound test command. Any noise?
 

atanere

Well-Known Member
Credits
0
I really can't read that font. If you copied/pasted the command, I don't think it should throw an error (file not found, or whatever). Did you copy/paste? I don't get an error in a brand new Mint MATE installation.
 

Granny Sue

Well-Known Member
Credits
0
Command 'pulseaudo' not found, did you mean:

command 'pulseaudio' from deb pulseaudio

Try: sudo apt install <deb name>

I really can't read that font. If you copied/pasted the command, I don't think it should throw an error (file not found, or whatever). Did you copy/paste? I don't get an error in a brand new Mint MATE installation.
I did copy/paste. I thought I had changed the font back to Ubuntu Regular, but it didn't seem to take effect. the response was,
Command 'pulseaudo' not found, did you mean:

command 'pulseaudio' from deb pulseaudio

Try: sudo apt install <deb name>"
 

atanere

Well-Known Member
Credits
0
Hmmm, very weird that your Mint MATE responds differently from my Mint MATE. Here's another way:

Code:
/usr/bin/pulseaudo -k
All that should happen here is that you hit Enter, and you get your prompt back. There is no report, and no error, I hope. I think it is like a "reset" command.
 

Granny Sue

Well-Known Member
Credits
0
Hmmm, very weird that your Mint MATE responds differently from my Mint MATE. Here's another way:

Code:
/usr/bin/pulseaudo -k
All that should happen here is that you hit Enter, and you get your prompt back. There is no report, and no error, I hope. I think it is like a "reset" command.
Unfortunaterly, I did get a response
bash: /usr/bin/pulseaudo: No such file or directory
 

atanere

Well-Known Member
Credits
0
Hmmm. These aren't the same, but let's make sure the program installed... give this command:
Code:
which pavucontrol
You should get a response for this one.
 

Granny Sue

Well-Known Member
Credits
0
Hmmm. These aren't the same, but let's make sure the program installed... give this command:
Code:
which pavucontrol
You should get a response for this one.
Yep, here it is:
/usr/bin/pavucontrol
 

atanere

Well-Known Member
Credits
0
Now, if you just get your prompt back, with no error this time, wait about 5 or 10 seconds, and then try the aplay command test file again.
 

Granny Sue

Well-Known Member
Credits
0
Here's what I got:

[email protected]:~$ aplay
Usage: aplay [OPTION]... [FILE]...

-h, --help help
--version print current version
-l, --list-devices list all soundcards and digital audio devices
-L, --list-pcms list device names
-D, --device=NAME select PCM by name
-q, --quiet quiet mode
-t, --file-type TYPE file type (voc, wav, raw or au)
-c, --channels=# channels
-f, --format=FORMAT sample format (case insensitive)
-r, --rate=# sample rate
-d, --duration=# interrupt after # seconds
-M, --mmap mmap stream
-N, --nonblock nonblocking mode
-F, --period-time=# distance between interrupts is # microseconds
-B, --buffer-time=# buffer duration is # microseconds
--period-size=# distance between interrupts is # frames
--buffer-size=# buffer duration is # frames
-A, --avail-min=# min available space for wakeup is # microseconds
-R, --start-delay=# delay for automatic PCM start is # microseconds
(relative to buffer size if <= 0)
-T, --stop-delay=# delay for automatic PCM stop is # microseconds from xrun
-v, --verbose show PCM structure and setup (accumulative)
-V, --vumeter=TYPE enable VU meter (TYPE: mono or stereo)
-I, --separate-channels one file for each channel
-i, --interactive allow interactive operation from stdin
-m, --chmap=ch1,ch2,.. Give the channel map to override or follow
--disable-resample disable automatic rate resample
--disable-channels disable automatic channel conversions
--disable-format disable automatic format conversions
--disable-softvol disable software volume control (softvol)
--test-position test ring buffer position
--test-coef=# test coefficient for ring buffer position (default 8)
expression for validation is: coef * (buffer_size / 2)
--test-nowait do not wait for ring buffer - eats whole CPU
--max-file-time=# start another output file when the old file has recorded
for this many seconds
--process-id-file write the process ID here
--use-strftime apply the strftime facility to the output file name
--dump-hw-params dump hw_params of the device
--fatal-errors treat all errors as fatal
Recognized sample formats are: S8 U8 S16_LE S16_BE U16_LE U16_BE S24_LE S24_BE U24_LE U24_BE S32_LE S32_BE U32_LE U32_BE FLOAT_LE FLOAT_BE FLOAT64_LE FLOAT64_BE IEC958_SUBFRAME_LE IEC958_SUBFRAME_BE MU_LAW A_LAW IMA_ADPCM MPEG GSM SPECIAL S24_3LE S24_3BE U24_3LE U24_3BE S20_3LE S20_3BE U20_3LE U20_3BE S18_3LE S18_3BE U18_3LE U18_3BE G723_24 G723_24_1B G723_40 G723_40_1B DSD_U8 DSD_U16_LE DSD_U32_LE DSD_U16_BE DSD_U32_BE
Some of these may not be available on selected hardware
The available format shortcuts are:
-f cd (16 bit little endian, 44100, stereo)
-f cdr (16 bit big endian, 44100, stereo)
-f dat (16 bit little endian, 48000, stereo)
 

atanere

Well-Known Member
Credits
0
No, you need the whole thing every time, as before. Either copy it from previous posts, or use the up arrow in your terminal to keep going up until you get to it. Here it is again:

Code:
aplay /usr/share/sounds/alsa/Front_Center.wav
This file is present in my Mint MATE, so if your sound suddenly starts to work, you will hear this file.
 

Granny Sue

Well-Known Member
Credits
0
No sound. But when I went to open the CD, it asked what app to use and Rythmbox is on the list twice. Is there a different app I should be using?
 

atanere

Well-Known Member
Credits
0
Is there a different app I should be using?
The only test we need to make is the aplay command above. It is trying to play a .wav audio file. If it works, it will say "Front Center" in your speakers. Bringing other apps into the troubleshooting process can bring their own problems. You ran the aplay command earlier, and it provides some text output that confirms it is on your system too.
 


Members online

No members online now.

Latest posts

Top