Option to select between windows 10 and ubuntu 20.04 is not showing.

bharu

New Member
Credits
120
@bharu ....the name of the game is patience.

Show some patience.

All members/Moderators here are volunteers
We are not paid for our input, ...nor do we expect it.
Every member has a home life/private life
That comes before everything else. And that includes answering questions here.
Hey @Condobloke ,
I think you got me wrong.
I'm neither forcing anyone nor losing my patience.
I know you guys don't get paid or anything, and I appreciate what you do.
I'm just asking for some help to sort out my problem.
and I don't expect people to help me out by keeping aside their daily life.
 


wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
13,559
I'm sure Chris will clarify then at least i might learn something
You could hope - I haven't been a regular user of Windows for coming up on 7 years. :)

I would prefer to first try efibootmgr to reorder the boot sequence. If that fails, then Andy's method from Windows would be my course of action.

Why?

If the Windows bdedit command fails, it will need to be reversed, and if Windows fails to boot correctly, it may prove problematic to access the Windows cmd command line facility to make the reversal.

For that matter, the OP should have a Windows recovery disk or solution in place before trying anything suggested. For Justin (just in case) :):)

So Option

2.a - The boot order revealed in the OP's screenshot is as follows, and he should write this down, there is a space in how it is shown, but there are no spaces, only commas and entries, in the command to follow

BootOrder: 3002,3000,3001,3003,3004,3005,2001,2002,2003

None of those is what we need and I am not sure why they are there.

What we want are the entries starting with 000 to be first, and in the correct order, looking like

BootOrder: 0000,0001,0002,0003,3002,3000,3001,3003,3004,3005,2001,2002,2003

So the command you need to issue is as follows:

Code:
sudo efibootmgr -o 0000,0001,0002,0003,3002,3000,3001,3003,3004,3005,2001,2002,2003
If that fails to work, but generates partial results, we can either tweak that command with the benefit of your output, or else

2.b - Use Andy's Windows bcedit command as he directed above

3. Would be to totally remove Ubuntu 20.04 from within Windows and reclaim the space, then repeat the process you used to install Ubuntu. If that approach is tried, you may want to safeguard Data from Home first.

Let us know how you get on.

Wizard
 

bharu

New Member
Credits
120
You could hope - I haven't been a regular user of Windows for coming up on 7 years. :)

I would prefer to first try efibootmgr to reorder the boot sequence. If that fails, then Andy's method from Windows would be my course of action.

Why?

If the Windows bdedit command fails, it will need to be reversed, and if Windows fails to boot correctly, it may prove problematic to access the Windows cmd command line facility to make the reversal.

For that matter, the OP should have a Windows recovery disk or solution in place before trying anything suggested. For Justin (just in case) :):)

So Option

2.a - The boot order revealed in the OP's screenshot is as follows, and he should write this down, there is a space in how it is shown, but there are no spaces, only commas and entries, in the command to follow

BootOrder: 3002,3000,3001,3003,3004,3005,2001,2002,2003

None of those is what we need and I am not sure why they are there.

What we want are the entries starting with 000 to be first, and in the correct order, looking like

BootOrder: 0000,0001,0002,0003,3002,3000,3001,3003,3004,3005,2001,2002,2003

So the command you need to issue is as follows:

Code:
sudo efibootmgr -o 0000,0001,0002,0003,3002,3000,3001,3003,3004,3005,2001,2002,2003
If that fails to work, but generates partial results, we can either tweak that command with the benefit of your output, or else

2.b - Use Andy's Windows bcedit command as he directed above

3. Would be to totally remove Ubuntu 20.04 from within Windows and reclaim the space, then repeat the process you used to install Ubuntu. If that approach is tried, you may want to safeguard Data from Home first.

Let us know how you get on.

Wizard
Hey,
I did what you said, I have attached a snippet of the output .
Yet it loaded directly into windows.

I don't know what's wrong with it. I guess I might have to adjust with what I have now.

Thanks for all of your effort guys.
@wizardfromoz , @captain-sensible, @Condobloke
 

Attachments

captain-sensible

Well-Known Member
Credits
9,609
there's error for 0002 , 3002 buts thats because they don't exist.

There are a lot of entries in there i don't understand why ; is it that you tried multiple times to install ubuntu and those extra entries got put on efi but are basically ghost entries ?

I'm also not sure on original image the /dev/sda entries apart from Windows OS, Windows reserved etc and Ubuntu is anything else or attempted install of any other OS ?

from here if you had rEFind on a usb , then you could use it for rescue and boot up Windows and ubuntu if you want to prune entries, as well as backing up as Chris mentioned


I woudn't mind if you could re-run lsblk as :

Code:
sudo  lsblk -o name,label,size,fstype,model
and

Code:
sudo fdisk -l
Chris might not be back until tomorrow, do you want to try to put rEFInd onto a spare usb ;can outline how to do thta later (if wife doesn't have more jobs to do for me)
 
Last edited:

bharu

New Member
Credits
120
there's error for 0002 , 3002 buts thats because they don't exist.

There are a lot of entries in there i don't understand why ; is it that you tried multiple times to install ubuntu and those extra entries got put on efi but are basically ghost entries ?

I'm also not sure on original image the /dev/sda entries apart from Windows OS, Windows reserved etc and Ubuntu is anything else or attempted install of any other OS ?

from here if you had rEFind on a usb , then you could use it for rescue and boot up Windows and ubuntu if you want to prune entries, as well as backing up as Chris mentioned


I woudn't mind if you could re-run lsblk as :

Code:
sudo  lsblk -o name,label,size,fstype,model
and

Code:
sudo fdisk -l
Chris might not be back until tomorrow, do you want to try to put rEFInd onto a spare usb ;can outline how to do thta later (if wife doesn't have more jobs to do for me)
Hi,
I think I may have installed Ubuntu twice but I deleted the disk partition of the Ubuntu after the first installation and then I reinstalled it.
Anyway,
Here are the outputs of the code..
 

Attachments

captain-sensible

Well-Known Member
Credits
9,609
ok from your images ubuntu is on /dev/sda9 ; EFI partition on /dev/sda2 and everything else is either Windows OS or Windows updates , recovery stuff et cetera. So on the face of it seems OK . Do you have massive RAM though since i can't see a partition for SWAP unless i'm blind.


Also in theory there should only be 2 core entries on the efi . One for Windows ; one for Ubuntu and extra for usb etc which means , we can hardly see the wood for the trees. If you booted into Ubuntu , the way you have been doing and deleted all entries except for the Windows one (using efibootmgr) ; you then re-install grub(after deleting efi entries BUT before rebooting or shuting down ) ; that should put back the entry for Ubuntu things will be cleaner.

deleting via efibootmgr is on the basis of :
Code:
efibootmgr -b 300c -B
//where 300c are the numbers you got from efibootmgr -v (in your image)
Can you confirm you tried from Windows :

Code:
bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi
//or
bcdedit /set "{bootmgr}" path \EFI\ubuntu\shimx64.efi

Will do a bit of research , to see if anyone has had similar problems. The last thing i'm thinking is was Ubuntu installed in UEFI mode ? you would think so maybe from fact of fstab and that efi partition shows it was mounted.

Regarding fast boot; there are ways to disable that via Windows ; you will have to research that and do it from booted Windows.
 
Last edited:

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
13,559
I think I may have installed Ubuntu twice but I deleted the disk partition of the Ubuntu after the first installation and then I reinstalled it.
My question here is @bharu have you at any time recently reinstalled Windows?

The reason I ask is that we do have one PC in the house with Windows on it, my wife's Dell has Win10 on it dualbooting with Linux Mint 19 'Tara' Cinnamon. I can only get on to it at certain times of day.

Her output to

efibootmgr

and

efibootmgr -v is as follows:

Code:
[email protected]:~$ efibootmgr
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0003,0004,0001,0002,0005,0006,0000
Boot0000* Windows Boot Manager
Boot0001* Diskette Drive
Boot0002* Internal HDD
Boot0003* ubuntu
Boot0004* USB Storage Device
Boot0005* CD/DVD/CD-RW Drive
Boot0006* Onboard NIC


[email protected]:~$ efibootmgr -v
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0003,0004,0001,0002,0005,0006,0000
Boot0000* Windows Boot Manager    HD(1,GPT,12f62196-a5ea-4339-a255-aec3a7ddfd28,0x800,0x145000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}..._................
Boot0001* Diskette Drive    BBS(Floppy,Diskette Drive,0x0)..BO
Boot0002* Internal HDD    BBS(HD,Internal HDD,0x0)..BO
Boot0003* ubuntu    HD(1,GPT,12f62196-a5ea-4339-a255-aec3a7ddfd28,0x800,0x145000)/File(\EFI\ubuntu\shimx64.efi)
Boot0004* USB Storage Device    BBS(USB,USB Storage Device,0x0)..BO
Boot0005* CD/DVD/CD-RW Drive    BBS(CDROM,P1: HL-DT-ST DVD+/-RW GU90N,0x0)..BO
Boot0006* Onboard NIC    BBS(Network,Realtek PXE B02 D00,0x0)..BO
Now you can see from this (LInux Mint is reflected as ubuntu) that the default ID for the Windows is 0000 , and that is typical for a dual boot setup.

The Boot Order that has been established, of having Linux installed after Windows is already on board shows that Linux is at the beginning and Windows at the end.

The minimal Grub Menu that first appears with this Setup will have
  • Linux Distro (here, Mint, yours, Ubuntu)
  • Advanced Options for Linux Distro
  • Windows Boot Manager
and that last is how Windows is booted.

Your output, however, shows as Windows having ID0002, and Ubuntu as 0000

This makes me wonder whether you have reinstalled Windows after having installed or reinstalled Ubuntu, is that so?

Cheers

Wiz
 

bharu

New Member
Credits
120
My question here is @bharu have you at any time recently reinstalled Windows?

The reason I ask is that we do have one PC in the house with Windows on it, my wife's Dell has Win10 on it dualbooting with Linux Mint 19 'Tara' Cinnamon. I can only get on to it at certain times of day.

Her output to

efibootmgr

and

efibootmgr -v is as follows:

Code:
[email protected]:~$ efibootmgr
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0003,0004,0001,0002,0005,0006,0000
Boot0000* Windows Boot Manager
Boot0001* Diskette Drive
Boot0002* Internal HDD
Boot0003* ubuntu
Boot0004* USB Storage Device
Boot0005* CD/DVD/CD-RW Drive
Boot0006* Onboard NIC


[email protected]:~$ efibootmgr -v
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0003,0004,0001,0002,0005,0006,0000
Boot0000* Windows Boot Manager    HD(1,GPT,12f62196-a5ea-4339-a255-aec3a7ddfd28,0x800,0x145000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}..._................
Boot0001* Diskette Drive    BBS(Floppy,Diskette Drive,0x0)..BO
Boot0002* Internal HDD    BBS(HD,Internal HDD,0x0)..BO
Boot0003* ubuntu    HD(1,GPT,12f62196-a5ea-4339-a255-aec3a7ddfd28,0x800,0x145000)/File(\EFI\ubuntu\shimx64.efi)
Boot0004* USB Storage Device    BBS(USB,USB Storage Device,0x0)..BO
Boot0005* CD/DVD/CD-RW Drive    BBS(CDROM,P1: HL-DT-ST DVD+/-RW GU90N,0x0)..BO
Boot0006* Onboard NIC    BBS(Network,Realtek PXE B02 D00,0x0)..BO
Now you can see from this (LInux Mint is reflected as ubuntu) that the default ID for the Windows is 0000 , and that is typical for a dual boot setup.

The Boot Order that has been established, of having Linux installed after Windows is already on board shows that Linux is at the beginning and Windows at the end.

The minimal Grub Menu that first appears with this Setup will have
  • Linux Distro (here, Mint, yours, Ubuntu)
  • Advanced Options for Linux Distro
  • Windows Boot Manager
and that last is how Windows is booted.

Your output, however, shows as Windows having ID0002, and Ubuntu as 0000

This makes me wonder whether you have reinstalled Windows after having installed or reinstalled Ubuntu, is that so?

Cheers

Wiz
Hey,
I haven't reinstalled my windows.
I think that might be because we changed the BootOrder.
 

bharu

New Member
Credits
120
ok from your images ubuntu is on /dev/sda9 ; EFI partition on /dev/sda2 and everything else is either Windows OS or Windows updates , recovery stuff et cetera. So on the face of it seems OK . Do you have massive RAM though since i can't see a partition for SWAP unless i'm blind.


Also in theory there should only be 2 core entries on the efi . One for Windows ; one for Ubuntu and extra for usb etc which means , we can hardly see the wood for the trees. If you booted into Ubuntu , the way you have been doing and deleted all entries except for the Windows one (using efibootmgr) ; you then re-install grub(after deleting efi entries BUT before rebooting or shuting down ) ; that should put back the entry for Ubuntu things will be cleaner.

deleting via efibootmgr is on the basis of :
Code:
efibootmgr -b 300c -B
//where 300c are the numbers you got from efibootmgr -v (in your image)
Can you confirm you tried from Windows :

Code:
bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi
//or
bcdedit /set "{bootmgr}" path \EFI\ubuntu\shimx64.efi

Will do a bit of research , to see if anyone has had similar problems. The last thing i'm thinking is was Ubuntu installed in UEFI mode ? you would think so maybe from fact of fstab and that efi partition shows it was mounted.

Regarding fast boot; there are ways to disable that via Windows ; you will have to research that and do it from booted Windows.
Hey,
I have only 4 GB RAM and yeah I have tried this code.
Code:
bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi

But as it didn't work, I reversed the command again.
Code:
efibootmgr -b 300c -B
//where 300c are the numbers you got from efibootmgr -v (in your image)
Here 300c are the Internal hard disks, Do you want me to delete them all?
 

bharu

New Member
Credits
120
My question here is @bharu have you at any time recently reinstalled Windows?

The reason I ask is that we do have one PC in the house with Windows on it, my wife's Dell has Win10 on it dualbooting with Linux Mint 19 'Tara' Cinnamon. I can only get on to it at certain times of day.

Her output to

efibootmgr

and

efibootmgr -v is as follows:

Code:
[email protected]:~$ efibootmgr
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0003,0004,0001,0002,0005,0006,0000
Boot0000* Windows Boot Manager
Boot0001* Diskette Drive
Boot0002* Internal HDD
Boot0003* ubuntu
Boot0004* USB Storage Device
Boot0005* CD/DVD/CD-RW Drive
Boot0006* Onboard NIC


[email protected]:~$ efibootmgr -v
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0003,0004,0001,0002,0005,0006,0000
Boot0000* Windows Boot Manager    HD(1,GPT,12f62196-a5ea-4339-a255-aec3a7ddfd28,0x800,0x145000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}..._................
Boot0001* Diskette Drive    BBS(Floppy,Diskette Drive,0x0)..BO
Boot0002* Internal HDD    BBS(HD,Internal HDD,0x0)..BO
Boot0003* ubuntu    HD(1,GPT,12f62196-a5ea-4339-a255-aec3a7ddfd28,0x800,0x145000)/File(\EFI\ubuntu\shimx64.efi)
Boot0004* USB Storage Device    BBS(USB,USB Storage Device,0x0)..BO
Boot0005* CD/DVD/CD-RW Drive    BBS(CDROM,P1: HL-DT-ST DVD+/-RW GU90N,0x0)..BO
Boot0006* Onboard NIC    BBS(Network,Realtek PXE B02 D00,0x0)..BO
Now you can see from this (LInux Mint is reflected as ubuntu) that the default ID for the Windows is 0000 , and that is typical for a dual boot setup.

The Boot Order that has been established, of having Linux installed after Windows is already on board shows that Linux is at the beginning and Windows at the end.

The minimal Grub Menu that first appears with this Setup will have
  • Linux Distro (here, Mint, yours, Ubuntu)
  • Advanced Options for Linux Distro
  • Windows Boot Manager
and that last is how Windows is booted.

Your output, however, shows as Windows having ID0002, and Ubuntu as 0000

This makes me wonder whether you have reinstalled Windows after having installed or reinstalled Ubuntu, is that so?

Cheers

Wiz
When I do that Command what I get is,

Code:
[email protected]:~$ efibootmgr
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 3000,3001,3003,3004,3005,3006,3007,3008,3009,300A,300B,2001,2002,2003
Boot0000* ubuntu
Boot0001* Ubuntu
Boot0003* Ubuntu
Boot0004* Ubuntu
Boot0005* Ubuntu
Boot0006* Ubuntu
Boot0007* Ubuntu
Boot0008* Ubuntu
Boot0009* Ubuntu
Boot000A* Ubuntu
Boot000B* Ubuntu
Boot000C* Windows Boot Manager
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot3000* Internal Hard Disk
Boot3001* Internal Hard Disk
Boot3003* Internal Hard Disk
Boot3004* Internal Hard Disk
Boot3005* Internal Hard Disk
Boot3006* Internal Hard Disk
Boot3007* Internal Hard Disk
Boot3008* Internal Hard Disk
Boot3009* Internal Hard Disk
Boot300A* Internal Hard Disk
Boot300B* Internal Hard Disk
Boot300D* Internal Hard Disk
Boot300E* Internal Hard Disk
Boot300F* Internal Hard Disk
Code:
[email protected]:~$ efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 3000,3001,3003,3004,3005,3006,3007,3008,3009,300A,300B,2001,2002,2003
Boot0000* ubuntu    HD(2,GPT,24ddaf0f-8347-4760-bdbc-f6c6245bdf62,0xc8800,0x82000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* Ubuntu    HD(2,GPT,24ddaf0f-8347-4760-bdbc-f6c6245bdf62,0xc8800,0x82000)/File(\EFI\ubuntu\grubx64.efi)RC
Boot0003* Ubuntu    HD(2,GPT,24ddaf0f-8347-4760-bdbc-f6c6245bdf62,0xc8800,0x82000)/File(\EFI\ubuntu\grubx64.efi)RC
Boot0004* Ubuntu    HD(2,GPT,24ddaf0f-8347-4760-bdbc-f6c6245bdf62,0xc8800,0x82000)/File(\EFI\ubuntu\grubx64.efi)RC
Boot0005* Ubuntu    HD(2,GPT,24ddaf0f-8347-4760-bdbc-f6c6245bdf62,0xc8800,0x82000)/File(\EFI\ubuntu\grubx64.efi)RC
Boot0006* Ubuntu    HD(2,GPT,24ddaf0f-8347-4760-bdbc-f6c6245bdf62,0xc8800,0x82000)/File(\EFI\ubuntu\grubx64.efi)RC
Boot0007* Ubuntu    HD(2,GPT,24ddaf0f-8347-4760-bdbc-f6c6245bdf62,0xc8800,0x82000)/File(\EFI\ubuntu\grubx64.efi)RC
Boot0008* Ubuntu    HD(2,GPT,24ddaf0f-8347-4760-bdbc-f6c6245bdf62,0xc8800,0x82000)/File(\EFI\ubuntu\grubx64.efi)RC
Boot0009* Ubuntu    HD(2,GPT,24ddaf0f-8347-4760-bdbc-f6c6245bdf62,0xc8800,0x82000)/File(\EFI\ubuntu\grubx64.efi)RC
Boot000A* Ubuntu    HD(2,GPT,24ddaf0f-8347-4760-bdbc-f6c6245bdf62,0xc8800,0x82000)/File(\EFI\ubuntu\grubx64.efi)RC
Boot000B* Ubuntu    HD(2,GPT,24ddaf0f-8347-4760-bdbc-f6c6245bdf62,0xc8800,0x82000)/File(\EFI\ubuntu\grubx64.efi)RC
Boot000C* Windows Boot Manager    HD(2,GPT,24ddaf0f-8347-4760-bdbc-f6c6245bdf62,0xc8800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}.../................
Boot2001* USB Drive (UEFI)    RC
Boot2002* Internal CD/DVD ROM Drive (UEFI)    RC
Boot3000* Internal Hard Disk    RC
Boot3001* Internal Hard Disk    RC
Boot3003* Internal Hard Disk    RC
Boot3004* Internal Hard Disk    RC
Boot3005* Internal Hard Disk    RC
Boot3006* Internal Hard Disk    RC
Boot3007* Internal Hard Disk    RC
Boot3008* Internal Hard Disk    RC
Boot3009* Internal Hard Disk    RC
Boot300A* Internal Hard Disk    RC
Boot300B* Internal Hard Disk    RC
Boot300D* Internal Hard Disk    RC
Boot300E* Internal Hard Disk    RC
Boot300F* Internal Hard Disk    RC
I absolutely have no idea why I have so many ubuntu and Ubuntu and Internal Hard Disk.
Thanks.
 

bharu

New Member
Credits
120
Hey guys,
The problem is solved.:D

Solution: MODERATOR'S NOTE : The following steps are taken by the OP in Windows - Wizard

Step 1: I opened command prompt as administrator and type in:
Code:
powercfg.exe /hibernate on
This in turn opened up the options to turn on/off fast startup.
I went to control panel > Click Power Options.> Click Choose what the power buttons do> Click Change settings that are currently unavailable. > Turn on fast startup (recommended) so that the checkmark disappears. > Click Save changes.

Step 2: I opened command prompt as administrator and type in:
Code:
bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi
//or
bcdedit /set "{bootmgr}" path \EFI\ubuntu\shimx64.efi
I guess both commands will work, I typed in the second one.
And Boom! , it worked.:D
I can see the Grub menu whenever I turn on my laptop now.

I hope the above solution be useful to the people who are facing the same issue.

Thanks you so much for your time and patience,
@captain-sensible @wizardfromoz
I wouldn't have solved this without your help and support.

cheers
Stay awesome.
 
Last edited:

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
13,559
Wonderful news. That Fast Startup business was itching at my brain but I am so rusty in Windows I could not put my finger on it.

I have just put a note in your previous Post so that The Viewers will know the steps you took were in Windows.

When you get your breath back,

1. Have a read up on Timeshift and how to safeguard your Ubuntu, Timeshift is in your Software Centre

REFERENCE URLs

Tony George pages

https://github.com/teejee2008/timeshift

https://github.com/teejee2008/Timeshift/releases

OTHER GUIDES

https://itsfoss.com/backup-restore-linux-timeshift/

https://www.fosslinux.com/34377/how-to-backup-and-restore-ubuntu-with-timeshift.htm

https://www.fossmint.com/backup-restore-linux-with-timeshift/

and this from Linux Lite Help Manual, and MX-Linux

https://www.linuxliteos.com/manual/tutorials.html#timeshift

https://mxlinux.org/wiki/applications/timeshift/

or read about it and ask questions at my Thread here

https://www.linux.org/threads/timeshift-similar-solutions-safeguard-recover-your-linux.15241/

2. Consider swinging over to Member Introductions, and tell us a little of the Bharu story. There, you can meet more people and make friends.

Well done, and thanks as always, Andy @captain-sensible :)

Wizard

Hey Andy, we are awesome - I must tell my wife, she will laugh her socks off
 

captain-sensible

Well-Known Member
Credits
9,609
Hey guys,
The problem is solved.:D

Solution: MODERATOR'S NOTE : The following steps are taken by the OP in Windows - Wizard

Step 1: I opened command prompt as administrator and type in:
Code:
powercfg.exe /hibernate on
This in turn opened up the options to turn on/off fast startup.
I went to control panel > Click Power Options.> Click Choose what the power buttons do> Click Change settings that are currently unavailable. > Turn on fast startup (recommended) so that the checkmark disappears. > Click Save changes.

Step 1: I opened command prompt as administrator and type in:
Code:
bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi
//or
bcdedit /set "{bootmgr}" path \EFI\ubuntu\shimx64.efi
I guess both commands will work, I typed in the second one.
And Boom! , it worked.:D
I can see the Grub menu whenever I turn on my laptop now.

I hope the above solution be useful to the people who are facing the same issue.

Thanks you so much for your time and patience,
@captain-sensible @wizardfromoz
I wouldn't have solved this without your help and support.

cheers
Stay awesome.
no problem, your welcome
 

captain-sensible

Well-Known Member
Credits
9,609
the only other loose end for me is that there was swap partition showing in @bharu image of dev/sda , but i think thats ubuntu is using is using a swap file. I've read that if you intend to have use of hibernation , then you need a swap partition. Anybody can clarify that ?

Also that there is a chance fastboot might be re-enabled after Windows updates ?
 
Last edited:

captain-sensible

Well-Known Member
Credits
9,609
Wonderful news. That Fast Startup business was itching at my brain but I am so rusty in Windows I could not put my finger on it.

I have just put a note in your previous Post so that The Viewers will know the steps you took were in Windows.

When you get your breath back,

1. Have a read up on Timeshift and how to safeguard your Ubuntu, Timeshift is in your Software Centre

REFERENCE URLs

Tony George pages

https://github.com/teejee2008/timeshift

https://github.com/teejee2008/Timeshift/releases

OTHER GUIDES

https://itsfoss.com/backup-restore-linux-timeshift/

https://www.fosslinux.com/34377/how-to-backup-and-restore-ubuntu-with-timeshift.htm

https://www.fossmint.com/backup-restore-linux-with-timeshift/

and this from Linux Lite Help Manual, and MX-Linux

https://www.linuxliteos.com/manual/tutorials.html#timeshift

https://mxlinux.org/wiki/applications/timeshift/

or read about it and ask questions at my Thread here

https://www.linux.org/threads/timeshift-similar-solutions-safeguard-recover-your-linux.15241/

2. Consider swinging over to Member Introductions, and tell us a little of the Bharu story. There, you can meet more people and make friends.

Well done, and thanks as always, Andy @captain-sensible :)

Wizard

Hey Andy, we are awesome - I must tell my wife, she will laugh her socks off
i might add that to my signature something like " apparently i'm awesome - at least 1% of the time, the rest of the time ...well "
 

Tolkem

Well-Known Member
Credits
4,205
Solution: MODERATOR'S NOTE : The following steps are taken by the OP in Windows - Wizard
Step 1: I opened command prompt as administrator and type in:

Code:
powercfg.exe /hibernate on
This in turn opened up the options to turn on/off fast startup.
I went to control panel > Click Power Options.> Click Choose what the power buttons do> Click Change settings that are currently unavailable. > Turn on fast startup (recommended) so that the checkmark disappears. > Click Save changes.
So, does fast startup needs to be disabled or enabled? It isn't quite clear to me which one it is.

Step 1: I opened command prompt as administrator and type in:

Code:
bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi
//or
bcdedit /set "{bootmgr}" path \EFI\ubuntu\shimx64.efi
Step 1? Shouldn't it be step 2? Anyways, which one is it here? Or how can I know which command to use? The reason I'm asking is that I too have a similar situation, only I'm using Windows 7 not 10.
Thanks and sorry for kind of "hijacking" this already solved thread. ;)
 
Last edited:

captain-sensible

Well-Known Member
Credits
9,609
Now off laptop and viewing by phone ,so apologies for any typo. the Op got it to work After fastboot was disabled.the edit was the shim one but the first entry should work. Can't even see the steps on this phone
 

Tolkem

Well-Known Member
Credits
4,205
Now off laptop and viewing by phone ,so apologies for any typo. the Op got it to work After fastboot was disabled.the edit was the shim one but the first entry should work. Can't even see the steps on this phone
Ok, got it. Thanks! Will try this and see if it works for me too, hopefully it will, and I will no longer need to use a key-combo to access the grub screen menu. :)
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top