Option to select between windows 10 and ubuntu 20.04 is not showing.

bharu

New Member
Credits
196
So, does fast startup needs to be disabled or enabled? It isn't quite clear to me which one it is.


Step 1? Shouldn't it be step 2? Anyways, which one is it here? Or how can I know which command to use? The reason I'm asking is that I too have a similar situation, only I'm using Windows 7 not 10.
Thanks and sorry for kind of "hijacking" this already solved thread. ;)
Hey,
Fast startup should be in off state.
and sorry for that typo.;)
The command should work most probably, in case if it didn'y try the second one.
 


Tolkem

Well-Known Member
Credits
5,451
Hey,
Fast startup should be in off state.
and sorry for that typo.;)
The command should work most probably, in case if it didn'y try the second one.
Thanks. Well, there's no fast startup in Windows 7, and I haven't tried step 2.
 

bharu

New Member
Credits
196
Hey guys,
The problem is solved.:D

Solution: MODERATOR'S NOTE : The following steps are taken by the OP in Windows - Wizard

Step 1: I opened command prompt as administrator and type in:
Code:
powercfg.exe /hibernate on
This in turn opened up the options to turn on/off fast startup.
I went to control panel > Click Power Options.> Click Choose what the power buttons do> Click Change settings that are currently unavailable. > Turn on fast startup (recommended) so that the checkmark disappears. > Click Save changes.

Step 2: I opened command prompt as administrator and type in:
Code:
bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi
//or
bcdedit /set "{bootmgr}" path \EFI\ubuntu\shimx64.efi
I guess both commands will work, I typed in the second one.
And Boom! , it worked.:D
I can see the Grub menu whenever I turn on my laptop now.

I hope the above solution be useful to the people who are facing the same issue.

Thanks you so much for your time and patience,
@captain-sensible @wizardfromoz
I wouldn't have solved this without your help and support.

cheers
Stay awesome.
Hey guys,

I don't what happened.
That problem is back.
When I was using my ubuntu, it got shutdown suddenly and when I restarted it , the screen was struck at some /dev/sdaX: clean xxxx/xxxxx files. xxxx/xxxxx blocks.
It was not going away, I tried to get rid of it but I don't know what I did. But I did lose my grub menu on startup. Later I was able to pass that error, but grub menu is not appearing on startup.

I tried all the steps in this post all over again, yet no progress.
I know I messed up.
But kindly help me out guys.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
14,375
@bharu - in #34 I recommended your installing Timeshift and running a snapshot.

Did you do so?

Wizard
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
14,375
Ba-bumm ... wrong :)

If you had done so, all you would need to do is run an Ubuntu Live USB stick, install Timeshift on it, locate a recent snapshot and restore it and then reboot.

You can't do that right now because you have no snapshot.

I'll have a think about it, but someone else may swing by in the meantime.

Wizard
 

Condobloke

Well-Known Member
Credits
9,941
I didn't do it because I thought it's not that important to do then.
We really don't make these suggestions/recommendations for the fun of it @bharu .
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Latest posts

Top