OS not using available RAM

float

New Member
Credits
101
OK, so I finally got it sorted. It all depends on the bootloader I use.
As I have a dual boot with Windows 10, I have two boot scenarios.
I can either go through the bootloader that came with Kali (my usual option until now). In which case, for some reason, the full amount of installed RAM is not recognized in Kali after boot.
I can also use the Windows bootloader, in which case all RAM is recognized when Kali boots.
So this second option will now be my preferred option to start Linux.
It's actually a bit more complex than that but I won't bore you with the details, unless you are interested in which case I can do a short write-up here. Just let me know.

Anyway, I want to thank all of you for the time you took to help me out. You got me on the right track so thanks a heap for that!
 


Tolkem

Well-Known Member
Credits
4,205
OK, so I finally got it sorted. It all depends on the bootloader I use.
Glad you solved it.

It's actually a bit more complex than that but I won't bore you with the details, unless you are interested in which case I can do a short write-up here. Just let me know.
I don't know the rest, but I'm interested in reading what you found. So please, do share, we're here to learn too after all. :)
 

KGIII

Super Moderator
Staff member
Gold Supporter
Credits
12,551
It's actually a bit more complex than that but I won't bore you with the details, unless you are interested in which case I can do a short write-up here. Just let me know.
Doing so may very well help the next person with this problem, so please do.
 

float

New Member
Credits
101
OK, so I have a dual boot system (Kali / Windows 10) on a laptop that uses Intel's Rapid Storage Technology (RST). It was enabled in UEFI by default. With this setting, Linux doesn't boot (not sure if it's just Kali or any flavour of Linux).
To allow Linux to boot, I have to go into UEFI and switch from RST (Optane without RAID) to AHCI. But this however prevents Windows from booting, which is no real issue for me as I don't use Windows that often.
So when I power up the laptop and hold F12, the Linux bootloader kicks in and Kali boots.
If I don't hold F12, the Windows bootloader loads, I get a bsod and need to go into recovery mode to access UEFI and switch AHCI back to RST.
Now for a reason unclear to me (I welcome any feedback or clarification on that point) I recently noticed that when booting into Kali using the linux bootloader (with SATA mode set to AHCI in UEFI), only under 3 Gb of RAM on the 16 Gb I have in the laptop are seen by Kali.
To get the full 16 Gb of RAM, I need to start the laptop without holding F12 to let the Windows bootloader load. I then get a bsod then the auto repair screen where I choose 'Advanced options' (translated from French so this may not be the exact phrase). Then 'Choose a peripheral' then 'kali'. Then the system boots into my Kali installation and I get the full amount of RAM available to the system.

If anyone has ideas of what may happen at the bootloader step to cause this to happen, I would be most interested. If this can be of any help, I have secure boot disabled and fast boot enabled in UEFI.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
13,559
Well done with what you have achieved to date. :)

I have some business to attend to for a couple of hours, but when back I will tell you a little about Timeshift, which as my friend The Green Hornet (@Tolkem ) has suggested, will come in useful for you in the future.

Cheers

Wizard

Off Topic - my sister has lived in The Loire Valley for 20 years, we have read about the COVID problems currently in France, so stay safe. :)
 

JasKinasis

Well-Known Member
Credits
5,977
It may be related to fast-boot.
With fast-boot enabled, windows doesn’t shut down properly/fully.
So that may be why Kali isn’t seeing beyond 3-4Gb of RAM. The rest of may be reserved by windows.

When loading the windows boot loader and then selecting Kali after the bsod, I’m guessing the reserved RAM is being released, so then Kali is able to see the full amount of RAM in the system.

So perhaps try disabling fast-boot?!

See also this:

Which backs up everything I’ve just said.
Towards the end of the article, it clearly states that Fast-boot typically reserves up to 75% of available RAM. Which is exactly the behaviour you’re seeing.

I’d recommend setting up your pc to allow you to get back into windows, then follow the steps to disable fast-boot. Then shut windows down completely. Then set your bios/UEFI up to allow your Kali install to boot.

Then Kali will always see the correct amount of RAM.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
13,559
Dagnabbit, I spotted that and was going to deal with it along with Timeshift, but Jas has phrased it better (and with a reference) than I would have done ... nice one Jas :)

I'll hold off on the Timeshift stuff until we see how the OP goes, but I would back money on the fast boot being the culprit.

Cheers

Wizard
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top