Parallels Desktop and Manjaro Linux

Ravel12

Member
Credits
360
This is not a question but more of sharing what I discovered.
If you boot Manjaro Gnome/KDE (maybe xfce too?) 20 live iso in Parallels Desktop 15, X will not start but if you CTRL-ALT-F2, you can see the prompt.

To get around this issue, disable 3D acceleration in vm settings, boot manjaro with boot option -xdriver=vesa and choose the non free drivers. This will allow X to start and install through the GUI.

1. Disable 3D in VM Settings
2. Add xdriver=vesa in boot options of Manjaro
3. X will start and provide you with a GUI installer
4. Install Manjaro using installer
5. Reboot
6. You will see a black screen. Wait a while and use CTRL-ALT-F2 to go to login prompt
7. login as root
8. pacman -S linux54 (Parallel tools doesn't work with linux56, the latest kernel :( )
9. pacman -R linux56 (Remove linux56 :( Hopefully parallel tools will work with 5.6 someday)
10. reboot after the kernel is installed
11. Repeat step 6 and 7
12. Click on the install parallel tools
13. mount /dev/sr0 /mnt
14. cd /mnt
15. ./install (This will install parallel tools if linux54 was corrected installed and booted into)
16. reboot and enjoy. (Remember to re-enable 3D)
 
Last edited:


Ravel12

Member
Credits
360
Th above steps do not work with manjaro 20.2

Try the following
1. Boot up the installer. You will reach a black screen
2. Ctrt alt F2
3. Login as root. Password is manjaro
4. pacman -Sy xf86-video-fbdev xf86-video-vesa
5. systemctl restart gdm
6. Or sddm if using kde
7. You should be able to install
8 . It using gnome, you will need to chroot into your installation, set the password for root, reboot into your installation, login as root, repeat steps 4 and 5. This is because gnome needs the gui to create your user
9. Kde should be able to skip chroot as root user and normal user passwords are created during installation. You will still need to login as root to install vesa and fbdev
 

bkarlan

New Member
Credits
7
This doesn't work. Using the 21.05 I cannot access root using Ctrl Atl F2 in Parallels. I'm using the keyboard function in the menu bar that is supposed to generate that keycode. I've also tried the keycodes on my MB Pro using either Ctrl Alt F2 or Ctrl Alt Fn F2.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top