No Longer Working

Eddie Paul Litz

Active Member
Apr 30, 2018
Reaction score
Can someone figure out why isn't working? Is was working for the longest time until sometime Ubuntu 21.10 got released. It was a favorite place to go to get Deb files. Can someone figure out why it's down please?

you mean this...?

do you have a vpn connected?...turn it off if you have

Reboot your pc and router

Are you using the browser that you usually do?

Maybe try a different browser?
It will be a vpn connection.
I just connected mine and that site will not connect
I'm not using a VPN. I tried it on Firefox & it's not working on there. I checked it on "Is it down right now" & it says "it's down for everyone"

lol...well that would hardly be correct....I am on that site as we speak
did you reboot...both pc and router ?
There IS a problem, but in Australia and on Firefox and Waterfox, it flashes through the error screen quickly and then displays the usual site.

Eddie Paul is signed off for now, but I will come back with a video once I've uploaded it and I will try for a screenshot.


Working fine in the UK
Using which browser, Brian ?
Drum roll - watch the video closely once I launch the address, and then I have captured a screenshot of the first page it goes to.

and the screenshot


The Distros I used were 'Impish Indri' GNOME that's Ubuntu 21.10 Desktop, since I figured Eddie would be on it, and 'Hirsute Hippo' Ubuntu 21.04, which I am retiring likely tomorrow since it has reached end of support.

Browsers used were Firefox latest and Waterfox latest on both Distros.

I would have been back sooner but it took a while to work out that my 'Impish Indri' was set up to launch under Wayland, which did not support the video player I was using without H264 codec, so I switched to Xorg and was OK.

So there IS a problem, which may be fatal for some and not for others.

In my case once I got to the usual screen, I had no trouble downloading the example of mplayer using wget.

I'll modify the above, that screenshot relates to Waterfox Classic being detected.

But I DID have the same sort of flashing screen with Firefox.

I'll check a couple more browsers under other distros.
Just tried it on Liberwolf [no vpn] loaded faster than FF
Works for me on: Firefox, Brave, Vivaldi and Chrome.
There are obviously rumblings in the jungle/gremlins in the works.

Immediately after my first reply to Eddie, I connected my vpn.....and the result of doing so was I was unable to connect.
Just for interests sake..... the vpn was routing via Switzerland.

Then @brickwizard chimed in with news that it is working in England/United Kingdom.

My browser is Chromium (latest)
brickwizards is Firefox (latest
wiardfrom oz's is waterfox (latest

"Is it down right now" has lost the plot and claimed it is down for everyone.....(when clearly it is not)

And it is working from The Netherlands for @f33dm3bits
claimed it is down for everyone.....(when clearly it is not)
@f33dm3bits has now reported No problems,

so some thoughts,
Is he routing through a country that has a block due to local copyrite laws
is there a block from his ISP
is his local sever having problems
or is there a problem with his own settings

Not working from Germany

It is working from Pennsylvania USA.....that is the state on the right hand side of Ohio...
I'll be back tomorrow with more, gotta cook tea.


Members online