Plex Server on Raspberry Pi4 issue

krpurcel

New Member
I am new to Linux. I'm trying to set up a Plex server on a Rasberry Pi 4. (Also new to Pi). I have the server created on Pi and have attached an external harddrive with movies to the Pi unit. In the Pi file manager the hard drive shows up on /media/pi/easystore with all the movies in it. However Plex does not recognize the content.

Checking on the web I found the article 'Using EXT, NTFS, or other format drives (internal or external) on Linux. I am working my way through it, but have hit a snag.

Per sections A & B I have identified the following:
disk to be added is /dev/sda1 = media/pi/easystore.
Block ID is /dev/sda1: LABEL="EASYSTORE" UUID="0E8A79768A795AE3" TYPE="ntfs" PTTYPE="atari" PARTLABEL="easystore" PARTUUID="96679758-b2c9-4156-9879-62299f4c7786"

Section C of the article is entitled 'Create The Locations Where We Will Graft Everything into Linux.' The instructions say you need to replace the username "Chuck" with your actual Linux username in the code. Then it shows the command "chown -R chuck:chuck /disks". I am unable to duplicate this step and am unsure what I am doing wrong. The whoami command lists my Linix username as "pi". However Substituting pi for chuck in the code example (chown - R pi:pi /disks) returns "cannot access '/disks': no such file or directory exists".
There is no directory named disks under the pi directory so that makes sense I guess. Section C of the article says the Media directory is used by the OS, so I created a directory named disks on the root drive. If I run 'ls -l' it shows up - 'drwxr-xr-x 2 pi pi 4096 Nov 18 06:12 disks'

Can someone explain to me what I am doing wrong at this step? I have replaced "Chuck" in that command with different variations of both 'pi' and 'easystore' without success.

One other noob question. The command 'sudo sh' takes you to a '#' prompt. What command returns you to the normal command line? I haven't figured that out and keep closing and reopening the command prompt screen to get out of it.

Thanks for your help!

Kevin
 


JulienCC

Active Member
There's a typo in the article. There's a command that is not on it own line and appears as a comment.
Do this before the chown stuff and things are going to be alright :
Code:
# mkdir /disks /disks/c /disks/media3 /disks/chuck2t
The command 'sudo sh' takes you to a '#' prompt. What command returns you to the normal command line? I haven't figured that out and keep closing and reopening the command prompt screen to get out of it.
Code:
# exit
 

krpurcel

New Member
Julien,

Thanks for your kind reply and your help. I was moving along an making progress. Then disaster! :)
I was successful in mounting the external hard drive. It appeared in DF. If I then used the unmount command it disappeared.

However it appears I messed up editing the /etc/fstab file. I edited it to be the following:
proc /proc proc defaults 0 0
/dev/mmcblk0p6 /boot vfat defaults 0 2
/dev/mmcblk0p7 / ext4 defaults,noatime 0 1
/dev/sda1 /media/pi/easystore ntfs-3g defaults 0 0
UUID=OE8A79768A795AE3 /disks/easystore ntfs defaults,auto,rw,nof

Once I did that, raspberry pi will not reboot properly. I get a message saying "Cannot open access to console, the root account is locked. See su log in (8) man page for more details. Press enter to continue".

The web tells me to type init=/bin/bash, but I am in a loop and cannot type anything. Pressing enter simply repeats the emergency mode information and returns to "Press Enter to continue".

Can you tell me how to fix this? And do you have suggestions as to how best save myself this kind of headache next time?

Thanks,
Kevin
 

JulienCC

Active Member
The web tells me to type init=/bin/bash
You have to add this as a kernel boot option. Since you're on a Pi I don't know if you have any bootloader. If you have grub or something like this, edit the boot command and add "init=/bin/bash", which will give you a root shell straight after the booting process and will allow you to fix what you broke.

Can you tell me how to fix this?
You need to fix your fstab file, which means access this file. If its on an sdcard you can mount the card on an other system. Otherwise you will need to find a way to add this boot option to your kernel boot command.

UUID=OE8A79768A795AE3 /disks/easystore ntfs defaults,auto,rw,nof
If think this is because you used an invalid option(I dont think "nof" is a thing) and you forgot the two last parameters (dump and fsck), this line should be
Code:
UUID=OE8A79768A795AE3 /disks/easystore ntfs defaults,auto,rw,nofail 0 0
And do you have suggestions as to how best save myself this kind of headache next time?
You are actually learning so not much to say. Try to read the documentation as much as possible, especially before messing with parameters. Linux has some doc for everything : http://www.man7.org/linux/man-pages/man5/fstab.5.html
 

Staff online

Members online


Latest posts

Top