Problem installing Linux mint 20 on Lenovo IdeaPad s340

cosmic mango

New Member
Joined
Jul 3, 2021
Messages
11
Reaction score
1
Credits
82
I have installed Linux on several older computers in the past with no problem, but this newer one, Lenovo IdeaPad s340 has UEFI and I can't figure out how to get it to boot up from a flash drive. I've looked at some YouTube videos, and their instructions don't seem to work.
 


Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
3,761
Reaction score
3,368
Credits
18,550
G'day cosmic mango, Welcome to Linux.org

Are you able to try the flash drive on another pc to be sure it is working ok ?

Have you disabled secure boot ?
 
OP
C

cosmic mango

New Member
Joined
Jul 3, 2021
Messages
11
Reaction score
1
Credits
82
Disabling secure boot is where the problem is. When I try to disable it, the down arrow bypasses that option. The instructions on YouTube indicate that it takes several different steps to do it, and my computer is not exactly the same as the one they are using - theirs is an s320, not an s340 and, although very similar, the options are not the same. It doesn't have a simple one step option to disable secure boot.
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
3,761
Reaction score
3,368
Credits
18,550
Try this
 
OP
C

cosmic mango

New Member
Joined
Jul 3, 2021
Messages
11
Reaction score
1
Credits
82
Thank you for your reply! When I checked today, it looks like I did somehow already disable secure boot, but maybe I was too tired and frustrated last night to realize it. So I didn't need to set a password.
So, now I am installing Linux Mint 20 and, after selecting English it is telling me I have to disable RST. There is a link, help.ubuntu/rst. I'm looking at it and haven't quite figured out what to do...
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
3,761
Reaction score
3,368
Credits
18,550
Are you attempting to dual boot...Windows with LM20 ?
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
3,761
Reaction score
3,368
Credits
18,550
I believe the problem is not ubuntu/linux....it is windows


I think this one applies to your situation.....

Choice #2: See http://triplescomputers.com/blog/un...ch-windows-10-from-raidide-to-ahci-operation/

  • Right-click the Windows Start Menu. Choose Command Prompt (Admin).
  • If you don’t see Command Prompt listed, it’s because you have already been updated to a later version of Windows. If so, use this method instead to get to the Command Prompt:
  • Click the Start Button and type cmd
  • Right-click the result and select Run as administrator
  • Type this command and press ENTER: bcdedit /set {current} safeboot minimal
  • If this command does not work for you, try bcdedit /set safeboot minimal
  • Restart the computer and enter BIOS Setup (the key to press varies between systems).
  • Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
  • Save changes and exit Setup and Windows will automatically boot to Safe Mode.
  • Right-click the Windows Start Menu once more. Choose Command Prompt (Admin)
  • Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
  • If you had to try the alternate command above, you will likely need to do so here also: bcdedit /deletevalue safeboot
  • Reboot once more and Windows will automatically start with AHCI drivers enabled.

Good Luck....this is uncharted territory for me as well.
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
3,761
Reaction score
3,368
Credits
18,550
maybe just maybe the crucial words are :
  • Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
maybe
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
3,761
Reaction score
3,368
Credits
18,550
ALSO....read this
It is on the same page at the bottom....

this may be a late answer, but this works perfectly without changing anything as given in the accepted answer.

before starting the process keep the Backup of your data from the System

after backup follow the below given steps to disable the RST and install the OS you wished too

here are the steps to disable the RTS from the windows system.

  1. Insert the Booted USB or CD.
  2. while starting the PC/Laptop keep pressing the f2 button or any other according to the system to open the BIOS menu.
  3. after opening the BIOS menu move to the Configuration tab.
  4. at the bottom of the Configuration Tab you find the option names as storage, Click on that
  5. after the storage Menu opens you find the DROPDOWN with ACHI and RAID SATA.
  6. choose the ACHI from Dropdown and press f10 or any other according to the system to save the setting.
  7. after step 6 PC will get shutDown or Restart, while starting keep press the f12 or any other according to the system to save the setting.
  8. after doing the above steps correctly you will get the boot menu with the USB or CD you inserted.
above steps are tried and verified with the Lenovo ideapad s340

Caution
: After this you won't get back the Winows and the Windows Key
 
OP
C

cosmic mango

New Member
Joined
Jul 3, 2021
Messages
11
Reaction score
1
Credits
82
This is so unreal...I followed the instructions and switched to ACHI and that solved that problem. Now there is a new problem...When I get to the installation screen, I select 'Erase disk and install Linux Mint'.
It gives the usual warning and then it goes right back to the original installation screen, or to the choose the partition screen. It refuses to just start installing!!!
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
3,761
Reaction score
3,368
Credits
18,550
Reboot ?
 
OP
C

cosmic mango

New Member
Joined
Jul 3, 2021
Messages
11
Reaction score
1
Credits
82
I rebooted. A question - In the grub menu (I think that's what it's called) - What is the difference between 'Start Linux Mint...' and 'Start Linux Mint...' (compatibility mode)?
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
3,761
Reaction score
3,368
Credits
18,550
I have never investigated compatibility mode......I always select 'start linux mint'
 
OP
C

cosmic mango

New Member
Joined
Jul 3, 2021
Messages
11
Reaction score
1
Credits
82
o.k. Was just wondering if that was something relevant...
Wow! Rebooting seems to have worked! Yay! It is proceeding along as it should.
One more question - It's getting really late here on the west coast of the U.S. Is it o.k. to stop the installation now and do it tomorrow? Will that mess up anything?
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
3,761
Reaction score
3,368
Credits
18,550
Its ok to get some shut eye.

Just leave it where it is, and take up there tomorrow.
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
3,761
Reaction score
3,368
Credits
18,550
All cool...sleep well

btw was that Linux Mint 20.1 ?
 
OP
C

cosmic mango

New Member
Joined
Jul 3, 2021
Messages
11
Reaction score
1
Credits
82
It's Linux 20. That's only because I had already put it on a thumb drive for another computer some months back, and I didn't want to take the time to do it all over again for the latest version.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top