Problem with accessing nextcloud outside local network, but vnc works outside local network

tesla123

New Member
Credits
27
I installed nextcloud (this is a software for syncing files from computer and other devices on the server and you can access them there, you can also text, videocall..., it's really cool) i am running on a orangepi3 running armbian which is debian based, i set port forwarding for port 5901 and dynamic dns i can access the pc outside my local network with no problem, but now i want to also set this for nextcloud, locally i can access it from 192.168.0.105/nextcloud, it should ne also running on port 443 but i can't access it from there, it just shows me the apache2 debian default page, i have also portforwarding for port 443 and 80, but when i enter https://my_domain_name:443 it says SSL_ERROR_RX_RECORD_TOO_LONG and on edge ERR_SSL_PROTOCOL_ERROR , so there is something wrong with ssl i guess?, i don't know much about it, i followed this guide for setting it up https://pimylifeup.com/raspberry-pi-ssl-lets-encrypt/, i also set my domain name on port 443 to use https instead of http, i edited 000-default.conf file in sites available apache2, if you need any extra info please tell me
 


tesla123

New Member
Credits
27
Nvm fixed it, mydomainname/nextcloud automatically uses 443 port and i alos set https, another thing how can i set a different port in tightvncserver?, because i have port forwarding on 5901 and i think that botnets are trying to brute force my vnc since it says authentication failure due too to many incorrect tries after a few hours of vnc running, i temporarely turned it off
 


Members online


Top