Problem with printer installation in both PRINT MANAGER and HPLIP under Deepin 20


New Member
I started with Deepin with version 15.11 in 2017. After years, I was fed up with Bil Gates and his invention. During this time I tried several distros, including Solus, Zorin, Mint and FreeBSD. Then I decided on Deepin. Deepin has almost completely replaced Microsoft for me. Unfortunately there is still a need for programs that cannot be replaced under Linux, such as Snagit, alas.

I've tried several things under Deepin and I'm more than happy with the distro.
Unfortunately, since the new version Deepin 20 there are a few problems

I successfully turned away an HP C7280 for over 10 years, although it was only really fun to work with the printer under Linux Deepin.

I bought a new printer for Christmas (HP OfficeJet Pro 7720) and tried to install it via Print Manager like the previous one. But unfortunately I was not able to complete the installation successfully and that worries me very much because I cannot help myself further.

When completing the installation, there are some errors that I unfortunately cannot start with? I've attached some screenshots here.

I tried to install it via hplip. The same problems arose. I already wrote to because of the problem. Unfortunately I don't think I can get any support from there?

You can see from the attached screens that this is a bigger problem.

I also tried adding the button via http: // localhost: 631. Even without success.
There was also the option of selecting the appropriate PPD file and thus completing the installation. Unfortunately, the files are not offered anywhere? In particular, the Hplip site would have to offer this in case something goes wrong and why they don't ... a legitimate question, right?

Since I have other laptops with Deepin as the operating system, I also tried the o.g. To install pushers. Unfortunately the same problem.

I also thought that maybe the problem was with the pusher, but I don't think it is? I firmly believe that the problem is with the driver. It looks like it has several problems and only a correct PPD file might be the solution?

I would be very grateful if someone could help me with this problem?



Staff member
Gold Supporter
G'day @mirro176 and welcome to :)

You could try to do it through CUPS


However I am not an expert in CUPS, maybe someone else is.

Good luck

Chris Turner
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online