• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Pronterface (Printrun) won't start up.

3dArnie

New Member
Joined
May 20, 2023
Messages
7
Reaction score
1
Credits
145
Hi guy,s here is my system info having problems with running Pronterface (Printrun) won't start up.
due to an issue with Python 3.10.
The Ubuntu packagers included the fix on Ubuntu 22.10. So any versions prior to that will have to either use the workaround or run the latest Printrun from source. Sadly, Linux Mint 21 is based on Ubuntu 22.04. Maybe ask the Linux Mint packagers (or the Ubuntu ones) to back-port the fix?
I use this for my 3D printing machines and is very important software i use.
However it will not run , only runs with a work around using terminal type " ./pronterface.py " in the dir of Printrun it starts up but that sucks don't want to leave Mint there must be something that can be done:)

System info:
Kernel: 5.15.0-72-generic x86_64 bits: 64 compiler: gcc v: 11.3.0 Desktop: Cinnamon 5.6.8
tk: GTK 3.24.33 wm: muffin dm: LightDM Distro: Linux Mint 21.1 Vera base: Ubuntu 22.04 jammy
Machine:
Type: Laptop System: TOSHIBA product: SATELLITE L775-18Q v: PSK3WE-05X00UDU
serial: <superuser required> Chassis: type: 9 serial: <superuser required>
Mobo: Intel model: Oneonta Falls serial: <superuser required> BIOS: American Megatrends
v: 1.70 date: 08/22/2011
Battery:
ID-1: BAT0 charge: 20.8 Wh (100.0%) condition: 20.8/48.4 Wh (42.9%) volts: 12.3 min: 10.8
model: TKBSR NS2P3SZMP4WR serial: N/A status: Full
CPU:
Info: dual core model: Intel Core i5-2450M bits: 64 type: MT MCP arch: Sandy Bridge rev: 7
cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
Speed (MHz): avg: 919 high: 1037 min/max: 800/3100 cores: 1: 879 2: 798 3: 1037 4: 964
bogomips: 19955
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Graphics:
Device-1: NVIDIA GF108M [GeForce GT 525M] vendor: Toshiba driver: nouveau v: kernel pcie:
speed: 2.5 GT/s lanes: 16 ports: active: LVDS-1 empty: HDMI-A-1,VGA-1 bus-ID: 01:00.0
chip-ID: 10de:0dec
Display: x11 server: X.Org v: 1.21.1.4 driver: X: loaded: modesetting unloaded: fbdev,vesa
gpu: nouveau display-ID: :0 screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 96
Monitor-1: LVDS-1 model: LG res: 1600x900 dpi: 106 diag: 438mm (17.3")
OpenGL: renderer: NVC1 v: 4.3 Mesa 22.2.5 direct render: Yes
 


Ok still no solutions tried changing PC:
System:
Kernel: 5.15.0-78-generic x86_64 bits: 64 compiler: gcc v: 11.3.0 Desktop: Cinnamon 5.8.4
tk: GTK 3.24.33 wm: muffin dm: LightDM Distro: Linux Mint 21.2 Victoria base: Ubuntu 22.04 jammy
Machine:
Type: Desktop System: LENOVO product: 7556E8G v: ThinkCentre Edge 91Z
serial: <superuser required>
Mobo: LENOVO model: N/A serial: <superuser required> BIOS: LENOVO v: 9OKT18AUS
date: 06/29/2011
CPU:
Info: quad core model: Intel Core i7-2600S bits: 64 type: MT MCP arch: Sandy Bridge rev: 7
cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
Speed (MHz): avg: 1596 high: 1597 min/max: 1600/3800 cores: 1: 1596 2: 1596 3: 1596 4: 1596
5: 1596 6: 1597 7: 1596 8: 1596 bogomips: 44696
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
Device-1: AMD Onega [Radeon HD 6650A/7650A] vendor: Lenovo driver: radeon v: kernel pcie:
speed: 5 GT/s lanes: 16 ports: active: DVI-D-1 empty: HDMI-A-1,VGA-1 bus-ID: 01:00.0
chip-ID: 1002:6750
Display: x11 server: X.Org v: 1.21.1.4 driver: X: loaded: ati,radeon
unloaded: fbdev,modesetting,vesa gpu: radeon display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96
Monitor-1: DVI-0 mapped: DVI-D-1 model: Lenovo LEN-E91-B res: 1920x1080 dpi: 102
diag: 546mm (21.5")
OpenGL: renderer: AMD TURKS (DRM 2.50.0 / 5.15.0-78-generic LLVM 15.0.7)
v: 4.5 Mesa 23.0.4-0ubuntu1~22.04.1 direct render: Yes
 
Still don't understand why you can download software using " Software Manager " if it doesn't run!
 
Pronterface has not been updated for around 6 years, however if your running a recent releace [which you are] then

sudo apt install printrun should install the application and dependencies [so I have read] [by using the apt command normally enforces dependencies, software managers do not always do this]
 
System:
Kernel: 5.15.0-91-generic x86_64 bits: 64 compiler: gcc v: 11.4.0 Desktop: Cinnamon 6.0.4
tk: GTK 3.24.33 wm: muffin dm: LightDM Distro: Linux Mint 21.3 Virginia base: Ubuntu 22.04 jammy
Machine:
Type: Desktop System: LENOVO product: 7556E8G v: ThinkCentre Edge 91Z
serial: <superuser required>
Mobo: LENOVO model: N/A serial: <superuser required> BIOS: LENOVO v: 9OKT18AUS
date: 06/29/2011
CPU:
Info: quad core model: Intel Core i7-2600S bits: 64 type: MT MCP arch: Sandy Bridge rev: 7
cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
Speed (MHz): avg: 1596 high: 1597 min/max: 1600/3800 cores: 1: 1596 2: 1597 3: 1596 4: 1595
5: 1596 6: 1596 7: 1596 8: 1596 bogomips: 44699
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
Device-1: AMD Onega [Radeon HD 6650A/7650A] vendor: Lenovo driver: radeon v: kernel pcie:
speed: 5 GT/s lanes: 16 ports: active: DVI-D-1,HDMI-A-1 empty: VGA-1 bus-ID: 01:00.0
chip-ID: 1002:6750
Device-2: Genesys Logic Digital Microscope type: USB driver: uvcvideo bus-ID: 2-1.5:6
chip-ID: 05e3:f12a
Display: x11 server: X.Org v: 1.21.1.4 driver: X: loaded: ati,radeon
unloaded: fbdev,modesetting,vesa gpu: radeon display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96
Monitor-1: DVI-0 mapped: DVI-D-1 pos: primary,left model: Lenovo LEN-E91-B res: 1920x1080
dpi: 102 diag: 546mm (21.5")
Monitor-2: HDMI-0 mapped: HDMI-A-1 pos: right model: Samsung S24B300 res: 1920x1080 dpi: 94
diag: 598mm (23.5")
OpenGL: renderer: AMD TURKS (DRM 2.50.0 / 5.15.0-91-generic LLVM 15.0.7)
v: 4.5 Mesa 23.0.4-0ubuntu1~22.04.1 direct render: Yes
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
Device-2: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series] vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: speed: 5 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aa90
Sound Server-1: ALSA v: k5.15.0-91-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e v: kernel port: f040
bus-ID: 00:19.0 chip-ID: 8086:1502
IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Centrino Wireless-N 1000 [Condor Peak] driver: iwlwifi v: kernel pcie:
speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:0084
IF: wlp3s0 state: down mac: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 150.41 GiB (16.1%)
ID-1: /dev/sda vendor: Seagate model: ST1000DM003-1SB102 size: 931.51 GiB speed: 6.0 Gb/s
serial: <filter>
Partition:
ID-1: / size: 435.3 GiB used: 150.4 GiB (34.6%) fs: ext4 dev: /dev/sda6
ID-2: /boot/efi size: 511 MiB used: 11.7 MiB (2.3%) fs: vfat dev: /dev/sda5
Swap:
ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile
Sensors:
System Temperatures: cpu: 47.0 C mobo: N/A gpu: radeon temp: 59.0 C
Fan Speeds (RPM): N/A
Repos:
Packages: 2874 apt: 2849 flatpak: 25
No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http: //packages.linuxmint.com virginia main upstream import backport
2: deb http: //archive.ubuntu.com/ubuntu jammy main restricted universe multiverse
3: deb http: //archive.ubuntu.com/ubuntu jammy-updates main restricted universe multiverse
4: deb http: //archive.ubuntu.com/ubuntu jammy-backports main restricted universe multiverse
5: deb http: //security.ubuntu.com/ubuntu/ jammy-security main restricted universe multiverse
Active apt repos in: /etc/apt/sources.list.d/vscode.list
1: deb [arch=amd64,arm64,armhf] http: //packages.microsoft.com/repos/code stable main
Info:
Processes: 286 Uptime: 20m Memory: 15.57 GiB used: 2.18 GiB (14.0%) Init: systemd v: 249

stil can't run Printrun alias "Pronterface" what happend to Linux
 

Members online


Top