Question on backport DMA Driver on linux 4.14.226

pramodsmvdu

New Member
Credits
17
I am trying to use snps (synopsys) DMA controller driver with linux version 4.14.226.

while testing Audio playback with ALSA we found issue so we took the many changes from linux 5.12
https://elixir.bootlin.com/linux/v5.12/source/drivers/dma/dw-axi-dmac/dw-axi-dmac-platform.c#L680

the old code from 4.17 https://elixir.bootlin.com/linux/v4.17-rc1/source/drivers/dma/dw-axi-dmac does not seem to be working.

to do this we had to change many base files of linux (4.14.226) which does not seem to be good for us.

Do you suggest any way to make the latest DMA controller driver to work on linux 4.14.226 without modifying base 4.14.226 linux file?
what should be the correct approach to backport it.

Looking forward to hearing from you soon and thanks in advance.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top