Reboot instead shutdown

polgia

New Member
Joined
Nov 15, 2023
Messages
3
Reaction score
1
Credits
34
Hi,
I installed Linux Mint 21.3 on a Dell Alienware X14 notebook. Everything works well and I am pretty satisfied.
However, there is a small issue regarding the shutdown. Each time I push the button, the system shuts down but after 5 seconds it reboots again. Then, if I push the button, it shuts down and it never restarts. The rule of two shutdowns is always respected.
I made several tests since this is a documented issue (such as disabling USB wake-up in BIOS or removing all external peripherals) but I could not find a solution. My impression is that some process does not end correctly and it causes wake-up. I tried to read the messages in the journal, but I did not understand too much. Any suggestions?
Thanks
polgia
 

Attachments

  • System_Info_Report.txt
    6.2 KB · Views: 89


G'day polgia, Welcome to Linux.org

if you click on menu and type in Power Management.....you should see a screen which looks like the below...:

1700069990407.png


That is the setting on my PC, (running LM21.2) and it does exactly that....shuts down.

Is your setting the same ?

Is it possible you are holding the button in for a moment too long?...
 
Thanks for your answer.
I realized I was not clear: when I said button I meant the shutdown button of the Cinnamon desktop. Not the physical On/Off button of the notebook.
However, I did what you said and it works, at least up to now. Pressing the Button of the PC the system turns off without reboot.
This confirms that the issue is a software problem, probably inside the software procedure of shutdown in Cinnamon.
I test the behavior for some time to be sure everything works and then I will put "solved" on the title.
Thanks for your suggestion!
 
I have to say that the problem is not solved. In fact, even pressing the PC On/Off, the PC restarted in a couple of cases. This makes things difficult. I read it may be related to some ACPI/Bluetooth error messages I have at boot. Bios is updated to the last version and I suppose problems are coming with the Nvidia board (may could be useful to open source drivers?).
I have no idea if I can investigate more. Suggestions?
Regards
 

Attachments

  • log messages.txt
    640 bytes · Views: 106
Two errors from the output of your file look like they may be implicated:
Code:
17:15:20 kernel: dell_smbios: Unable to run on non-Dell system
  7 17:15:20 kernel:
  8 17:15:20 kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20221020/psobject-220)

Your machine appears to be Alienware, a subsidiary of Dell, but using a Dell BIOS. It may be the default BIOS for your machine, but the kernel sees it as a problem, differentiating the machine from original Dell. There may not be much you can do about that without a different kernel that copes with the issue. It shouldn't reflect on your issue though since it's about accessing info.

The second issue is the ACPI error. These often appear in linux and are mostly harmless because the BIOS/UEFI software is often non-compliant with ACPI standards, and the kernel picks that up. Manufacturers take short cuts. Nevertheless, you can try to add the kernel parameter: acpi=off, at boot up to disable ACPI, and see if it makes a difference. It may have other effects that you don't wish for, so it is entirely reversible by removing the parameter.
 
Last edited:

Members online


Top