• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Repository problems


New Member
Jun 6, 2017
Reaction score
I was trying to get Winehq from the Wine website. I copied and pasted the command line input for the Wine Repository. Since then, when I try to open the Synaptic package manager or do anything from terminal, I get this error msg: E:Malformed entry 1 in list file. etc/apt/sources.list.d/additional-repositories.list (URI parse)
E: List could not be read.
Go to the repository dialog to correct the problem
E: _cache ->open()failed, please report
I don't know what to do next.

E:Malformed entry 1 in list file. etc/apt/sources.list.d/additional-repositories.list (URI parse)

There is a mistake (malformation) in your sources list.

Do something like
cat /etc/apt/sources.list
Then Copy and Paste the whole of your sources list here, so we can see it.
Do you mean like this?
cat /etc/apt/sources.list
#deb cdrom:[Linux Mint 19 _Tara_ - Release amd64 20180717]/ bionic contrib main non-free
I've looked again at your first post.

The problem is not your sources list! It's sources.list.d. :(

What are the contents of /etc/apt/sources.list/*

cat /etc/apt/sources.list/*

Can you also look inside the Wine file inside sources.list.d. Your Package Manager should enable you to do that. What does it say?

Your sources list only contains the CD and it is non-operational. It has a # at the beginning of the line. Do you not access the Internet. Otherwise, it should be more than this. You might look at https://easylinuxtipsproject.blogspot.com/p/sources.html ---BUT this is only for Linux Mint 19.3
Last edited:
As a follow up, I've come to the conclusion that all the repository info on my computer was wiped out when I tried to add the repository for Wine 5.0. I still haven't found any documentation that shows me how to get it back. I've tried doing it from the software source and applying a repository. That didn't work. I tried typing in one of the URL repositories but I couldn't make out what to do with it. The only thing I can think of is to reload the OS.


  • synaptic package mgr error.png
    synaptic package mgr error.png
    16.6 KB · Views: 666
Which Linux are you using ?
if you are unsure....click on menu, and type in Welcome ....tell us the information that is shown there

have you made use of an app called Timeshift since booting up Linux ?

If you are comfortable reinstalling the OS, that will be the simplest solution. Is there any data/pics/music etc etc that you need to save before you do that ?

You can try this if you are game :...double click on Home....then click on Files (i dont have a copy of Linux in front of me atm....so I am hoping this is correct)....then open(double click) etc......then click on apt......then on sources.list.d.......then additional-repositories.list,,,,,tell me what you see there

:)Malformed entry 1 in list file. etc/apt/sources.list.d/additional-repositories.list (URI parse) ...)

Just keep in mind that if you have nothing you need to save in the way of pics/data etc etc....then you have nothing to lose by trying out the double click on home etc etc

**...If you do decide to reinstall....and you have your OS on a thumb drive/usb drive.......then just boot to that usb drive and click on "Install" on the desktop.**
Last edited:
Linux Mint 19 Tara in #3, Brian.

Wizard just passing through. :)
#deb cdrom:[Linux Mint 19 _Tara_ - Release amd64 20180717]/ bionic contrib main non-free
I cannot install update, it tells me malformed entry 4 in list.........I'm a newbie, hate windows but start getting devastated with linux
g'day @Som_Olli and welcome.

grab your question and start a thread - right-hand side post thread.



Staff online

Members online

Latest posts