Routing with VPN doesn't work, I wonder why?


New Member
Sep 4, 2020
Reaction score

I'm establishing a VPN connection, but it doesn't seem to work like I thought. Here's the resulting routing table ant the traceroute output:

root@porteus:/home/guest# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface UG 100 0 0 eth0 UGH 1000 0 0 tun0 UH 0 0 0 tun0 U 0 0 0 lo UG 1000 0 0 tun0 U 100 0 0 eth0
root@porteus:/home/guest# traceroute
traceroute to (, 30 hops max, 60 byte packets
1 home ( 1.719 ms 3.817 ms 3.892 ms
2 ( 6.225 ms 6.078 ms 6.031 ms

I tried to specify in my OVPN file route-metric 0 but no luck, all packets are still not using my VPN at all. What should I change to make my VPN interface tun0 to be default and the only interface for all TCP/IP communications on my machine?

Go to the web page at and scroll down to step 5.
I just wrote an article on setting this up for the LCFS series. This is not an easy setup, whether it is CentOS or Ubuntu. No matter your distro, this should help. The problem is you need to MASQUERADE the firewall.

Members online