RTL8812AU - device not ready

skcay

New Member
Credits
15
Hey there :)

I bought a new wifi adapter (TP-Link Archer T4U v.3 | RTL8812AU) which I try to get working..


My internal wifi card works, so don't care about that one :)

I think I installed all the drivers using that manual.

But if I click in the top-right corner on wifi it always says "device not ready"...

May you help me, please? :)

Here are some information.

I use Kali Linux 2020.3


ifconfig result:

Bash:
[email protected]:/home/skcay# ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 92 bytes 6952 (6.7 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 92 bytes 6952 (6.7 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.179.27 netmask 255.255.255.0 broadcast 192.168.179.255
inet6 fe80::c0c:7471:3a43:eef0 prefixlen 64 scopeid 0x20<link>
inet6 2001:16b8:b3:7a01:79f7:6368:3816:8686 prefixlen 64 scopeid 0x0<global>
ether f8:28:19:e8:f6:49 txqueuelen 1000 (Ethernet)
RX packets 122729 bytes 147659931 (140.8 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 59996 bytes 8438389 (8.0 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

iwconfig result (wlan0)

Bash:
[email protected]:/home/skcay# iwconfig
lo no wireless extensions.

wlan1 IEEE 802.11 ESSID:"Martin Router King Gast"
Mode:Managed Frequency:2.462 GHz Access Point: 46:4E:6D:56:1D:3E
Bit Rate=1 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on
Link Quality=33/70 Signal level=-77 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1 Invalid misc:11 Missed beacon:0

wlan0 unassociated ESSID:"" Nickname:"<[email protected]>"
Mode:Managed Frequency=2.412 GHz Access Point: Not-Associated
Sensitivity:0/0
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/100 Signal level=0 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
lshc -C network result

Bash:
[email protected]:/home/skcay# lshw -c network
*-network
description: Wireless interface
product: QCA6174 802.11ac Wireless Network Adapter
vendor: Qualcomm Atheros
physical id: 0
bus info: [email protected]:6b:00.0
logical name: wlan1
version: 32
serial: f8:28:19:e8:f6:49
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ath10k_pci driverversion=5.7.0-kali1-amd64 firmware=WLAN.RM.4.4.1-00140-QCARMSWPZ-1 ip=192.168.179.27 latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:143 memory:6e200000-6e3fffff
*-network DISABLED
description: Wireless interface
physical id: 3
bus info: [email protected]:7
logical name: wlan0
serial: f6:0f:4f:30:dc:90
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=rtl88XXau driverversion=5.7.0-kali1-amd64 multicast=yes wireless=unassociated


ip link set dev wlan 0 up result

Bash:
[email protected]:/home/skcay# ip link set dev wlan0 up
RTNETLINK answers: Operation not permitted

I have no idea what to do, maybe you can help me!

Thank you!

*Sorry for spelling mistakes..

Skcay.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Top