Screen is laggy and stutters even after changing settings

BigCapitalist

New Member
Credits
240
I tried changing my settings in Linux because it was not running at the right framerate and I am getting screen tearing but nothing has worked so far. I ran the XRANDR command and changed the settings to a higher HZ but the monitor is still extremely laggy and stutters. What could I be doing wrong?
 


dos2unix

Well-Known Member
Credits
2,904
What linux? What kernel? What video card? What monitor? What resolution?
What video drivers? A lot of things make a difference.

1603848129230.png

I actually get better performance from Linux these days than I do from my Windows box.
( Admittedly, it is nVidia 2080 vs nVidia 1080 ) .. but even so.

1603848254896.png


Remember your monitor has to support the refresh rate you type in, if you type a higher number, it may slow you down or even break. Also what is the pixel color change speed 4ms or lower is good.
This monitor is 1ms GTG. Even the cable and monitor can make a difference. For example one monitor I have supports 144Hz using the display port, but only 60Hz using HDMI.
Another monitor I have supports 60Hz in 2k (QHD) mode, but only 30Hz in 4k mode.

1603848747117.png


All these little things like flipping and texture mapping make a big difference.

1603848836970.png


A newer kernel can also speed things up. I would recommend 4.18 or newer.
I am currently running 5.8.16.
 
Last edited:

Nelson Muntz

Active Member
Credits
2,292
What linux? What kernel? What video card? What monitor? What resolution?
What video drivers? A lot of things make a difference.
Specs are in the thread.
 

jglen490

Well-Known Member
Credits
3,076
You have a built in Intel video chip and an installed Nvidia card, according to your other post.

System:
Kernel: 5.4.0-52-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Gnome 3.36.4 Distro: Ubuntu 20.04.1 LTS (Focal Fossa)
Machine:
Type: Desktop Mobo: ASUSTeK model: B250 MINING EXPERT v: Rev X.0x
serial: <filter> UEFI: American Megatrends v: 1208 date: 09/24/2019
CPU:
Topology: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP
arch: Skylake-S rev: 3 L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 27999
Speed: 3319 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 2261 2: 2024
3: 2196 4: 2055
Graphics:
Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel
bus ID: 00:02.0
Device-2: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Gigabyte
driver: nvidia v: 455.32.00 bus ID: 01:00.0
Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia
unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: N/A v: N/A direct render: N/A
Audio:
Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus ID: 00:1f.3
Device-2: NVIDIA GP106 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus ID: 01:00.1
Sound Server: ALSA v: k5.4.0-52-generic
Network:
Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k
port: f040 bus ID: 00:1f.6
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: e000
bus ID: 0c:00.0
IF: wlp12s0 state: up mac: <filter>
Drives:
Local Storage: total: 232.89 GiB used: 13.09 GiB (5.6%)
ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB
Partition:
ID-1: / size: 227.74 GiB used: 13.08 GiB (5.7%) fs: ext4 dev: /dev/sda2
Sensors:
System Temperatures: cpu: 29.8 C mobo: 28.0 C gpu: nvidia temp: 52 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 286 Uptime: 6m Memory: 7.66 GiB used: 1.73 GiB (22.5%)
Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17
inxi: 3.0.38
Go into Synaptic or Muon and install the nvidia-settings package, since you have the nvidia 455 driver installed. I don't know if that is the actual recommended driver, but it sounds about right for your video card. The nividia-setting package will give you a GUI to help you fine tune your setting. The xrandr utility is good, but the native Nvidia stuff is better.

You should also use the Driver Manager GUI in System Settings, or ubuntu-drivers devices on the CLI, to make sure that the 455 driver is recommended for your card.
 


Members online


Top