Screen tearing when watching videos and scrolling...

Jaymz_RG1003

New Member
Joined
Nov 9, 2021
Messages
28
Reaction score
2
Credits
194
Hi, I'm new to Linux and so far loving it. There is one problem that I can't seem to fix, though: Screen tearing.

I notice it most when watching YouTube videos on Firefox. I tried to see if maybe it was something conflicting with the browser, so I tried Pale Moon browser (the only other browser that doesn't have the extreme screen tearing with large, random geometric shapes all over), and the normal screen tearing happens on Pale Moon when watching videos on YouTube and also scrolling up and down pages.

I have tried several remedies, such as, disabling hardware acceleration in Firefox, turning off vblank_mode for xfwm4 in the Settings Editor, and switching to the proprietary driver (it was using the Linux version of a driver automatically and saying there are no additional drivers available in the additional drivers tab of Software & Updates).

Here's my desktop info:
Model: HP p6203w
OS: Linux Lite - Ubuntu 20.04.3 LTS, Kernel 5.4.0-89-generic (x86_64)
Vendor: Nouveau
Graphics card: NVIDIA GeForce 6150SE nForce 430 (old, I know, lol)
 


OP
J

Jaymz_RG1003

New Member
Joined
Nov 9, 2021
Messages
28
Reaction score
2
Credits
194
You could try this.
Yes, the force full composition pipeline was one of the first things I tried when I first installed Linux and was crashing my desktop whenever I'd watch a video on VLC player. That seems to have fixed that particular problem.
 

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
Did that help?
 

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
OP
J

Jaymz_RG1003

New Member
Joined
Nov 9, 2021
Messages
28
Reaction score
2
Credits
194
You could try running Debian 9 Stretch and install the nvidia-legacy-304xx-driver.
Debian 9 is only supported until June of 2022 so that will buy you some time.

Here's the article:

Maybe try a more light weight distro like Linux Lite or MX Linux?
I thought I was running Linux Lite, lol. That's what the label said it was when I downloaded the OS. I'll try the your other suggestions.
 

rado84

Well-Known Member
Joined
Feb 25, 2019
Messages
452
Reaction score
398
Credits
1,685
Screen tearing is an old problem with nvidia video cards. For a while there was a solution but recently it was broken, though IDK if nvidia broke it or Mozilla, or both at the same time. Still, if you wish to try it, run
Code:
# nvidia-settings
click on "X Server Display Configuration", then click the button "Advanced" and then click on both checkboxes named "Force Composition Pipeline" and "Force Full Composition Pipeline". Save settings to file, then reboot. This should fix screen tearing.
HOWEVER!!! As I said, recently that function was broken and if you're using either GNOME or a Gnome-based desktop (such as Cinnamon, which I'm using), enabling these two options causes the flipping to disable on its own which in turn causes problems with native games - tearing in the game, VSync not working properly or not working at all (the latter is the case with ETS2).
So, if you're not playing any games, these two nvidia options should work fine for you. Well, it won't be 100% because a few years ago Mozilla screwed up their own option (Firefox's option + nvidia options used to remove tearing at 100%) for preventing screen tearing in linux but at least you won't see it that often.
 

Alexzee

Well-Known Member
Joined
Jun 1, 2019
Messages
1,998
Reaction score
962
Credits
9,842
I thought I was running Linux Lite, lol. That's what the label said it was when I downloaded the OS. I'll try the your other suggestions.
Sorry, I missed that:-
 
OP
J

Jaymz_RG1003

New Member
Joined
Nov 9, 2021
Messages
28
Reaction score
2
Credits
194
Screen tearing is an old problem with nvidia video cards. For a while there was a solution but recently it was broken, though IDK if nvidia broke it or Mozilla, or both at the same time. Still, if you wish to try it, run
Code:
# nvidia-settings
click on "X Server Display Configuration", then click the button "Advanced" and then click on both checkboxes named "Force Composition Pipeline" and "Force Full Composition Pipeline". Save settings to file, then reboot. This should fix screen tearing.
HOWEVER!!! As I said, recently that function was broken and if you're using either GNOME or a Gnome-based desktop (such as Cinnamon, which I'm using), enabling these two options causes the flipping to disable on its own which in turn causes problems with native games - tearing in the game, VSync not working properly or not working at all (the latter is the case with ETS2).
So, if you're not playing any games, these two nvidia options should work fine for you. Well, it won't be 100% because a few years ago Mozilla screwed up their own option (Firefox's option + nvidia options used to remove tearing at 100%) for preventing screen tearing in linux but at least you won't see it that often.
How do you access the NVIDIA settings? I'm a n00b with Linux, lol.
 

rado84

Well-Known Member
Joined
Feb 25, 2019
Messages
452
Reaction score
398
Credits
1,685
I tried it in Terminal, but nothing happened. Was that what I was supposed to do?
How hard can it be to type "sudo nvidia-settings"? If nothing happens, that means you don't have the proprietary nvidia driver installed.
 
OP
J

Jaymz_RG1003

New Member
Joined
Nov 9, 2021
Messages
28
Reaction score
2
Credits
194
How hard can it be to type "sudo nvidia-settings"? If nothing happens, that means you don't have the proprietary nvidia driver installed.
Ok, can you not reply anymore?

You seem to be getting rude now. I said I was new at Linux, so sorry if I wasn't sure where to type that. I appreciate the suggestions, but I'd rather chat with someone with a little more patience.
 
Last edited:
OP
J

Jaymz_RG1003

New Member
Joined
Nov 9, 2021
Messages
28
Reaction score
2
Credits
194
So I might just get a new desktop. It's time, lol. After researching this problem elsewhere online, I know to avoid any desktop with Nvidia graphics cards.

With that being said, what brand of graphics cards should I look for in a desktop? I heard AMD works really well with Linux OS.
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
3,880
Reaction score
2,622
Credits
28,033
When you open nvidia-settings is "Force Full Composition Pipeline" still checked as shown in the image below?
ZUko2.png
 
OP
J

Jaymz_RG1003

New Member
Joined
Nov 9, 2021
Messages
28
Reaction score
2
Credits
194
When you open nvidia-settings is "Force Full Composition Pipeline" still checked as shown in the image below?
ZUko2.png
Unfortunately, I can't open nvidia-settings because my desktop is using a Linux driver; not Nvidia's proprietary driver.

Here's a screenshot:
 

Attachments

  • Screenshot_2021-11-11_14-09-46.png
    Screenshot_2021-11-11_14-09-46.png
    27.8 KB · Views: 31

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
3,880
Reaction score
2,622
Credits
28,033
I looked the driver on nvidia.com for a "6150SE nForce 430" in list of Operating systems Linux isn't even mentioned so it seems they didn't even have a Linux driver for those cards back then. So you're only option is to use the Nouveau drivers. Old Nvidia cards are a problem on Linux so even more for a card from around 2004. Do you know if you are using Wayland or Xorg?
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Top